Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034057
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2016-09-22 13:132016-12-16 18:38
ReporternataliagView Statuspublic 
Assigned ToNaroaIriarte 
PriorityhighResolutionfixedFixed in Version3.0PR17Q1
StatusclosedFix in branchFixed in SCM revision23168c38ed78
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0034057: Wrong Tabulation Order in form fields in Organization window

DescriptionWhen you try to use tabulation in the Organization window using the form view and starting in "Search Key" field instead of jumping to next field(Name), it goes to the tab below (Information).
Steps To Reproduce1- Login in the application and go to "Organization" window.
2- Select one of the records and open it using the "click to open the record in a form" button.
3- Press tab button. The tab focus disappears.
4- Press again tab button. Now the tabulator is in the lower tab,"Information".
5- Pressing again the tab button, it returns up, to the "Name" field.
6- If you continue tabulating, in the rest of fields it goes well until pressing the tab button after the tabulator being in audit section. Then there are some strange behaviors again.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0034051 closedNaroaIriarte Wrong Tabulation Order in form fields 
related to defect 0021380 closedalostale When the first focus field is a drop down list, the content of the field should be selected 
related to defect 0021381 closeddbaz Focus is lost after a record is saved in form view, resulting in incorrect operation of keyboards 
related to defect 0021420 closeddbaz [KS] CTRL+O does not consistently work 
related to defect 00223903.0MP19 closedAugustoMauch Tab key does not work correctly in grid view 
related to defect 00221233.0MP20 closedAugustoMauch UI looses focus when entering filter in grid mode 
related to defect 0030401 acknowledgedplatform Tab Key looses focus in GL Item 
related to defect 00213073.0MP15 closeddbaz The focus oes not move for the following field from a field using a column with text reference 
related to defect 00282313.0PR15Q2 closedAugustoMauch Focus is placed automatically on the last field under some circumnstances 
related to defect 00283963.0PR15Q2 closedAugustoMauch Focus is placed automatically on the field group (if any) having all the fields in read only mode 
related to defect 0029687 closeddbaz Is not possible to set the hour 12 in DateTime fields 
related to defect 00229033.0MP21 closedAugustoMauch Focus is lost when changing the images in Client window 
related to defect 0031705 closedcaristu a date used to filter on a grid dissapears after enter it 

-  Notes
(0090181)
caristu (developer)
2016-09-23 08:32
edited on: 2016-10-21 12:14

Note that in this case the behavior regarding the first focused field when opening a record in form view using the "click to open the record in a form" button is different from the behavior when using a double-click: when using double-click the first focused element is the field where we made the double click.

For this reason, if we open the record in form view using double-click and clicking on the description field the problem is not reproducible, because the tabIndex assigned to this field is higher than the tabIndex assigned to the child tab element.

Nevertheless, by opening the record with "click to open the record in a form" or double-clicking on the search key field the problem can be reproduced as the tabIndex assigned to that field is the same as the one assigned to the child tab element.

(0090762)
NaroaIriarte (developer)
2016-10-21 12:52

The fix of this issue is now pushed to try.
(0090804)
hgbot (developer)
2016-10-24 09:38

Repository: erp/devel/pi
Changeset: 23168c38ed78f1cec09e30577356cfe1ae79193c
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Fri Oct 21 12:25:34 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/23168c38ed78f1cec09e30577356cfe1ae79193c [^]

Fixed issue 34057: The focus' behavior was not the expected.

In some windows, in form view, the focus was not working fine when using the tab key. In some cases the focus was jumping from a field to the child tab bar instead to the following focusable field, and after, to the field.

The problem was that the tabIndex of the child tab bar was the same than the tabIndex of the field which was expected to be focused.
This is caused because the tabIndex of the child tab bar is not being updated when the formitems are created, and that is the reason because the tabIndexes are overlapped.

To fix this, the "prepareViewForm" of the "ob-standard-view" class has been modified, now it forces to update the child tab bar tabIndex and it gives to it a higher value than the values of the tabIndexes of the parent elements.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0090809)
hgbot (developer)
2016-10-24 11:09

Repository: erp/devel/pi
Changeset: 25c6ca652d57d9b0feccb1fac1e841620a8d522f
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Mon Oct 24 11:08:32 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/25c6ca652d57d9b0feccb1fac1e841620a8d522f [^]

Related to issue 34057: The comment has been improved.

The comment has been improved to be clearer.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0090977)
alostale (developer)
2016-10-28 09:23

code reviewed

tested both in form and grid views
(0092549)
hudsonbot (developer)
2016-12-16 18:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/dc8bf00badd0 [^]
Maturity status: Test
(0092550)
hudsonbot (developer)
2016-12-16 18:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/dc8bf00badd0 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-09-22 13:13 nataliag New Issue
2016-09-22 13:13 nataliag Assigned To => platform
2016-09-22 13:13 nataliag Modules => Core
2016-09-22 13:13 nataliag Triggers an Emergency Pack => No
2016-09-22 13:15 nataliag Relationship added related to 0034051
2016-09-23 08:32 caristu Note Added: 0090181
2016-09-29 09:29 alostale Status new => acknowledged
2016-10-10 11:12 egoitz Issue Monitored: egoitz
2016-10-13 11:56 NaroaIriarte Status acknowledged => scheduled
2016-10-13 11:56 NaroaIriarte Assigned To platform => NaroaIriarte
2016-10-20 18:12 caristu Note Edited: 0090181 View Revisions
2016-10-20 18:12 caristu Note Edited: 0090181 View Revisions
2016-10-21 12:14 caristu Note Edited: 0090181 View Revisions
2016-10-21 12:52 NaroaIriarte Note Added: 0090762
2016-10-24 09:17 NaroaIriarte Relationship added related to 0021380
2016-10-24 09:17 NaroaIriarte Relationship added related to 0021381
2016-10-24 09:18 NaroaIriarte Relationship added related to 0021420
2016-10-24 09:20 NaroaIriarte Relationship added related to 0022390
2016-10-24 09:31 NaroaIriarte Relationship added related to 0022123
2016-10-24 09:38 hgbot Checkin
2016-10-24 09:38 hgbot Note Added: 0090804
2016-10-24 09:38 hgbot Status scheduled => resolved
2016-10-24 09:38 hgbot Resolution open => fixed
2016-10-24 09:38 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/23168c38ed78f1cec09e30577356cfe1ae79193c [^]
2016-10-24 09:48 NaroaIriarte Relationship added related to 0030401
2016-10-24 09:52 NaroaIriarte Relationship added related to 0021307
2016-10-24 10:06 NaroaIriarte Relationship added related to 0028231
2016-10-24 10:07 NaroaIriarte Relationship added related to 0028396
2016-10-24 10:08 NaroaIriarte Relationship added related to 0029687
2016-10-24 10:13 NaroaIriarte Relationship added related to 0022903
2016-10-24 10:18 NaroaIriarte Relationship added related to 0031705
2016-10-24 11:09 hgbot Checkin
2016-10-24 11:09 hgbot Note Added: 0090809
2016-10-24 11:45 NaroaIriarte Review Assigned To => alostale
2016-10-28 09:23 alostale Note Added: 0090977
2016-10-28 09:23 alostale Status resolved => closed
2016-10-28 09:23 alostale Fixed in Version => 3.0PR17Q1
2016-12-16 18:38 hudsonbot Checkin
2016-12-16 18:38 hudsonbot Note Added: 0092549
2016-12-16 18:38 hudsonbot Checkin
2016-12-16 18:38 hudsonbot Note Added: 0092550


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker