Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034051
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2016-09-22 11:032016-12-16 18:39
ReporternataliagView Statuspublic 
Assigned ToNaroaIriarte 
PriorityhighResolutionfixedFixed in Version3.0PR17Q1
StatusclosedFix in branchFixed in SCM revisiona7f3c703cb83
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0034051: Wrong Tabulation Order in form fields

DescriptionTabulation in form views seems to prioritize fields of type image and jump to this type of fields instead of following the pertinent order.
Steps To Reproduce1- Login in the application and go to "User" window.
2- Select one of the records and open it in record form.
3- Open the "More Information" section and close the record.
4- Open again the last record in record form, now the "more information" section should appear open.
5- Tabulator is in "Name" field. Press once tab button and it changes to "Username" field.
6- Press again tabulator and you can see that it disappears. If you press enter button the image field is opened(tabulator has jump from "Username" field to "Image" field in the "More information" section).
7- Close the image popup and press tab button again. Now it returns to "First Name" field. The correct order of fields should have been: Name->Username->First Name.... But is has been: Name->Username->Image->First Name...
8- Now if you continue tabulating the order of the rest of fields is ok.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0034658 closedinigosanchez The focus is lost when navigating through the "Product" window with the tab key. 
related to defect 0034057 closedNaroaIriarte Wrong Tabulation Order in form fields in Organization window 

-  Notes
(0090180)
caristu (developer)
2016-09-23 08:26
edited on: 2016-09-23 08:37

After tabulating on "Username" field, the focus is acquired not by the Image field but by the upload button of the field itself.

This is happening because this button has a tabIndex which is between the tabIndex values of the Username field and the Firstname field.

The solution for this issue must set the tabIndex value properly for the button.

(0091815)
hgbot (developer)
2016-11-25 09:51

Repository: erp/devel/pi
Changeset: a7f3c703cb83b402be682c7626b87c3c005a61ee
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Thu Nov 24 16:01:47 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/a7f3c703cb83b402be682c7626b87c3c005a61ee [^]

Fixed issue 34051: The tab key was not focusing properly in some circumstances

The fields were not correctly focused when using the tab key. If there was an image in the form, the focus was jumping to it when it was supposed not to.
The problems seems to be in the canvas item. The tab index was not being properly set.
To fix this the "ob-formitem-image.js" has been modifyed, now, the "canFocus" property has been set to true for the image canvas.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-image.js
---
(0091822)
alostale (developer)
2016-11-25 10:55

code reviewed
Tested: now the focus moves correctly and it is possible to set it in icon to upload new images
(0092658)
hudsonbot (developer)
2016-12-16 18:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/dc8bf00badd0 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-09-22 11:03 nataliag New Issue
2016-09-22 11:03 nataliag Assigned To => platform
2016-09-22 11:03 nataliag Modules => Core
2016-09-22 11:03 nataliag Triggers an Emergency Pack => No
2016-09-22 13:15 nataliag Relationship added related to 0034057
2016-09-23 08:26 caristu Note Added: 0090180
2016-09-23 08:37 caristu Note Edited: 0090180 View Revisions
2016-09-23 08:37 caristu Note Edited: 0090180 View Revisions
2016-09-29 09:30 alostale Status new => acknowledged
2016-11-15 15:24 heccam Issue Monitored: heccam
2016-11-22 15:47 NaroaIriarte Assigned To platform => NaroaIriarte
2016-11-22 15:47 NaroaIriarte Status acknowledged => scheduled
2016-11-25 09:51 hgbot Checkin
2016-11-25 09:51 hgbot Note Added: 0091815
2016-11-25 09:51 hgbot Status scheduled => resolved
2016-11-25 09:51 hgbot Resolution open => fixed
2016-11-25 09:51 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a7f3c703cb83b402be682c7626b87c3c005a61ee [^]
2016-11-25 09:58 NaroaIriarte Review Assigned To => alostale
2016-11-25 10:55 alostale Note Added: 0091822
2016-11-25 10:55 alostale Status resolved => closed
2016-11-25 10:55 alostale Fixed in Version => 3.0PR17Q1
2016-11-30 17:35 NaroaIriarte Relationship added related to 0034658
2016-12-16 18:39 hudsonbot Checkin
2016-12-16 18:39 hudsonbot Note Added: 0092658


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker