Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0021420
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfacemajoralways2012-08-22 20:512016-10-24 09:18
ReporterpjuvaraView Statuspublic 
Assigned Todbaz 
PrioritynormalResolutionfixedFixed in Version3.0MP15
StatusclosedFix in branchpiFixed in SCM revisionb7143de1a15c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP12.1SCM revision 
Review Assigned Tomtaal
Web browserGoogle Chrome
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2011-09-27
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/7d3eaa3a17c45de0256302f2bee25b8984e722fc [^]
Triggers an Emergency PackNo
Summary

0021420: [KS] CTRL+O does not consistently work

DescriptionCTRL+O is supposed to open the launcher.

It does not consistently work in the application. It seems that when you perform some actions, you loose focus and when you do CTRL+O opens the browser Open File dialog instead.
Steps To ReproduceAn example of when this happens.

Environment: Ubuntu 12.04 + Chrome 21.
In any window, edit an existing record in grid mode. Press CTRL+S to save.
Now press CTRL+O.

The save action "lost" the focus.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0034057 closedNaroaIriarte Wrong Tabulation Order in form fields in Organization window 
has duplicate defect 0021381 closeddbaz Focus is lost after a record is saved in form view, resulting in incorrect operation of keyboards 
related to defect 0021546 closedAugustoMauch Regression in Form view when saving a record 

-  Notes
(0051660)
dbaz (developer)
2012-08-30 02:43

The problem root is that the focus is lost once the "Save" button action is done (it can be reproduced using the mouse or the keyboard)
(0051717)
dbaz (developer)
2012-08-31 22:24

The problem is that before the regression commit, the previous focused item was stored:

https://code.openbravo.com/erp/devel/pi/rev/7d3eaa3a17c45de0256302f2bee25b8984e722fc#l1.201 [^]

and then in the save callback it was restored

https://code.openbravo.com/erp/devel/pi/rev/7d3eaa3a17c45de0256302f2bee25b8984e722fc#l1.210 [^]

This logic was using "storeFocusItem" and "restoreFocusItem" that also don't exist anymore:

https://code.openbravo.com/erp/devel/pi/rev/7d3eaa3a17c45de0256302f2bee25b8984e722fc#l1.263 [^]


In the fix a simplified version of this code is going to be introduced in order to recover the logic.

The fix risk is medium, and should be supervised by Martin Taal
(0051718)
hgbot (developer)
2012-08-31 22:27

Repository: erp/devel/pi
Changeset: 2e55c0d0da0d133a538c77b6380340f7b4de53c8
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Fri Aug 31 22:27:11 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/2e55c0d0da0d133a538c77b6380340f7b4de53c8 [^]

Fixed issue 21420: focus is set back in the form view after save action

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
---
(0051755)
mtaal (developer)
2012-09-03 07:05

Reviewed
(0051793)
mtaal (developer)
2012-09-04 06:57

I have seen the following behavior:

Go to message window
Do new in form
Enter a search key
Enter a value in the message text
Do ctrl-S

The record gets saved but the value in the message text is cleared. Note that pressing the save button works, so only the shortcut seems to give the problem.
(0051814)
hgbot (developer)
2012-09-04 13:10

Repository: erp/devel/pi
Changeset: 5492d5749d01b2fc25ba399063be8f3e78abf5c4
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Tue Sep 04 13:09:31 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5492d5749d01b2fc25ba399063be8f3e78abf5c4 [^]

Related to issue 21420: 'saveRow' focus logic is now more solid

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
---
(0051816)
dbaz (developer)
2012-09-04 13:23

I cannot reproduce the test case provided by mtaal. Anyway, I have pushed an improvement to the fix, but it has nothing to see with the behavior that mtaal points.
(0051819)
mtaal (developer)
2012-09-04 15:37

Reviewed
(0052646)
hgbot (developer)
2012-09-26 17:14

Repository: erp/devel/pi
Changeset: b7143de1a15ca6eabe66ee61d27695cec62df17b
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Fri Aug 31 22:27:11 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b7143de1a15ca6eabe66ee61d27695cec62df17b [^]

Fixed issue 21420: focus is set back in the form view after save action

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
---
(0052647)
hgbot (developer)
2012-09-26 17:14

Repository: erp/devel/pi
Changeset: 271836623f04a24d26dd6669d77813aba88e51b7
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Tue Sep 04 13:09:31 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/271836623f04a24d26dd6669d77813aba88e51b7 [^]

Related to issue 21420: 'saveRow' focus logic is now more solid

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
---
(0052667)
hudsonbot (developer)
2012-09-26 17:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b780e90c6452 [^]

Maturity status: Test
(0052676)
hudsonbot (developer)
2012-09-26 17:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b780e90c6452 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-08-22 20:51 pjuvara New Issue
2012-08-22 20:51 pjuvara Assigned To => dbaz
2012-08-22 20:51 pjuvara Web browser => Google Chrome
2012-08-22 20:51 pjuvara Modules => Core
2012-08-30 02:43 dbaz Note Added: 0051660
2012-08-31 22:24 dbaz Closed by => mtaal
2012-08-31 22:24 dbaz Web browser Google Chrome => Google Chrome
2012-08-31 22:24 dbaz Regression level => Production - Confirmed Stable
2012-08-31 22:24 dbaz Regression date => 2011-09-27
2012-08-31 22:24 dbaz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/7d3eaa3a17c45de0256302f2bee25b8984e722fc [^]
2012-08-31 22:24 dbaz Note Added: 0051717
2012-08-31 22:27 hgbot Checkin
2012-08-31 22:27 hgbot Note Added: 0051718
2012-08-31 22:27 hgbot Status new => resolved
2012-08-31 22:27 hgbot Resolution open => fixed
2012-08-31 22:27 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2e55c0d0da0d133a538c77b6380340f7b4de53c8 [^]
2012-09-03 07:05 mtaal Note Added: 0051755
2012-09-03 07:05 mtaal Status resolved => closed
2012-09-03 07:05 mtaal Fixed in Version => 3.0MP15
2012-09-04 06:57 mtaal Note Added: 0051793
2012-09-04 06:57 mtaal Status closed => new
2012-09-04 06:57 mtaal Resolution fixed => open
2012-09-04 06:57 mtaal Fixed in Version 3.0MP15 =>
2012-09-04 13:10 hgbot Checkin
2012-09-04 13:10 hgbot Note Added: 0051814
2012-09-04 13:21 dbaz Status new => scheduled
2012-09-04 13:21 dbaz fix_in_branch => pi
2012-09-04 13:21 dbaz Status scheduled => resolved
2012-09-04 13:21 dbaz Resolution open => fixed
2012-09-04 13:23 dbaz Note Added: 0051816
2012-09-04 15:14 AugustoMauch Relationship added related to 0021546
2012-09-04 15:37 mtaal Note Added: 0051819
2012-09-04 15:37 mtaal Status resolved => closed
2012-09-04 15:37 mtaal Fixed in Version => 3.0MP15
2012-09-05 11:11 dbaz Relationship added has duplicate 0021381
2012-09-26 17:14 hgbot Checkin
2012-09-26 17:14 hgbot Note Added: 0052646
2012-09-26 17:14 hgbot Status closed => resolved
2012-09-26 17:14 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/2e55c0d0da0d133a538c77b6380340f7b4de53c8 [^] => http://code.openbravo.com/erp/devel/pi/rev/b7143de1a15ca6eabe66ee61d27695cec62df17b [^]
2012-09-26 17:14 hgbot Checkin
2012-09-26 17:14 hgbot Note Added: 0052647
2012-09-26 17:17 hudsonbot Checkin
2012-09-26 17:17 hudsonbot Note Added: 0052667
2012-09-26 17:18 hudsonbot Checkin
2012-09-26 17:18 hudsonbot Note Added: 0052676
2012-09-26 17:27 gorka_gil Status resolved => closed
2016-10-24 09:18 NaroaIriarte Relationship added related to 0034057


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker