Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029687
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminoralways2015-04-23 19:352016-10-24 10:08
ReportercaristuView Statuspublic 
Assigned Todbaz 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revisionbaf06c383c41
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-05-15
Regression introduced in release3.0PR14Q3
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/43e598987eb706d4eac832d474b84a1d0b7ac958 [^]
Triggers an Emergency PackNo
Summary

0029687: Is not possible to set the hour 12 in DateTime fields

DescriptionIs not possible to set the hour 12 in DateTime fields, it is always being converted to 0 when the field loses the focus.
Steps To Reproduce1) Go to the Work Effort window and create a new record in the header
2) Navigate to the Production Run tab
3) In the Starting Time field, type date and a hour with 12 for example: 04-23-2015 12:26:05
4) Move to another field. Notice that the Starting Time is changed to 04-23-2015 00:26:05
Proposed SolutionThe parseEditorValue method uses the OB.Utilities.Date.OBToJS which is doing this conversion waiting for a PM indicator. As this indicator is not included it then makes the replacement.
TagsNo tags attached.
Attached Filesdiff file icon fix29687.diff [^] (1,322 bytes) 2015-04-27 15:48 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0034057 closedNaroaIriarte Wrong Tabulation Order in form fields in Organization window 
depends on backport 00296913.0PR15Q2 closeddbaz Is not possible to set the hour 12 in DateTime fields 
depends on backport 00296923.0PR15Q1.4 closeddbaz Is not possible to set the hour 12 in DateTime fields 
caused by feature request 00259363.0PR14Q3 closeddbaz DateTime reference format support hh:mm:ss a 

-  Notes
(0076822)
hgbot (developer)
2015-04-28 12:15

Repository: erp/devel/pi
Changeset: baf06c383c41ca564846d1d7e0ccd21f157f2c55
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Tue Apr 28 12:07:49 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/baf06c383c41ca564846d1d7e0ccd21f157f2c55 [^]

Fixed issue 29687: DateTime now works ok with 12:XX:XX times

The root of the problem was that there was a 'typo' and the
'minus' sign was missing in the 'if' statement in charge
of evaluate if it was in 24h mode or not. This was used later
to substract 12h to the entered date if this was in the
12:XX:XX form, change that obviously doesn't apply in the
24h mode

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities-date.js
---
(0076847)
alostale (developer)
2015-04-29 09:30

code reviewed

tested with 12 and 24 hour time format in grid and form views
(0076878)
hgbot (developer)
2015-04-29 16:25

Repository: erp/devel/pi
Changeset: 85224ff98fb5e4cb434ae5107a50df3b6ba02d0d
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Wed Apr 29 16:24:29 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/85224ff98fb5e4cb434ae5107a50df3b6ba02d0d [^]

Related to issue 29687: Added QUnit test cases

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/test/ob-utilities-date-test.js
---
(0076884)
hgbot (developer)
2015-04-29 18:22

Repository: erp/devel/pi
Changeset: 7c3c564c85918a61bbb4a22574303d3cb89772c3
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Wed Apr 29 18:21:34 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/7c3c564c85918a61bbb4a22574303d3cb89772c3 [^]

Related to issue 29687: Added QUnit test cases - Fixed JSLint problem

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/test/ob-utilities-date-test.js
---
(0077173)
hudsonbot (developer)
2015-05-07 22:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test
(0077184)
hudsonbot (developer)
2015-05-07 22:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test
(0077187)
hudsonbot (developer)
2015-05-07 22:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-04-23 19:35 caristu New Issue
2015-04-23 19:35 caristu Assigned To => platform
2015-04-23 19:35 caristu Modules => Core
2015-04-23 19:35 caristu Triggers an Emergency Pack => No
2015-04-23 19:36 caristu Issue Monitored: networkb
2015-04-24 08:36 alostale Relationship added related to 0025936
2015-04-24 08:36 alostale Status new => acknowledged
2015-04-24 11:36 alostale Relationship replaced caused by 0025936
2015-04-24 11:40 alostale Regression level => Production - Confirmed Stable
2015-04-24 11:40 alostale Regression date => 2014-05-15
2015-04-24 11:40 alostale Regression introduced in release => 3.0PR14Q3
2015-04-24 11:40 alostale Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/43e598987eb706d4eac832d474b84a1d0b7ac958 [^]
2015-04-24 11:40 alostale Assigned To platform => dbaz
2015-04-24 11:40 alostale Priority normal => immediate
2015-04-24 11:40 alostale Severity major => minor
2015-04-24 11:43 alostale Status acknowledged => scheduled
2015-04-27 15:48 dbaz File Added: fix29687.diff
2015-04-28 12:15 dbaz Review Assigned To => alostale
2015-04-28 12:15 hgbot Checkin
2015-04-28 12:15 hgbot Note Added: 0076822
2015-04-28 12:15 hgbot Status scheduled => resolved
2015-04-28 12:15 hgbot Resolution open => fixed
2015-04-28 12:15 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/baf06c383c41ca564846d1d7e0ccd21f157f2c55 [^]
2015-04-29 09:30 alostale Note Added: 0076847
2015-04-29 09:30 alostale Status resolved => closed
2015-04-29 09:30 alostale Fixed in Version => 3.0PR15Q3
2015-04-29 16:25 hgbot Checkin
2015-04-29 16:25 hgbot Note Added: 0076878
2015-04-29 18:22 hgbot Checkin
2015-04-29 18:22 hgbot Note Added: 0076884
2015-05-07 22:17 hudsonbot Checkin
2015-05-07 22:17 hudsonbot Note Added: 0077173
2015-05-07 22:17 hudsonbot Checkin
2015-05-07 22:17 hudsonbot Note Added: 0077184
2015-05-07 22:17 hudsonbot Checkin
2015-05-07 22:17 hudsonbot Note Added: 0077187
2016-10-24 10:08 NaroaIriarte Relationship added related to 0034057


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker