Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031705
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2015-12-14 18:282016-10-24 10:18
ReporteregoitzView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q1
StatusclosedFix in branchFixed in SCM revisiond85f65dd5246
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2015-04-22
Regression introduced in release3.0PR15Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/b1614f4301585bb0f8affbf5cf53f451dd284851 [^]
Triggers an Emergency PackNo
Summary

0031705: a date used to filter on a grid dissapears after enter it

DescriptionWhen you write a date on the filter of a grid, after loss the focus, the value entered is removed, but the filter works properly
Steps To Reproduce-Go to sales order window with date 14-12-2015
-Remove all the filter on grid view
-Filter on the order date field by writing.
1412
-Then press tab key to change to next column
*The value entered is removed but the filter works properly
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0034057 closedNaroaIriarte Wrong Tabulation Order in form fields in Organization window 
depends on backport 00317213.0PR15Q4.2 closedcaristu a date used to filter on a grid dissapears after enter it 
depends on backport 00317223.0PR15Q3.5 closedcaristu a date used to filter on a grid dissapears after enter it 
caused by defect 00295543.0PR15Q3 closedcaristu Date filters are not cleared when switching between saved views 
has duplicate defect 00317133.0PR16Q1 closedplatform Date value not maintained in grid when used to filter, while string values are maintained 
causes defect 0032474 closedcaristu '[object Object]' instead of blank value after clearing value in selector 

-  Notes
(0082764)
caristu (developer)
2015-12-15 13:32
edited on: 2015-12-15 18:42

The date is cleared because of since changeset[1] the date filters clear all its content on their clearValue() function.

The problem is caused because after clicking on the enter or tab button the date filter value is not recovered because the value is not being set accordingly.

[1] https://code.openbravo.com/erp/devel/pi/rev/b1614f4301585bb0f8affbf5cf53f451dd284851 [^]

(0082784)
hgbot (developer)
2015-12-15 19:00

Repository: erp/devel/pi
Changeset: d85f65dd5246e3189c45b0b1a202340c930bade9
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Dec 15 18:59:05 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/d85f65dd5246e3189c45b0b1a202340c930bade9 [^]

fixes issue 31705: a date used to filter on a grid dissapears after enter it

After solving issue 29554 the values of the date filters are completely removed when invoking the clearValue() method. For this reason, in order to prevent the clearing of the date filter it is necessary to call setValue().

This was already controlled when choosing the dates from the date pickers, but not after entering the date with the tab or enter keys or when using the 'Use as Filter' menu option.

Now this cases are controlled also, by calling setValue() on the setSingleDateValue() method.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-minidaterange.js
---
(0082793)
hgbot (developer)
2015-12-16 09:07

Repository: erp/devel/pi
Changeset: 17016914f029b502a391792438ec40750d2b95cd
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Dec 16 09:05:20 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/17016914f029b502a391792438ec40750d2b95cd [^]

related to issue 31705: do not set singleDateMode after clearing filter values

The singleDateMode should not be set to true when clearing the filter values because this is preventing the date range dialog to appear under some circumnstances.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-minidaterange.js
---
(0082809)
alostale (developer)
2015-12-17 08:29

code reviewed

Tested:

 1. Adding date filter by typing (as described in this issue)
 2. Adding date filter by right click in date field to "Use as filter" (as described in 0031713)
 3. Using date filters in saved views (see 0029554)
 4. Getting direct link for a grid filtered by date with set by all the 3 ways defined above
(0082837)
caristu (developer)
2015-12-17 16:00
edited on: 2015-12-17 16:00

An automated test has been created to cover the scenario of this issue. It has been added into TestLink also: https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-9979 [^]

(0082844)
hudsonbot (developer)
2015-12-17 17:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7bb1cbcee3ce [^]
Maturity status: Test
(0082846)
hudsonbot (developer)
2015-12-17 17:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7bb1cbcee3ce [^]
Maturity status: Test
(0083830)
hgbot (developer)
2016-02-02 09:43

Repository: tools/automation/int
Changeset: e5f9606e5f846bddbb37676b9e0a118bb09b41c2
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Dec 16 14:07:29 2015 +0100
URL: http://code.openbravo.com/tools/automation/int/rev/e5f9606e5f846bddbb37676b9e0a118bb09b41c2 [^]

added automated test for issue 31705

---
M src-test/com/openbravo/test/integration/erp/modules/client/application/gui/GeneratedTab.java
M src-test/com/openbravo/test/integration/erp/modules/client/application/gui/OBGrid.java
M src-test/com/openbravo/test/integration/erp/modules/client/application/gui/OBStandardView.java
A src-test/com/openbravo/test/integration/erp/modules/client/application/testscripts/standardview/grid/DateFilterPersistsAfterPressingTabKey.java
---
(0083831)
hgbot (developer)
2016-02-02 09:43

Repository: tools/automation/int
Changeset: 9e4f70bc7b145a07138a84764448bd31fdec958c
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Dec 17 13:08:57 2015 +0100
URL: http://code.openbravo.com/tools/automation/int/rev/9e4f70bc7b145a07138a84764448bd31fdec958c [^]

add automated test for issue 31705 into a test suite

---
M src-test/com/openbravo/test/integration/erp/modules/client/application/testsuites/standardview/grid/GridSuite.java
M src-test/com/openbravo/test/integration/erp/modules/client/application/testsuites/standardview/grid/build.xml
A src-test/com/openbravo/test/integration/erp/modules/client/application/testsuites/standardview/grid/GFI001_DateFilterPersistsAfterPressingKey.java
R src-test/com/openbravo/test/integration/erp/modules/client/application/testscripts/standardview/grid/DateFilterPersistsAfterPressingTabKey.java
---
(0084996)
hgbot (developer)
2016-03-15 19:13

Repository: erp/devel/pi
Changeset: 330cd48c5a70635408ead8b3fbfc72659ed18f52
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Mar 15 19:12:36 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/330cd48c5a70635408ead8b3fbfc72659ed18f52 [^]

fixes issue 32474: [object Object] appears after clearing value in selector

Having singleDateMode as false after clearing the filter content of the date causes the return of an empty object in the getValuesAsCriteria method of the grid. The this.singleDateMode was being set to true in clearFilterValues function, but this statement was deleted to solve issue 31705, because it was preventing to show the range dialog after clearing the filters, when pressing the Enter key.

To solve both problems the change regarding setting singleDateMode in clearFilterValues has been reverted, and in order to ensure that the range dialog is displayed when it should be, a new check has been included in the keyPress method.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-minidaterange.js
---
(0085001)
hgbot (developer)
2016-03-16 11:55

Repository: erp/backports/3.0PR16Q1.1
Changeset: 5ae13dc119e9fd18489af9f8bed42a4aea9b1991
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Mar 16 11:55:00 2016 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR16Q1.1/rev/5ae13dc119e9fd18489af9f8bed42a4aea9b1991 [^]

fixes issue 32477: [object Object] appears after clearing value in selector

Having singleDateMode as false after clearing the filter content of the date causes the return of an empty object in the getValuesAsCriteria method of the grid. The this.singleDateMode was being set to true in clearFilterValues function, but this statement was deleted to solve issue 31705, because it was preventing to show the range dialog after clearing the filters, when pressing the Enter key.

To solve both problems the change regarding setting singleDateMode in clearFilterValues has been reverted, and in order to ensure that the range dialog is displayed when it should be, a new check has been included in the keyPress method.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-minidaterange.js
---
(0085004)
hgbot (developer)
2016-03-16 12:28

Repository: erp/backports/3.0PR15Q4.5
Changeset: d6a7ec729aa86b7fe2c8e29d663e4e8086177f77
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Mar 15 19:22:47 2016 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR15Q4.5/rev/d6a7ec729aa86b7fe2c8e29d663e4e8086177f77 [^]

fixes issue 32478: [object Object] appears after clearing value in selector

Having singleDateMode as false after clearing the filter content of the date causes the return of an empty object in the getValuesAsCriteria method of the grid. The this.singleDateMode was being set to true in clearFilterValues function, but this statement was deleted to solve issue 31705, because it was preventing to show the range dialog after clearing the filters, when pressing the Enter key.

To solve both problems the change regarding setting singleDateMode in clearFilterValues has been reverted, and in order to ensure that the range dialog is displayed when it should be, a new check has been included in the keyPress method.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-minidaterange.js
---
(0085199)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-12-14 18:28 egoitz New Issue
2015-12-14 18:28 egoitz Assigned To => platform
2015-12-14 18:28 egoitz Modules => Core
2015-12-14 18:28 egoitz Regression level => Production - Confirmed Stable
2015-12-14 18:28 egoitz Triggers an Emergency Pack => No
2015-12-15 11:02 alostale Regression introduced in release => 3.0PR15Q3
2015-12-15 11:03 alostale Priority normal => immediate
2015-12-15 11:03 alostale Status new => acknowledged
2015-12-15 11:04 alostale Relationship added has duplicate 0031713
2015-12-15 13:32 caristu Regression date => 2015-04-22
2015-12-15 13:32 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/b1614f4301585bb0f8affbf5cf53f451dd284851 [^]
2015-12-15 13:32 caristu Note Added: 0082764
2015-12-15 13:33 caristu Assigned To platform => caristu
2015-12-15 13:33 caristu Status acknowledged => scheduled
2015-12-15 13:59 alostale Status scheduled => acknowledged
2015-12-15 13:59 alostale Status acknowledged => scheduled
2015-12-15 14:00 alostale Relationship added caused by 0029554
2015-12-15 18:42 caristu Note Edited: 0082764 View Revisions
2015-12-15 19:00 hgbot Checkin
2015-12-15 19:00 hgbot Note Added: 0082784
2015-12-15 19:00 hgbot Status scheduled => resolved
2015-12-15 19:00 hgbot Resolution open => fixed
2015-12-15 19:00 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d85f65dd5246e3189c45b0b1a202340c930bade9 [^]
2015-12-15 19:01 caristu Review Assigned To => alostale
2015-12-15 19:01 caristu Issue Monitored: alostale
2015-12-16 09:07 hgbot Checkin
2015-12-16 09:07 hgbot Note Added: 0082793
2015-12-17 08:29 alostale Note Added: 0082809
2015-12-17 08:29 alostale Status resolved => closed
2015-12-17 08:29 alostale Fixed in Version => 3.0PR16Q1
2015-12-17 16:00 caristu Note Added: 0082837
2015-12-17 16:00 caristu Note Edited: 0082837 View Revisions
2015-12-17 17:49 hudsonbot Checkin
2015-12-17 17:49 hudsonbot Note Added: 0082844
2015-12-17 17:49 hudsonbot Checkin
2015-12-17 17:49 hudsonbot Note Added: 0082846
2016-02-02 09:43 hgbot Checkin
2016-02-02 09:43 hgbot Note Added: 0083830
2016-02-02 09:43 hgbot Checkin
2016-02-02 09:43 hgbot Note Added: 0083831
2016-03-15 10:27 caristu Relationship added causes 0032474
2016-03-15 19:13 hgbot Checkin
2016-03-15 19:13 hgbot Note Added: 0084996
2016-03-16 11:55 hgbot Checkin
2016-03-16 11:55 hgbot Note Added: 0085001
2016-03-16 12:28 hgbot Checkin
2016-03-16 12:28 hgbot Note Added: 0085004
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085199
2016-10-24 10:18 NaroaIriarte Relationship added related to 0034057


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker