Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029554
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfacemajoralways2015-04-09 17:202015-12-17 17:49
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revisionb1614f430158
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029554: Date filters are not cleared when switching between saved views

DescriptionDate filters are not cleared when switching between saved views. This can be confusing for the user.
Steps To Reproduce1) Go to the Purchase Order window
2) Remove the implicit filter and add a filter in the order date field, for example: From 09-04-2013
3) Save the view
4) Switch to the standard view, notice that the filter for the standard view has been applied properly, but the date in the order date filter has not been cleared. (See attached)
TagsNo tags attached.
Attached Filespng file icon dateFilterNotCleared.png [^] (38,492 bytes) 2015-04-09 17:43

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0029661 closedcaristu Dates are not cleared properly when switching between saved views that contains a filter on the same date field 
causes defect 0031705 closedcaristu a date used to filter on a grid dissapears after enter it 

-  Notes
(0076684)
hgbot (developer)
2015-04-22 10:47

Repository: erp/devel/pi
Changeset: b1614f4301585bb0f8affbf5cf53f451dd284851
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Apr 22 10:46:09 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b1614f4301585bb0f8affbf5cf53f451dd284851 [^]

fixes issue 29554: Date filters not cleared when switching between saved views

The problem was that the clearValue() method of FormItem is not enough to clear the contents of the filter.
To solve it the clearValue method of OBMiniDateRangeItem has been overriden.
Also, it was necessary to call setValue() inside the displayValue() method, to set the value of the object and avoid the clearing of the dates in the filter when smartclient invokes the setItemValues() method of the form.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-minidaterange.js
---
(0076754)
alostale (developer)
2015-04-24 14:10

code reviewed

Tested by switching from:
- saved view to standard
- standard to saved
- setting a default view different than standard
(0077141)
hudsonbot (developer)
2015-05-07 22:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test
(0082845)
hudsonbot (developer)
2015-12-17 17:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7bb1cbcee3ce [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-04-09 17:20 caristu New Issue
2015-04-09 17:20 caristu Assigned To => platform
2015-04-09 17:20 caristu Modules => Core
2015-04-09 17:20 caristu Triggers an Emergency Pack => No
2015-04-09 17:20 caristu Issue Monitored: networkb
2015-04-09 17:43 caristu File Added: dateFilterNotCleared.png
2015-04-09 17:43 caristu File Deleted: dateFilterNotCleared.png
2015-04-09 17:43 caristu File Added: dateFilterNotCleared.png
2015-04-09 17:44 caristu Steps to Reproduce Updated View Revisions
2015-04-16 08:31 alostale Status new => acknowledged
2015-04-20 09:15 alostale Status acknowledged => scheduled
2015-04-20 09:15 alostale Assigned To platform => caristu
2015-04-22 08:49 caristu Relationship added related to 0029661
2015-04-22 10:41 caristu Review Assigned To => alostale
2015-04-22 10:41 caristu Issue Monitored: alostale
2015-04-22 10:47 hgbot Checkin
2015-04-22 10:47 hgbot Note Added: 0076684
2015-04-22 10:47 hgbot Status scheduled => resolved
2015-04-22 10:47 hgbot Resolution open => fixed
2015-04-22 10:47 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b1614f4301585bb0f8affbf5cf53f451dd284851 [^]
2015-04-24 14:10 alostale Note Added: 0076754
2015-04-24 14:10 alostale Status resolved => closed
2015-04-24 14:10 alostale Fixed in Version => 3.0PR15Q3
2015-05-07 22:16 hudsonbot Checkin
2015-05-07 22:16 hudsonbot Note Added: 0077141
2015-12-15 14:00 alostale Relationship added causes 0031705
2015-12-15 19:00 hgbot Checkin
2015-12-15 19:00 hgbot Note Added: 0082783
2015-12-16 10:13 hgbot Checkin
2015-12-16 10:13 hgbot Note Added: 0082796
2015-12-16 11:07 caristu Note Deleted: 0082796
2015-12-16 18:18 hgbot Checkin
2015-12-16 18:18 hgbot Note Added: 0082807
2015-12-16 18:28 caristu Note Deleted: 0082807
2015-12-16 18:29 caristu Note Deleted: 0082783
2015-12-17 17:49 hudsonbot Checkin
2015-12-17 17:49 hudsonbot Note Added: 0082845


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker