Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032474
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2016-03-15 10:272016-03-18 08:43
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revision330cd48c5a70
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2015-12-16
Regression introduced in release3.0PR15Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/17016914f029b502a391792438ec40750d2b95cd [^]
Triggers an Emergency PackNo
Summary

0032474: '[object Object]' instead of blank value after clearing value in selector

Description'[object Object]' instead of blank value appears after clearing value in selector
Steps To Reproduce1- Log in ERP as F&B International Group Admin.
2- Go to Financial Account window and select 'Bank - Account 1'.
3- Go to Transaction subtab and insert a new row in grid.
4- Click in magnifying glass button to add a Payment. A Payment popup is shown and Financial Account filter has the following value: 'Bank - Account 1 - USD'.
5- Clear all filters and realize that Payment Date filter has the following value: '[object Object]' instead of blank value.
Proposed SolutionIn ob-formitem-minidaterange.js, in function hasAdvancedCriteria() return always true.
    
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00324773.0PR16Q1.1 closedcaristu '[object Object]' instead of blank value after clearing value in selector 
depends on backport 00324783.0PR15Q4.5 closedcaristu '[object Object]' instead of blank value after clearing value in selector 
caused by defect 0031705 closedcaristu a date used to filter on a grid dissapears after enter it 
causes defect 00328153.0PR16Q3 closedcaristu Direct link to documents in the workspace is not working 

-  Notes
(0084997)
hgbot (developer)
2016-03-15 19:13

Repository: erp/devel/pi
Changeset: 330cd48c5a70635408ead8b3fbfc72659ed18f52
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Mar 15 19:12:36 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/330cd48c5a70635408ead8b3fbfc72659ed18f52 [^]

fixes issue 32474: [object Object] appears after clearing value in selector

Having singleDateMode as false after clearing the filter content of the date causes the return of an empty object in the getValuesAsCriteria method of the grid. The this.singleDateMode was being set to true in clearFilterValues function, but this statement was deleted to solve issue 31705, because it was preventing to show the range dialog after clearing the filters, when pressing the Enter key.

To solve both problems the change regarding setting singleDateMode in clearFilterValues has been reverted, and in order to ensure that the range dialog is displayed when it should be, a new check has been included in the keyPress method.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-minidaterange.js
---
(0084998)
caristu (developer)
2016-03-15 19:17

Created an automated test to cover this scenario: https://code.openbravo.com/tools/automation/pi-smoke-platform/rev/9df79d65a16f [^]
(0085198)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test
(0085218)
alostale (developer)
2016-03-18 08:43

code reviewed

tested also all related issues:

* 31705
* 29554
* 29661

- Issue History
Date Modified Username Field Change
2016-03-15 10:27 caristu New Issue
2016-03-15 10:27 caristu Assigned To => platform
2016-03-15 10:27 caristu Modules => Core
2016-03-15 10:27 caristu Regression level => Production - Confirmed Stable
2016-03-15 10:27 caristu Regression date => 2015-12-16
2016-03-15 10:27 caristu Regression introduced in release => 3.0PR15Q3
2016-03-15 10:27 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/17016914f029b502a391792438ec40750d2b95cd [^]
2016-03-15 10:27 caristu Triggers an Emergency Pack => No
2016-03-15 10:27 caristu Relationship added caused by 0031705
2016-03-15 11:10 caristu Status new => scheduled
2016-03-15 19:13 hgbot Checkin
2016-03-15 19:13 hgbot Note Added: 0084997
2016-03-15 19:13 hgbot Status scheduled => resolved
2016-03-15 19:13 hgbot Resolution open => fixed
2016-03-15 19:13 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/330cd48c5a70635408ead8b3fbfc72659ed18f52 [^]
2016-03-15 19:17 caristu Note Added: 0084998
2016-03-15 19:23 caristu Review Assigned To => alostale
2016-03-15 19:23 caristu Issue Monitored: alostale
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085198
2016-03-18 08:18 alostale Assigned To platform => caristu
2016-03-18 08:43 alostale Note Added: 0085218
2016-03-18 08:43 alostale Status resolved => closed
2016-03-18 08:43 alostale Fixed in Version => 3.0PR16Q2
2016-06-09 17:45 caristu Relationship added causes 0032815


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker