Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032815
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2016-04-29 15:002016-06-21 07:47
ReporterJONHMView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q3
StatusclosedFix in branchFixed in SCM revision8ec5b7456fa1
ProjectionnoneETAnoneTarget Version3.0PR16Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toalostale
Web browserGoogle Chrome
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2016-03-15
Regression introduced in release3.0PR15Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/330cd48c5a70635408ead8b3fbfc72659ed18f52 [^]
Triggers an Emergency PackNo
Summary

0032815: Direct link to documents in the workspace is not working

DescriptionDirect link to documents in the workspace is not working when first field in grid is of "Date" type. The result is a blank document.
Steps To Reproduce== First Way ==

**First you need an activated instance to make changes effective in window.
* Navigate to Sales Order window, set the first column of grid view as a "Date" type
* Rebuild the application

1) Create a new Sales Order
2) Return to Workspace and click the direct link to that document

The result is a blank window. See the attached video


== Second Way ==
Configuration Steps:
a) Add the Invoices to Collect widget into the workspace
b) Create a saved view in Sales Invoice window, with "Invoice Date" field at the first position. Set this view as default.

Steps To Reproduce:
1) Open the [Sales Invoice] window
2) Move to the Workspace. Click on any document number of the Invoice to Collect widget.
TagsNo tags attached.
Attached Files? file icon ErrorLinkedItem.mp4 [^] (1,863,988 bytes) 2016-04-29 15:00

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00216973.0MP17 closedAugustoMauch Filtering columns behaviour is not consistent for dates and prices 
depends on backport 00332083.0PR16Q2.1 closedcaristu Direct link to documents in the workspace is not working 
depends on backport 00332093.0PR16Q1.4 closedcaristu Direct link to documents in the workspace is not working 
caused by defect 0032474 closedcaristu '[object Object]' instead of blank value after clearing value in selector 
related to defect 00332043.0PR16Q3 closedcaristu Javascript error appears in console after opening a window with a saved view 
related to defect 0033543 acknowledgedplatform On date filters is not possible to edit manually a date entered previously with the date widget 
related to defect 0036927 closedcaristu Form opened in blank when navigating to a record in a window which has a date column on the first position in grid view 

-  Notes
(0087149)
caristu (developer)
2016-06-10 11:57
edited on: 2016-06-10 11:58

Repository: erp/devel/pi
Changeset: 330cd48c5a70635408ead8b3fbfc72659ed18f52
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Jun 10 11:48:56 2016 +0200
URL: https://code.openbravo.com/erp/devel/pi/rev/8ec5b7456fa1 [^]

fixes issue 32815: Direct link to documents in the workspace is not working

The problem happened having a saved view with a date field as the first one of the grid. In this case the date item was firing an extra datasource call causing the bad behavior.
This extra call was being performed because the date field was detecting wrongly the deletion of its content. Now an extra check is added: the empty filter is applied if the newValue is '' and also if the grid was being filtered by this field.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-minidaterange.js
---

(0087201)
hgbot (developer)
2016-06-13 16:10

Repository: erp/devel/pi
Changeset: c285b5a9fd36006bfe681a29e8297a526a48cb2a
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Jun 13 16:09:31 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/c285b5a9fd36006bfe681a29e8297a526a48cb2a [^]

related to issue 32815: remove unneeded variable

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-minidaterange.js
---
(0087220)
caristu (developer)
2016-06-14 08:38

Added test case into TestLink: https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-10032 [^]
(0087602)
hudsonbot (developer)
2016-06-17 19:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0dc7be081b1c [^]
Maturity status: Test
(0087609)
hudsonbot (developer)
2016-06-17 19:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0dc7be081b1c [^]
Maturity status: Test
(0087695)
alostale (developer)
2016-06-21 07:47

code reviewed

tested this issue and its related ones

- Issue History
Date Modified Username Field Change
2016-04-29 15:00 JONHM New Issue
2016-04-29 15:00 JONHM Assigned To => platform
2016-04-29 15:00 JONHM File Added: ErrorLinkedItem.mp4
2016-04-29 15:00 JONHM Web browser => Google Chrome
2016-04-29 15:00 JONHM Modules => Core
2016-04-29 15:00 JONHM Triggers an Emergency Pack => No
2016-05-02 13:01 JONHM Web browser Google Chrome => Google Chrome
2016-05-20 09:43 alostale Status new => acknowledged
2016-06-09 11:27 caristu Relationship added related to 0033204
2016-06-09 12:33 caristu Web browser Google Chrome => Google Chrome
2016-06-09 12:33 caristu Regression introduced in release => 3.0PR15Q4
2016-06-09 12:33 caristu Priority normal => immediate
2016-06-09 12:33 caristu Steps to Reproduce Updated View Revisions
2016-06-09 13:30 alostale Web browser Google Chrome => Google Chrome
2016-06-09 13:30 alostale Regression level => Production - Confirmed Stable
2016-06-09 13:30 alostale Assigned To platform => caristu
2016-06-09 13:31 alostale Status acknowledged => scheduled
2016-06-09 16:13 egoitz Issue Monitored: egoitz
2016-06-09 17:43 caristu Relationship added related to 0021697
2016-06-09 17:45 caristu Relationship added caused by 0032474
2016-06-09 17:57 caristu Web browser Google Chrome => Google Chrome
2016-06-09 17:57 caristu Target Version => 3.0PR16Q3
2016-06-10 11:57 caristu Note Added: 0087149
2016-06-10 11:57 caristu Status scheduled => resolved
2016-06-10 11:57 caristu Fixed in Version => 3.0PR16Q3
2016-06-10 11:57 caristu Fixed in SCM revision => 8ec5b7456fa1
2016-06-10 11:57 caristu Resolution open => fixed
2016-06-10 11:58 caristu Note Edited: 0087149 View Revisions
2016-06-10 11:58 caristu Note Edited: 0087149 View Revisions
2016-06-10 11:58 caristu Review Assigned To => alostale
2016-06-10 11:58 caristu Web browser Google Chrome => Google Chrome
2016-06-10 11:59 caristu Issue Monitored: alostale
2016-06-13 16:10 hgbot Checkin
2016-06-13 16:10 hgbot Note Added: 0087201
2016-06-14 08:38 caristu Note Added: 0087220
2016-06-17 19:38 hudsonbot Checkin
2016-06-17 19:38 hudsonbot Note Added: 0087602
2016-06-17 19:38 hudsonbot Checkin
2016-06-17 19:38 hudsonbot Note Added: 0087609
2016-06-20 18:24 caristu Web browser Google Chrome => Google Chrome
2016-06-20 18:24 caristu Regression date => 2016-03-15
2016-06-20 18:24 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/330cd48c5a70635408ead8b3fbfc72659ed18f52 [^]
2016-06-21 07:47 alostale Note Added: 0087695
2016-06-21 07:47 alostale Status resolved => closed
2016-07-26 17:09 caristu Relationship added related to 0033543
2017-09-22 12:41 alostale Relationship added related to 0036927


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker