Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033204
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2016-06-09 11:212016-06-17 19:38
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q3
StatusclosedFix in branchFixed in SCM revision36db2944c992
ProjectionnoneETAnoneTarget Version3.0PR16Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2016-04-13
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/4bc26a30e2966fc212fa9b336a9e36f4e1a042c6 [^]
Triggers an Emergency PackNo
Summary

0033204: Javascript error appears in console after opening a window with a saved view

DescriptionJavascript error appears in console after opening a window with a saved view.
The error is reproducible when the grid view definition has the filterClause attribute set to true
Steps To Reproduce1) Go to the [Sales Order] window and create a new saved view. Set it as default.
2) Close the window
3) Re-open it again. The following error appears in dev console: "Uncaught TypeError: strValue.replace is not a function"
Proposed SolutionAfter the following changeset[1], the filterClause is a boolean value. But in the following line[2] of ob-view-grid, it still expects a string. The error is thrown when the passed value to OB.Utilities.isNonEmptyString is equal to true.

[1] https://code.openbravo.com/erp/devel/pi/rev/d239cb280bb9 [^]
[2] https://code.openbravo.com/erp/devel/pi/file/ed44288c1e71/modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js#l1122 [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00328153.0PR16Q3 closedcaristu Direct link to documents in the workspace is not working 
related to defect 0025033 closedAugustoMauch Removing the filter show refresh the window if the window was openend with the default filter clause 
caused by feature request 00326103.0PR16Q3 closedNaroaIriarte standard datasources shouldn't accept where parameter by default 

-  Notes
(0087195)
hgbot (developer)
2016-06-13 12:05
edited on: 2016-06-13 12:28

Repository: erp/devel/pi
Changeset: 36db2944c9926ac8cb35ba6f538d571053ec5f91
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Jun 13 12:04:17 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/36db2944c9926ac8cb35ba6f538d571053ec5f91 [^]

fixes issue 33204: Javascript error after opening a window with a saved view
Since this changeset[1], filterClause is no longer a string but a boolean. So the check done on the setViewState method of ob-view-grid has been fixed accordingly

[1] https://code.openbravo.com/erp/devel/pi/rev/4bc26a30e2966fc212fa9b336a9e36f4e1a042c6 [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---

(0087221)
caristu (developer)
2016-06-14 08:42

TestLink: https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-10033 [^]
(0087374)
alostale (developer)
2016-06-17 08:24

code reviewed + tested
(0087607)
hudsonbot (developer)
2016-06-17 19:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0dc7be081b1c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-06-09 11:21 caristu New Issue
2016-06-09 11:21 caristu Assigned To => platform
2016-06-09 11:21 caristu Modules => Core
2016-06-09 11:21 caristu Regression level => Pre packaging ( pi )
2016-06-09 11:21 caristu Regression date => 2016-04-13
2016-06-09 11:21 caristu Regression introduced in release => pi
2016-06-09 11:21 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/4bc26a30e2966fc212fa9b336a9e36f4e1a042c6 [^]
2016-06-09 11:21 caristu Triggers an Emergency Pack => No
2016-06-09 11:23 caristu Relationship added caused by 0032610
2016-06-09 11:27 caristu Relationship added related to 0032815
2016-06-09 11:30 caristu Proposed Solution updated
2016-06-09 11:30 caristu Proposed Solution updated
2016-06-10 12:43 caristu Assigned To platform => caristu
2016-06-10 12:43 caristu Status new => scheduled
2016-06-10 12:44 caristu Target Version => 3.0PR16Q3
2016-06-13 11:34 caristu Relationship added related to 0025033
2016-06-13 12:05 hgbot Checkin
2016-06-13 12:05 hgbot Note Added: 0087195
2016-06-13 12:05 hgbot Status scheduled => resolved
2016-06-13 12:05 hgbot Resolution open => fixed
2016-06-13 12:05 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/36db2944c9926ac8cb35ba6f538d571053ec5f91 [^]
2016-06-13 12:28 caristu Note Edited: 0087195 View Revisions
2016-06-14 08:42 caristu Note Added: 0087221
2016-06-17 08:24 alostale Review Assigned To => alostale
2016-06-17 08:24 alostale Note Added: 0087374
2016-06-17 08:24 alostale Status resolved => closed
2016-06-17 08:24 alostale Fixed in Version => 3.0PR16Q3
2016-06-17 19:38 hudsonbot Checkin
2016-06-17 19:38 hudsonbot Note Added: 0087607


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker