Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025033
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfacecriticalalways2013-10-28 13:502013-10-30 20:47
ReporteregoitzView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0MP29
StatusclosedFix in branchFixed in SCM revisionab075f83c2f8
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2013-09-11
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/290c9b12a211 [^]
Triggers an Emergency PackNo
Summary

0025033: Removing the filter show refresh the window if the window was openend with the default filter clause

DescriptionRemoving the filter show refresh the window if the window was openend with the default filter clause
Steps To Reproduce-Access to saler order window and remove the defult filter clause by clicking on the funnel
-On sales order window create 10 orders on draft
-Apply filter to shon only 4 of that rows
-Save the filtering as a view and set us default.
-Logout and login
-Access to the window and see that only the 4 rows are shown due to the defult view
-Remove the filter by clicking the funnel
-The window is not refreshed so the default filter clause is still applied so only 10 rows are shown
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00332043.0PR16Q3 closedcaristu Javascript error appears in console after opening a window with a saved view 

-  Notes
(0061935)
hgbot (developer)
2013-10-29 13:11

Repository: erp/devel/pi
Changeset: ab075f83c2f8cc8c198d8b2541ef90de3134fbbc
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Oct 29 13:05:23 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/ab075f83c2f8cc8c198d8b2541ef90de3134fbbc [^]

Fixes issue 25033: Problems with personalization and grid adaptive filtering

There was a problem when a saved view with no filter clause is applied over a view that had an active filter clause.

Consider the following sequence of events:
- A window (i.e. Sales Order) is opened
- An initial request to the datasource before the personalized view is applied. Suppose the datasource returns fewer than 100 records
- The personalized view is applied. As there is fewer than 100 records, the filtering is done locally. This is wrong, because the initial dataset was built over a filterClause, and the personalize view that is being applied does not have a filter clause. In this case the filtering should not be done locally.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0061967)
alostale (developer)
2013-10-30 11:02

code reviewed + verified
(0061981)
hudsonbot (developer)
2013-10-30 20:47

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/80f375c041fe [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-10-28 13:50 egoitz New Issue
2013-10-28 13:50 egoitz Assigned To => AugustoMauch
2013-10-28 13:50 egoitz Modules => Core
2013-10-28 13:50 egoitz Triggers an Emergency Pack => No
2013-10-28 13:54 egoitz Regression level => Production - QA Approved
2013-10-29 11:06 egoitz Steps to Reproduce Updated View Revisions
2013-10-29 13:05 AugustoMauch Issue Monitored: alostale
2013-10-29 13:06 AugustoMauch Review Assigned To => alostale
2013-10-29 13:06 AugustoMauch Severity major => critical
2013-10-29 13:10 AugustoMauch Regression date => 2013-09-11
2013-10-29 13:10 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/290c9b12a211 [^]
2013-10-29 13:11 hgbot Checkin
2013-10-29 13:11 hgbot Note Added: 0061935
2013-10-29 13:11 hgbot Status new => resolved
2013-10-29 13:11 hgbot Resolution open => fixed
2013-10-29 13:11 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ab075f83c2f8cc8c198d8b2541ef90de3134fbbc [^]
2013-10-30 11:02 alostale Note Added: 0061967
2013-10-30 11:02 alostale Status resolved => closed
2013-10-30 11:02 alostale Fixed in Version => 3.0MP29
2013-10-30 20:47 hudsonbot Checkin
2013-10-30 20:47 hudsonbot Note Added: 0061981
2016-06-13 11:34 caristu Relationship added related to 0033204


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker