Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0021697
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminoralways2012-09-20 14:302012-10-11 07:51
ReporterplujanView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0MP17
StatusclosedFix in branchpiFixed in SCM revisionf2ec6da4445f
ProjectionnoneETAnoneTarget Version3.0MP17
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned Todbaz
Web browserApple Safari
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0021697: Filtering columns behaviour is not consistent for dates and prices

DescriptionWhile testing the application in keyboard-only mode (no mouse) some inconsistencies came up on applying filters when the fields are of type Date or Price. See steps and attached screenshot.
Steps To ReproduceNote that steps describing the incorrect behaviour are steps 10, 12 and 16

1. Log in as Openbravo user
2. Create two Sales Invoices:
2.1. Invoice 1: for date 19 Jun, business partner "Alimentos y Supermercados". With no lines.
2.2. Invoice 2: for date 20 Sep, business partner "Alimentos y Supermercados". One line containing 1 unit of Agua Sin Gas 1L (net amount 1.53)
3. In the header grid, use Ctrl+Shift+F to go to filters. Focus will move to Organization filter box.
4. Type F. This action will filter all the Organization containing the F letter.
5. Delete the F. This action will bring back all the items.
6. Hit Tab key to move to next filter. Document No gets focused.
7. Type 0. This action will filter all the Document numbers containing the 0.
8. Delete the 0. This action will bring back all the items.
9. Hit Tab key to move to next filter. Invoice Date gets focused.
10. Type "19/06/2012". This action does nothing. You have to hit the Tab key to get the list filtered.
11. Use Shift+Tab to return to the Invoice Date field.
12. Delete the content of the field and hit Tab again. The action is not recognized, so the previous filter is not removed.
13. Focus is now in Business Partner filter. Type "Al" and the previous action in Invoice Date and the Business Partner filter are applied at the same time.
14. Remove the "Al" and the list gets unfiltered.
15. Hit Tab key to move to next filter. Total Gross Amount gets focused.
16. Write "0". This action does nothing. Hitting the Tab key does not work neither. However, the "0" is replaced by a "0.00".
17. Filter by "No" in Payment Complete. Now the filtering of the amount gets effect.
TagsNo tags attached.
Attached Filespng file icon mp15-FilteringPrices.png [^] (64,301 bytes) 2012-09-20 14:30

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00328153.0PR16Q3 closedcaristu Direct link to documents in the workspace is not working 

-  Notes
(0052824)
AugustoMauch (developer)
2012-09-27 10:08

After talking with the submitter of the issue, this are the changes that will be made to make the filtering consistent:
- When a numeric column filter loses the focus its filter will be applied (the same as if the user had pressed Enter)
- When a date column filter is emptied and then loses the focus, that particular filter should not be applied.
(0052854)
hgbot (developer)
2012-09-28 10:24

Repository: erp/devel/pi
Changeset: e3837a02a9d54139c43bf47481e85ede416edc4a
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Sep 28 10:09:48 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/e3837a02a9d54139c43bf47481e85ede416edc4a [^]

Related to issue 21697: Numeric filters are executed when they lose the focus

Now, the numeric filter will be applied not only when the Enter key is pressed, but also when the focus leaves the filter.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-number.js
---
(0052857)
AugustoMauch (developer)
2012-09-28 11:17

Test plan:
- Check that for numerical column filters, the filter is applied when the focus leaves the column even is the Enter key has not been pressed.
- For date filters, check that is the filter is deleted, the empty filter is applied even if the Enter key has not been pressed before.
- For both types of filters, check that they are not being applied twice if the Tab key is pressed after the Enter key.
(0052858)
hgbot (developer)
2012-09-28 11:25

Repository: erp/devel/pi
Changeset: 803d0686dbd32c481c6863f11feb9753df00d70c
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Sep 28 11:24:29 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/803d0686dbd32c481c6863f11feb9753df00d70c [^]

Fixes bug 21697: When a date filter is removed, it is applied when tabbing out

Before this fix, in order to delete a date filter the Enter key had to be pressed. This was not consistent, because in order to apply a not-null date filter, it was enough to tab out of the column. Now, if the date filter text is deleted and the column loses the focus, the change will be applied even if the Enter key is not pressed.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-minidaterange.js
---
(0052933)
dbaz (developer)
2012-09-29 01:17

Reviewed @ changeset: 18081 - 4c8b2e89747d
(0052976)
hgbot (developer)
2012-10-01 21:59

Repository: erp/devel/pi
Changeset: 471b8c5410e5fa93da16ea557da9918789748ba5
Author: Stefan Hühner <stefan.huehner <at> openbravo.com>
Date: Mon Oct 01 19:00:47 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/471b8c5410e5fa93da16ea557da9918789748ba5 [^]

Issue 21697: Backout 803d0686dbd3 as it breaks int-gui tests

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-minidaterange.js
---
(0052977)
hgbot (developer)
2012-10-01 22:00

Repository: erp/devel/pi
Changeset: 85a11d1edcafbc0c72a3ab0da7d6a3e34d8babf6
Author: Stefan Hühner <stefan.huehner <at> openbravo.com>
Date: Mon Oct 01 19:01:27 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/85a11d1edcafbc0c72a3ab0da7d6a3e34d8babf6 [^]

Issue 21697: Backout e3837a02a9d5 as it breaks int-gui tests

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-number.js
---
(0052978)
shuehner (administrator)
2012-10-01 22:01

Fix needed to be temporarily backed out as it broke the int-gui test just one day before the freeze and no easy/fast with for the tests is insight.
Re-targeting cset for mp17
(0053036)
hudsonbot (developer)
2012-10-04 18:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c067ea513614 [^]

Maturity status: Test
(0053038)
hudsonbot (developer)
2012-10-04 18:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c067ea513614 [^]

Maturity status: Test
(0053049)
hudsonbot (developer)
2012-10-04 18:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c067ea513614 [^]

Maturity status: Test
(0053050)
hudsonbot (developer)
2012-10-04 18:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c067ea513614 [^]

Maturity status: Test
(0053118)
hgbot (developer)
2012-10-08 16:35

Repository: erp/devel/pi
Changeset: f574046d4be7e8d357f835773d76ecc6c3697f28
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Oct 08 16:31:43 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f574046d4be7e8d357f835773d76ecc6c3697f28 [^]

Fixes issue 21697: Fix of issue 21697 reapplied

The fix of the issue 21697 has been reapplied after the test it broke has been adapted.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-minidaterange.js
---
(0053166)
dbaz (developer)
2012-10-09 13:14

In "Sales Invoice" for example, in the "Total Gross Amount" column, it doesn't work. If you write "0" and tab, the grid is not filtered
(0053173)
hgbot (developer)
2012-10-09 13:43

Repository: erp/devel/pi
Changeset: f2ec6da4445fb21aed4c0ed009c6b5a2964c8625
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Oct 09 13:41:46 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f2ec6da4445fb21aed4c0ed009c6b5a2964c8625 [^]

Fixes issue 21697: Reapplies code that had been backed out

On October 1st the two changesets that fixed the issue were backed out, but then only the one related to the date column filter was reapplied, and not the one related to the numeric fields.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-number.js
---
(0053174)
dbaz (developer)
2012-10-09 14:15

Reviewed @ changeset: 18175 - f2ec6da4445f
(0053209)
hudsonbot (developer)
2012-10-10 16:35

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b088fe9dfe19 [^]

Maturity status: Test
(0053211)
hudsonbot (developer)
2012-10-10 16:35

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b088fe9dfe19 [^]

Maturity status: Test
(0053222)
hudsonbot (developer)
2012-10-10 16:35

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b088fe9dfe19 [^]

Maturity status: Test
(0053223)
hudsonbot (developer)
2012-10-10 16:35

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b088fe9dfe19 [^]

Maturity status: Test
(0053263)
hudsonbot (developer)
2012-10-11 07:50

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/63dfc135f2a1 [^]

Maturity status: Test
(0053280)
hudsonbot (developer)
2012-10-11 07:51

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/63dfc135f2a1 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-09-20 14:30 plujan New Issue
2012-09-20 14:30 plujan Assigned To => dbaz
2012-09-20 14:30 plujan File Added: mp15-FilteringPrices.png
2012-09-20 14:30 plujan Web browser => Apple Safari
2012-09-20 14:30 plujan Modules => Core
2012-09-27 10:08 AugustoMauch Note Added: 0052824
2012-09-28 10:24 hgbot Checkin
2012-09-28 10:24 hgbot Note Added: 0052854
2012-09-28 11:14 AugustoMauch Issue Monitored: dbaz
2012-09-28 11:15 AugustoMauch Closed by => dbaz
2012-09-28 11:15 AugustoMauch Web browser Apple Safari => Apple Safari
2012-09-28 11:15 AugustoMauch Assigned To dbaz => AugustoMauch
2012-09-28 11:17 AugustoMauch Note Added: 0052857
2012-09-28 11:25 hgbot Checkin
2012-09-28 11:25 hgbot Note Added: 0052858
2012-09-28 11:25 hgbot Status new => resolved
2012-09-28 11:25 hgbot Resolution open => fixed
2012-09-28 11:25 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/803d0686dbd32c481c6863f11feb9753df00d70c [^]
2012-09-29 01:17 dbaz Note Added: 0052933
2012-09-29 01:17 dbaz Status resolved => closed
2012-09-29 01:17 dbaz Fixed in Version => 3.0MP16
2012-09-29 01:17 dbaz Issue End Monitor: dbaz
2012-10-01 21:59 hgbot Checkin
2012-10-01 21:59 hgbot Note Added: 0052976
2012-10-01 22:00 hgbot Checkin
2012-10-01 22:00 hgbot Note Added: 0052977
2012-10-01 22:01 shuehner Note Added: 0052978
2012-10-01 22:01 shuehner Status closed => new
2012-10-01 22:01 shuehner Resolution fixed => open
2012-10-01 22:01 shuehner Fixed in Version 3.0MP16 =>
2012-10-01 22:01 shuehner Web browser Apple Safari => Apple Safari
2012-10-01 22:01 shuehner Target Version => 3.0MP17
2012-10-02 09:38 AugustoMauch Status new => acknowledged
2012-10-02 09:38 AugustoMauch Status acknowledged => scheduled
2012-10-02 09:38 AugustoMauch fix_in_branch => pi
2012-10-04 18:18 hudsonbot Checkin
2012-10-04 18:18 hudsonbot Note Added: 0053036
2012-10-04 18:18 hudsonbot Checkin
2012-10-04 18:18 hudsonbot Note Added: 0053038
2012-10-04 18:18 hudsonbot Checkin
2012-10-04 18:18 hudsonbot Note Added: 0053049
2012-10-04 18:18 hudsonbot Checkin
2012-10-04 18:18 hudsonbot Note Added: 0053050
2012-10-08 16:35 hgbot Checkin
2012-10-08 16:35 hgbot Note Added: 0053118
2012-10-08 16:35 hgbot Status scheduled => resolved
2012-10-08 16:35 hgbot Resolution open => fixed
2012-10-08 16:35 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/803d0686dbd32c481c6863f11feb9753df00d70c [^] => http://code.openbravo.com/erp/devel/pi/rev/f574046d4be7e8d357f835773d76ecc6c3697f28 [^]
2012-10-09 13:14 dbaz Note Added: 0053166
2012-10-09 13:14 dbaz Status resolved => new
2012-10-09 13:14 dbaz Resolution fixed => open
2012-10-09 13:43 hgbot Checkin
2012-10-09 13:43 hgbot Note Added: 0053173
2012-10-09 13:43 hgbot Status new => resolved
2012-10-09 13:43 hgbot Resolution open => fixed
2012-10-09 13:43 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/f574046d4be7e8d357f835773d76ecc6c3697f28 [^] => http://code.openbravo.com/erp/devel/pi/rev/f2ec6da4445fb21aed4c0ed009c6b5a2964c8625 [^]
2012-10-09 14:15 dbaz Note Added: 0053174
2012-10-09 14:15 dbaz Status resolved => closed
2012-10-09 14:15 dbaz Fixed in Version => 3.0MP17
2012-10-10 16:35 hudsonbot Checkin
2012-10-10 16:35 hudsonbot Note Added: 0053209
2012-10-10 16:35 hudsonbot Checkin
2012-10-10 16:35 hudsonbot Note Added: 0053211
2012-10-10 16:35 hudsonbot Checkin
2012-10-10 16:35 hudsonbot Note Added: 0053222
2012-10-10 16:35 hudsonbot Checkin
2012-10-10 16:35 hudsonbot Note Added: 0053223
2012-10-11 07:50 hudsonbot Checkin
2012-10-11 07:50 hudsonbot Note Added: 0053263
2012-10-11 07:51 hudsonbot Checkin
2012-10-11 07:51 hudsonbot Note Added: 0053280
2016-06-09 17:43 caristu Relationship added related to 0032815


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker