Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033208
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminoralways2016-04-29 15:002016-06-21 07:48
ReporterJONHMView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q2.1
StatusclosedFix in branchFixed in SCM revision28ef3ec9f640
ProjectionnoneETAnoneTarget Version3.0PR16Q2.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toalostale
Web browserGoogle Chrome
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date
Regression introduced in release3.0PR15Q4
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0033208: Direct link to documents in the workspace is not working

DescriptionDirect link to documents in the workspace is not working when first field in grid is of "Date" type. The result is a blank document.
Steps To Reproduce== First Way ==

**First you need an activated instance to make changes effective in window.
* Navigate to Sales Order window, set the first column of grid view as a "Date" type
* Rebuild the application

1) Create a new Sales Order
2) Return to Workspace and click the direct link to that document

The result is a blank window. See the attached video


== Second Way ==
Configuration Steps:
a) Add the Invoices to Collect widget into the workspace
b) Create a saved view in Sales Invoice window, with "Invoice Date" field at the first position. Set this view as default.

Steps To Reproduce:
1) Open the [Sales Invoice] window
2) Move to the Workspace. Click on any document number of the Invoice to Collect widget.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00328153.0PR16Q3 closedcaristu Direct link to documents in the workspace is not working 

-  Notes
(0087378)
hgbot (developer)
2016-06-17 08:52

Repository: erp/backports/3.0PR16Q2.1
Changeset: 28ef3ec9f6402ce85037849cf31f4044bcbe7ac1
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Jun 17 08:52:10 2016 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR16Q2.1/rev/28ef3ec9f6402ce85037849cf31f4044bcbe7ac1 [^]

fixes issue 33208: Direct link to documents in the workspace is not working

The problem happened having a saved view with a date field as the first one of the grid. In this case the date item was firing an extra datasource call causing the bad behavior. This extra call was being performed because the date field was detecting wrongly the deletion of its content. Now an extra check is added: the empty filter is applied if the newValue is '' and also if the grid was being filtered by this field.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-minidaterange.js
---
(0087697)
alostale (developer)
2016-06-21 07:48

code reviewed

tested this issue and its related ones

- Issue History
Date Modified Username Field Change
2016-06-09 13:31 alostale Type defect => backport
2016-06-09 13:31 alostale Target Version => 3.0PR16Q2.1
2016-06-09 13:31 alostale Web browser Google Chrome => Google Chrome
2016-06-09 13:31 alostale Target Version 3.0PR16Q2.1 => 3.0PR16Q2
2016-06-10 11:46 caristu Web browser Google Chrome => Google Chrome
2016-06-10 11:46 caristu Target Version 3.0PR16Q2 => 3.0PR16Q2.1
2016-06-17 08:52 hgbot Checkin
2016-06-17 08:52 hgbot Note Added: 0087378
2016-06-17 08:52 hgbot Status scheduled => resolved
2016-06-17 08:52 hgbot Resolution open => fixed
2016-06-17 08:52 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR16Q2.1/rev/28ef3ec9f6402ce85037849cf31f4044bcbe7ac1 [^]
2016-06-21 07:48 alostale Review Assigned To => alostale
2016-06-21 07:48 alostale Note Added: 0087697
2016-06-21 07:48 alostale Status resolved => closed
2016-06-21 07:48 alostale Fixed in Version => 3.0PR16Q2.1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker