Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036927
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorsometimes2017-09-22 11:232018-01-03 12:38
ReporterJONHMView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revision54e2948eb10b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036927: Form opened in blank when navigating to a record in a window which has a date column on the first position in grid view

DescriptionWhen navigating to a record in a window which has a date column on the first position in grid view, sometimes the form is shown in blank.
Steps To Reproduce* Having an environment with the instance activated:

1) Open 'Product' window in grid mode and show 'Creation Date' column. Put it on the first position of the grid
2) Open 'Goods Shipment' window and select some record. Switch to [Lines] tab and open the record in form view. Then open on a new tab the product.
3) Using developer's tools, notice that some extra DS requests are fired to the datasource. This can cause that the window is opened in blank with no records

Note: the same behavior happens when opening the record using the "Recent Documents" link.
Proposed SolutionThe problem is caused by a race condition: under this circumstances, multiple DS requests are being fired (see attached image) which seems that can cause troubles when trying to draw the form with the target record data.
TagsNo tags attached.
Attached Filespng file icon Screenshot from 2017-09-22 11-00-43.png [^] (69,993 bytes) 2017-09-22 11:23


png file icon multipleDS.png [^] (52,847 bytes) 2017-09-26 12:51


diff file icon issue36927.diff [^] (2,526 bytes) 2017-09-26 16:52 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00328153.0PR16Q3 closedcaristu Direct link to documents in the workspace is not working 

-  Notes
(0099728)
hgbot (developer)
2017-10-03 16:37

Repository: erp/devel/pi
Changeset: 54e2948eb10b7fc6a122fa54f001a8f882873985
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Sep 26 12:41:49 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/54e2948eb10b7fc6a122fa54f001a8f882873985 [^]

fixes bug 36927: Multiple DS requests having a date item as first focused item

  When directly opening a record in a tab which has a date item as the first focused item, extra DS calls were fired which could prevent the record to be opened properly (the form displayed in blank)

  This has happening because a combination of different facts:

   - When the grid is redrawn, Smarclient fires an update of the first focused item. In the case of date items this causes that false item edition is fired because it detects that the value of the date item filter changes from undefined to empty string.

   - If the previous scenario happens while opening a record directly, the grid datasource detects that it needs to fetch data because at this point the number of cached rows is different from the total rows (see [1]).

  To avoid those extra DS requests we now ignore those false item editions while a target record is being opened.

[1] https://code.openbravo.com/erp/mods/org.openbravo.userinterface.smartclient.dev/file/66d2b640b66e/web/org.openbravo.userinterface.smartclient/isomorphic/client/application/ResultSet.js#l833 [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-minidaterange.js
---
(0099729)
hgbot (developer)
2017-10-03 16:41

Repository: erp/devel/pi
Changeset: 7b2a0a999bb27a0052d38d06369fe2f9950c2290
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Oct 03 16:24:09 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/7b2a0a999bb27a0052d38d06369fe2f9950c2290 [^]

related to issue 36927: update copyright year

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-minidaterange.js
---
(0099793)
alostale (developer)
2017-10-06 12:33

reviewed + tested
(0101311)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test
(0101312)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-09-22 11:23 JONHM New Issue
2017-09-22 11:23 JONHM Assigned To => platform
2017-09-22 11:23 JONHM File Added: Screenshot from 2017-09-22 11-00-43.png
2017-09-22 11:23 JONHM Modules => Core
2017-09-22 11:23 JONHM Triggers an Emergency Pack => No
2017-09-22 12:41 alostale Relationship added related to 0032815
2017-09-25 10:49 caristu Status new => scheduled
2017-09-25 10:49 caristu Assigned To platform => caristu
2017-09-25 20:04 caristu Summary Error when 'opening on tab' a window which have a date column on the first position in grid view => Multiple DS requests when navigation to a record in a window which have a date column on the first position in grid view
2017-09-25 20:04 caristu Description Updated View Revisions
2017-09-25 20:04 caristu Steps to Reproduce Updated View Revisions
2017-09-25 20:04 caristu Summary Multiple DS requests when navigation to a record in a window which have a date column on the first position in grid view => Multiple DS requests when navigating to a record in a window which have a date column on the first position in grid view
2017-09-26 12:26 caristu Summary Multiple DS requests when navigating to a record in a window which have a date column on the first position in grid view => Form opened in blank when navigating to a record in a window which has a date column on the first position in grid view
2017-09-26 12:26 caristu Description Updated View Revisions
2017-09-26 12:26 caristu Proposed Solution updated
2017-09-26 12:27 caristu Reproducibility always => sometimes
2017-09-26 12:35 caristu File Added: issue36927.diff
2017-09-26 12:47 caristu File Added: multipleDS.png
2017-09-26 12:47 caristu File Deleted: multipleDS.png
2017-09-26 12:48 caristu File Added: multipleDS.png
2017-09-26 12:48 caristu File Deleted: multipleDS.png
2017-09-26 12:48 caristu File Deleted: issue36927.diff
2017-09-26 12:50 caristu File Added: multipleDS.png
2017-09-26 12:51 caristu File Deleted: multipleDS.png
2017-09-26 12:51 caristu File Added: multipleDS.png
2017-09-26 12:51 caristu File Added: issue36927.diff
2017-09-26 16:52 caristu File Deleted: issue36927.diff
2017-09-26 16:52 caristu File Added: issue36927.diff
2017-10-03 16:37 hgbot Checkin
2017-10-03 16:37 hgbot Note Added: 0099728
2017-10-03 16:38 hgbot Status scheduled => resolved
2017-10-03 16:38 hgbot Resolution open => fixed
2017-10-03 16:38 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/54e2948eb10b7fc6a122fa54f001a8f882873985 [^]
2017-10-03 16:41 hgbot Checkin
2017-10-03 16:41 hgbot Note Added: 0099729
2017-10-03 16:41 caristu Review Assigned To => alostale
2017-10-06 12:33 alostale Note Added: 0099793
2017-10-06 12:33 alostale Status resolved => closed
2017-10-06 12:33 alostale Fixed in Version => 3.0PR18Q1
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101311
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101312


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker