Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032477
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminoralways2016-03-15 10:272016-03-18 08:43
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q1.1
StatusclosedFix in branchFixed in SCM revision5ae13dc119e9
ProjectionnoneETAnoneTarget Version3.0PR16Q1.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2015-12-16
Regression introduced in release3.0PR15Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/17016914f029b502a391792438ec40750d2b95cd [^]
Triggers an Emergency PackNo
Summary

0032477: '[object Object]' instead of blank value after clearing value in selector

Description'[object Object]' instead of blank value appears after clearing value in selector
Steps To Reproduce1- Log in ERP as F&B International Group Admin.
2- Go to Financial Account window and select 'Bank - Account 1'.
3- Go to Transaction subtab and insert a new row in grid.
4- Click in magnifying glass button to add a Payment. A Payment popup is shown and Financial Account filter has the following value: 'Bank - Account 1 - USD'.
5- Clear all filters and realize that Payment Date filter has the following value: '[object Object]' instead of blank value.
Proposed SolutionIn ob-formitem-minidaterange.js, in function hasAdvancedCriteria() return always true.
    
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0032474 closedcaristu '[object Object]' instead of blank value after clearing value in selector 

-  Notes
(0085002)
hgbot (developer)
2016-03-16 11:55

Repository: erp/backports/3.0PR16Q1.1
Changeset: 5ae13dc119e9fd18489af9f8bed42a4aea9b1991
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Mar 16 11:55:00 2016 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR16Q1.1/rev/5ae13dc119e9fd18489af9f8bed42a4aea9b1991 [^]

fixes issue 32477: [object Object] appears after clearing value in selector

Having singleDateMode as false after clearing the filter content of the date causes the return of an empty object in the getValuesAsCriteria method of the grid. The this.singleDateMode was being set to true in clearFilterValues function, but this statement was deleted to solve issue 31705, because it was preventing to show the range dialog after clearing the filters, when pressing the Enter key.

To solve both problems the change regarding setting singleDateMode in clearFilterValues has been reverted, and in order to ensure that the range dialog is displayed when it should be, a new check has been included in the keyPress method.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-minidaterange.js
---
(0085219)
alostale (developer)
2016-03-18 08:43

code reviewed

tested also all related issues:

* 31705
* 29554
* 29661

- Issue History
Date Modified Username Field Change
2016-03-15 11:10 caristu Type defect => backport
2016-03-15 11:10 caristu Target Version => 3.0PR16Q1.1
2016-03-16 11:55 hgbot Checkin
2016-03-16 11:55 hgbot Note Added: 0085002
2016-03-16 11:55 hgbot Status scheduled => resolved
2016-03-16 11:55 hgbot Resolution open => fixed
2016-03-16 11:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR16Q1.1/rev/5ae13dc119e9fd18489af9f8bed42a4aea9b1991 [^]
2016-03-16 12:29 caristu Review Assigned To => alostale
2016-03-16 12:29 caristu Issue Monitored: alostale
2016-03-18 08:29 alostale Assigned To platform => caristu
2016-03-18 08:43 alostale Note Added: 0085219
2016-03-18 08:43 alostale Status resolved => closed
2016-03-18 08:43 alostale Fixed in Version => 3.0PR16Q1.1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker