Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0022123
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminoralways2012-10-28 15:162016-10-24 09:31
ReporterpjuvaraView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0MP20
StatusclosedFix in branchFixed in SCM revision8e1a1a70be0d
ProjectionnoneETAnoneTarget Version3.0MP20
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Todbaz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0022123: UI looses focus when entering filter in grid mode

DescriptionWhen you are in a window in grid mode and you want to look for a specific record using the filters and you start typing, the grid automatically perform queries as you type.

The first time that the query is fired, the focus is lost from the grid. This means that if you had typed a partial value and you want to continue typing, you need to move the focus back in the grid.

Subsequent queries do not have this problem.

This is a very significant annoyance and productivity loss for users (that is why I report this as Major issue).
Steps To ReproduceThe behavior can be experienced in any grid. For example:
1) Login as system administrator
2) Navigates to the Tables and Columns window
3) Let's suppose you want to search for table with Name "ADUser".
4) In the filter for column Name, type - without hesitation - "AD" and stop there to simulate a hesitation
5) The query fires and you can see that the focus is lost.
6) Put the focus back and add "u"
7) The query fires and the focus is now preserved.
Proposed SolutionThe focus should not be lost after the first query.
TagsCoworking
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0034057 closedNaroaIriarte Wrong Tabulation Order in form fields in Organization window 

-  Notes
(0054910)
AugustoMauch (developer)
2012-12-13 10:05

This issue can be reproduced in Linux (Firefox and Chrome), but not in Windows (IE and Chrome).
(0055403)
AugustoMauch (developer)
2013-01-09 09:30

Postponed to MP20 because a proper fix has not been found yet.
(0056017)
hgbot (developer)
2013-01-31 16:11

Repository: erp/devel/pi
Changeset: 8e1a1a70be0dd8a06c5dfa60553a0e4115143e42
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Jan 31 16:10:28 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/8e1a1a70be0dd8a06c5dfa60553a0e4115143e42 [^]

Fixes issue 22123: UI doesnt lose the focus when entering filter in grid mode

At some point, the whole grid (filters included) were being redrawn, when only the body of the grid needed to be redrawn. If the focus was in the grid filter, it got lost. This issue has been fixed by redrawing only the body of the grid.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0056023)
dbaz (developer)
2013-01-31 17:15

Reviewed @ changeset: 19533 @ 8e1a1a70be0d
(0056099)
hudsonbot (developer)
2013-02-01 22:28

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b070aa80fc76 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-10-28 15:16 pjuvara New Issue
2012-10-28 15:16 pjuvara Assigned To => dbaz
2012-10-28 15:16 pjuvara Modules => Core
2012-10-28 15:16 pjuvara Tag Attached: Coworking
2012-12-10 12:09 jonalegriaesarte Triggers an Emergency Pack => No
2012-12-10 12:09 jonalegriaesarte Severity major => minor
2012-12-10 12:09 jonalegriaesarte Target Version => 3.0MP19
2012-12-10 13:27 dbaz Assigned To dbaz => AugustoMauch
2012-12-13 10:05 AugustoMauch Note Added: 0054910
2013-01-09 09:30 AugustoMauch Note Added: 0055403
2013-01-09 09:30 AugustoMauch Target Version 3.0MP19 => 3.0MP20
2013-01-31 16:05 AugustoMauch Issue Monitored: dbaz
2013-01-31 16:06 AugustoMauch Review Assigned To => dbaz
2013-01-31 16:11 hgbot Checkin
2013-01-31 16:11 hgbot Note Added: 0056017
2013-01-31 16:11 hgbot Status new => resolved
2013-01-31 16:11 hgbot Resolution open => fixed
2013-01-31 16:11 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/8e1a1a70be0dd8a06c5dfa60553a0e4115143e42 [^]
2013-01-31 17:15 dbaz Note Added: 0056023
2013-01-31 17:15 dbaz Status resolved => closed
2013-01-31 17:15 dbaz Fixed in Version => 3.0MP20
2013-02-01 12:28 AugustoMauch Relationship added duplicate of 0022766
2013-02-01 22:28 hudsonbot Checkin
2013-02-01 22:28 hudsonbot Note Added: 0056099
2013-02-12 13:14 AugustoMauch Relationship deleted 0022766
2016-10-24 09:31 NaroaIriarte Relationship added related to 0034057


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker