Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035553
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] A. Platformminorhave not tried2017-03-17 10:202020-02-28 10:31
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR17Q3
StatusclosedFix in branchFixed in SCM revisionc17655a6fb3f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035553: Improve scalability of the login process

DescriptionThe are of set of tasks and improvements that can be applied to the log-in process (in the backend) with the objective of improving its scalability.

More info: http://wiki.openbravo.com/wiki/Projects:Login_Process_Perfomance_Improvements [^]
Steps To Reproduce.
TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0043363 closedalostale unneded requests to StaticResources when working in cluster 
related to feature request 0035386 closedcaristu Login page needs some clean up 
related to design defect 0035677 newplatform The logic to show the link to an accessible window in field title is not complete 
related to defect 0035746 closedcaristu API Changes after Login Process Perfomance Improvements Project 
related to defect 0035834 closedalostale platform modules fail in CI 
related to feature request 0035852 closedcaristu Add a mechanism to cache the static resources 
related to feature request 0035980 closedcaristu Improve the time spent to load the widgets after log-in 
related to design defect 0035989 acknowledgedplatform Default session values calculation on login is slow having a big amount of organizations 
related to defect 0036518 closedalostale useless ping to butler on every login 
related to defect 0037267 closedcaristu Improvements in the I18NComponent component 
related to defect 0037324 closedalostale slow login having many preferences 
related to defect 0037358 closedinigosanchez Avoid query to AttributeData.selectOrgCurrency during login if system does not have any accounting schema. 
related to defect 0039938 closedcaristu It is not needed to keep the URL target query string in session 
causes defect 0035769 closedcaristu Unstable jobs in CI after improving the scalability of the login process 
causes defect 0035771 closedcaristu Can not login with a user that has a role without access to any organization 
causes defect 0035800 closedcaristu Can not add navigation bar element of Activity module 
causes defect 0035825 closedcaristu Default org/warehouse not sorted properly in profile widget 
causes defect 0037278 closedinigosanchez Deactivated roles are displayed in the role dropdown of user section 
causes defect 0037289 closedinigosanchez It is not possible to do login using a role if the role has got a deactivated organization 
causes defect 0037624 closedinigosanchez Filter on quick launch menu is not accent sensitive 
causes defect 0038041 closedcaristu Cannot log in in the application if the log in warehouse name contains an apostrophe (') 
causes defect 0038051 closedalostale Prevents concurrent sessions for same user not working 

-  Notes
(0095998)
hgbot (developer)
2017-04-12 09:26

Repository: erp/devel/pi
Changeset: c17655a6fb3ffb29cdd5d73073615ba9d60cd941
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Apr 12 08:20:53 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/c17655a6fb3ffb29cdd5d73073615ba9d60cd941 [^]

fixes issue 35553: Improve scalability of the login process

---
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_PREFERENCE.xml
M modules/org.openbravo.client.application/src-db/database/model/tables/OBUIAPP_NAVBAR_COMPONENT.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_ELEMENT.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_FIELD.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/OBCLKER_TEMPLATE.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/OBSERDS_DATASOURCE.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/OBUIAPP_NAVBAR_COMPONENT.xml
M modules/org.openbravo.client.application/src/org/openbravo/client/application/ApplicationComponentProvider.java
M modules/org.openbravo.client.application/src/org/openbravo/client/application/ApplicationConstants.java
M modules/org.openbravo.client.application/src/org/openbravo/client/application/GlobalMenu.java
M modules/org.openbravo.client.application/src/org/openbravo/client/application/MainLayoutComponent.java
M modules/org.openbravo.client.application/src/org/openbravo/client/application/MenuManager.java
M modules/org.openbravo.client.application/src/org/openbravo/client/application/PropertiesComponent.java
M modules/org.openbravo.client.application/src/org/openbravo/client/application/navigationbarcomponents/ApplicationMenuComponent.java
M modules/org.openbravo.client.application/src/org/openbravo/client/application/navigationbarcomponents/UserInfoComponent.java
M modules/org.openbravo.client.application/src/org/openbravo/client/application/navigationbarcomponents/UserInfoWidgetActionHandler.java
M modules/org.openbravo.client.application/src/org/openbravo/client/application/navigationbarcomponents/templates/application-menu.js.ftl
M modules/org.openbravo.client.application/src/org/openbravo/client/application/navigationbarcomponents/templates/user-info.js.ftl
M modules/org.openbravo.client.application/src/org/openbravo/client/application/templates/layout.js.ftl
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/classic/ob-classic-compatibility.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-application-menu.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-quick-launch.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-user-profile-widget.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/test/ob-navbar-test.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities.js
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/ApplicationComponent.java
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/ApplicationDynamicComponent.java
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/KernelComponentProvider.java
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/KernelConstants.java
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/templates/application-js.ftl
M modules/org.openbravo.client.myob/src/org/openbravo/client/myob/MyOpenbravoActionHandler.java
M modules/org.openbravo.client.myob/src/org/openbravo/client/myob/MyOpenbravoComponent.java
M modules/org.openbravo.client.myob/src/org/openbravo/client/myob/MyOpenbravoComponentProvider.java
M modules/org.openbravo.client.myob/src/org/openbravo/client/myob/templates/my_ob_js.ftl
M modules/org.openbravo.client.myob/web/org.openbravo.client.myob/js/ob-community-branding-widget.js
M modules/org.openbravo.client.myob/web/org.openbravo.client.myob/js/ob-myopenbravo.js
M modules/org.openbravo.client.myob/web/org.openbravo.client.myob/js/test/ob-myopenbravo-test.js
M modules/org.openbravo.financial.paymentreport/src-db/database/sourcedata/AD_PREFERENCE.xml
M modules/org.openbravo.reports.ordersawaitingdelivery/src-db/database/sourcedata/AD_PREFERENCE.xml
M src-db/database/sourcedata/AD_PREFERENCE.xml
M src-test/src/org/openbravo/test/datasource/DataSourceSecurity.java
M src-test/src/org/openbravo/test/datasource/DataSourceWhereParameter.java
M src/index.jsp
M src/org/openbravo/erpCommon/ad_process/HeartbeatProcess.java
A modules/org.openbravo.client.application/src/org/openbravo/client/application/HeartBeatPopUpComponent.java
A modules/org.openbravo.client.application/src/org/openbravo/client/application/NavigationBarComponent.java
A modules/org.openbravo.client.application/src/org/openbravo/client/application/NavigationBarComponentGenerator.java
A modules/org.openbravo.client.application/src/org/openbravo/client/application/navigationbarcomponents/RoleInfo.java
A modules/org.openbravo.client.application/src/org/openbravo/client/application/templates/navigation-bar.js.ftl
A modules/org.openbravo.client.application/src/org/openbravo/client/application/templates/ob-heartbeat-registration.js.ftl
A modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-layout.js
A modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-notes-datasource.js
A modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/SessionDynamicResourceComponent.java
A modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/SessionDynamicTemplateComponent.java
R modules/org.openbravo.client.application/src-db/database/sourcedata/OBSERDS_DATASOURCE_FIELD.xml
R modules/org.openbravo.client.application/src/org/openbravo/client/application/HeartBeatPopupActionHandler.java
R modules/org.openbravo.client.application/src/org/openbravo/client/application/navigationbarcomponents/QuickCreateComponent.java
R modules/org.openbravo.client.application/src/org/openbravo/client/application/navigationbarcomponents/QuickCreateDataSource.java
R modules/org.openbravo.client.application/src/org/openbravo/client/application/navigationbarcomponents/QuickLaunchComponent.java
R modules/org.openbravo.client.application/src/org/openbravo/client/application/navigationbarcomponents/QuickLaunchDataSource.java
R modules/org.openbravo.client.application/src/org/openbravo/client/application/navigationbarcomponents/templates/help-about.js.ftl
R modules/org.openbravo.client.application/src/org/openbravo/client/application/navigationbarcomponents/templates/quick-launch.js.ftl
R modules/org.openbravo.client.application/src/org/openbravo/client/application/window/WindowDefinitionComponent.java
---
(0096045)
hgbot (developer)
2017-04-18 08:33

Repository: erp/devel/pi
Changeset: b4942f5e80dabd06f29a1826ff5abbcf0dc36c2f
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Apr 18 08:32:30 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b4942f5e80dabd06f29a1826ff5abbcf0dc36c2f [^]

related to issue 35553: added missing jslint check

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/navigationbarcomponents/templates/user-info.js.ftl
---
(0096046)
caristu (developer)
2017-04-18 08:34

Updated doc about the new static navigation bar components feature: http://wiki.openbravo.com/wiki/How_to_create_a_Navigation_Bar_Component#Static_Navigation_Bar_Components [^]
(0096066)
hgbot (developer)
2017-04-19 15:05

Repository: erp/mods/org.openbravo.activiti
Changeset: b80b9cd0f7b965d12bdd1e2754c1352076bfcdc8
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Apr 19 15:05:02 2017 +0200
URL: http://code.openbravo.com/erp/mods/org.openbravo.activiti/rev/b80b9cd0f7b965d12bdd1e2754c1352076bfcdc8 [^]

related to issue 35553: added new column in src-db

---
M src-db/database/sourcedata/AD_MODULE.xml
M src-db/database/sourcedata/OBUIAPP_NAVBAR_COMPONENT.xml
---
(0096121)
alostale (developer)
2017-04-24 12:04

reviewed as part of the project
(0096886)
hudsonbot (developer)
2017-05-29 17:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1ee70113bdc4 [^]
Maturity status: Test
(0096892)
hudsonbot (developer)
2017-05-29 17:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1ee70113bdc4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-03-17 10:20 caristu New Issue
2017-03-17 10:20 caristu Assigned To => platform
2017-03-17 10:20 caristu Modules => Core
2017-03-17 10:20 caristu Triggers an Emergency Pack => No
2017-03-17 10:20 caristu Assigned To platform => caristu
2017-03-17 10:20 caristu Relationship added related to 0035386
2017-04-03 13:55 caristu Relationship added related to 0035677
2017-04-10 19:23 caristu Relationship added related to 0035746
2017-04-12 09:26 hgbot Checkin
2017-04-12 09:26 hgbot Note Added: 0095998
2017-04-12 09:26 hgbot Status new => resolved
2017-04-12 09:26 hgbot Resolution open => fixed
2017-04-12 09:26 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/c17655a6fb3ffb29cdd5d73073615ba9d60cd941 [^]
2017-04-12 09:36 caristu Review Assigned To => alostale
2017-04-12 11:25 caristu Note Added: 0096009
2017-04-12 12:37 caristu Relationship added causes 0035769
2017-04-12 13:12 caristu Relationship added causes 0035771
2017-04-18 08:33 hgbot Checkin
2017-04-18 08:33 hgbot Note Added: 0096045
2017-04-18 08:34 caristu Note Deleted: 0096009
2017-04-18 08:34 caristu Note Added: 0096046
2017-04-19 15:05 hgbot Checkin
2017-04-19 15:05 hgbot Note Added: 0096066
2017-04-20 08:32 caristu Relationship added causes 0035800
2017-04-24 12:04 alostale Note Added: 0096121
2017-04-24 12:04 alostale Status resolved => closed
2017-04-24 12:04 alostale Fixed in Version => 3.0PR17Q3
2017-04-24 18:32 caristu Relationship added causes 0035825
2017-04-25 15:56 alostale Relationship added related to 0035834
2017-04-27 08:39 caristu Relationship added related to 0035852
2017-05-12 08:31 caristu Relationship added related to 0035980
2017-05-15 10:24 caristu Relationship added related to 0035989
2017-05-15 11:11 caristu Tag Attached: Performance
2017-05-29 17:43 hudsonbot Checkin
2017-05-29 17:43 hudsonbot Note Added: 0096886
2017-05-29 17:43 hudsonbot Checkin
2017-05-29 17:43 hudsonbot Note Added: 0096892
2017-07-20 10:18 alostale Relationship added related to 0036518
2017-11-08 19:05 caristu Relationship added related to 0037267
2017-11-13 13:07 caristu Relationship added causes 0037278
2017-11-14 18:20 caristu Relationship added causes 0037289
2017-11-17 15:01 hgbot Checkin
2017-11-17 15:01 hgbot Note Added: 0100591
2017-11-17 15:04 hgbot Checkin
2017-11-17 15:04 hgbot Note Added: 0100593
2017-11-17 15:26 caristu Note Deleted: 0100591
2017-11-17 15:26 caristu Note Deleted: 0100593
2017-11-20 12:13 alostale Relationship added related to 0037324
2017-11-22 14:52 shuehner Relationship added related to 0037358
2018-01-16 11:17 inigosanchez Relationship added causes 0037624
2018-03-05 16:57 caristu Relationship added caused by 0038041
2018-03-05 16:58 caristu Relationship deleted caused by 0038041
2018-03-05 16:58 caristu Relationship added causes 0038041
2018-03-06 13:46 alostale Relationship added causes 0038051
2019-01-18 10:01 alostale Relationship added related to 0039938
2020-02-28 10:31 alostale Relationship added related to 0043363


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker