Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038051
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2018-03-06 10:472018-03-12 18:27
ReportergorkaionView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR18Q2
StatusclosedFix in branchFixed in SCM revision47941073c4da
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2017-04-12
Regression introduced in release3.0PR17Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/c17655a6fb3ffb29cdd5d73073615ba9d60cd941 [^]
Triggers an Emergency PackNo
Summary

0038051: Prevents concurrent sessions for same user not working

DescriptionWith the system configured to allow one session per user. When a second session is opened a confirmation popup is opened to kill previous sessions, if OK is pressed a white page with the following json is shown instead of log in into the backend.

{"showMessage":true,"messageType":"Error","messageTitle":"Please try again.","messageText":"Invalid user name or password."}
Steps To Reproduce1 Configure the openbravo properties to allow only one session per user by changing the property login.limit.user.session value to true.
2 Restart tomcat and log in to the backedn with user Openbravo.
3 On a different browser or hostname try to log in again with user Openbravo.
4 Check that the concurrent session popup is shown but if OK is pressed the white page appears.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00380573.0PR18Q1.1 closedalostale Prevents concurrent sessions for same user not working 
depends on backport 00380583.0PR17Q4.2 closedalostale Prevents concurrent sessions for same user not working 
caused by feature request 0035553 closedcaristu Improve scalability of the login process 

-  Notes
(0103028)
alostale (developer)
2018-03-06 14:40

TestLink:
https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-10870 [^]
(0103053)
hgbot (developer)
2018-03-07 09:06

Repository: erp/devel/pi
Changeset: 47941073c4da09c262f06f546bc6c41307262184
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Mar 06 14:10:50 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/47941073c4da09c262f06f546bc6c41307262184 [^]

fixed bug 38051: prevents concurrent sessions for same user not working

  When login.limit.user.session is enabled, only one session per named user is
  allowed. In case there is another session for the same user that's currently
  logging in, a confirmation message appears to tell the user other session will
  be cancelled.

  After confirmation, login should be completed, but it failed displaying a blank
  page.

  The problem was caused because instead of resending a POST request to complete
  login, a GET without param values was sent to LoginHandler.

  Now it is fixed, in case of accepeted confirmation diagog, login will be sent
  again.

---
M src/org/openbravo/base/secureApp/LoginHandler.java
M src/org/openbravo/erpCommon/security/Login.html
M web/js/login.js
M web/js/utils.js
---
(0103065)
hudsonbot (developer)
2018-03-07 15:41

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/eee5a0bdc00a [^]
Maturity status: Test
(0103165)
caristu (developer)
2018-03-12 18:27

Code reviewed + tested OK.

- Issue History
Date Modified Username Field Change
2018-03-06 10:47 gorkaion New Issue
2018-03-06 10:47 gorkaion Assigned To => platform
2018-03-06 10:47 gorkaion Modules => Core
2018-03-06 10:47 gorkaion Regression level => Production - Confirmed Stable
2018-03-06 10:47 gorkaion Triggers an Emergency Pack => No
2018-03-06 13:46 alostale Relationship added caused by 0035553
2018-03-06 13:48 alostale Regression date => 2017-04-12
2018-03-06 13:48 alostale Regression introduced in release => 3.0PR17Q3
2018-03-06 13:48 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/c17655a6fb3ffb29cdd5d73073615ba9d60cd941 [^]
2018-03-06 13:48 alostale Severity critical => major
2018-03-06 14:04 alostale Assigned To platform => alostale
2018-03-06 14:04 alostale Review Assigned To => caristu
2018-03-06 14:05 alostale Status new => scheduled
2018-03-06 14:40 alostale Note Added: 0103028
2018-03-07 09:06 hgbot Checkin
2018-03-07 09:06 hgbot Note Added: 0103053
2018-03-07 09:06 hgbot Status scheduled => resolved
2018-03-07 09:06 hgbot Resolution open => fixed
2018-03-07 09:06 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/47941073c4da09c262f06f546bc6c41307262184 [^]
2018-03-07 15:41 hudsonbot Checkin
2018-03-07 15:41 hudsonbot Note Added: 0103065
2018-03-12 16:27 joniturralde93 Issue Monitored: joniturralde93
2018-03-12 18:27 caristu Note Added: 0103165
2018-03-12 18:27 caristu Status resolved => closed
2018-03-12 18:27 caristu Fixed in Version => 3.0PR18Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker