Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035769
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2017-04-12 12:302017-04-24 12:21
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q3
StatusclosedFix in branchFixed in SCM revision9c529a8c8b8d
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035769: Unstable jobs in CI after improving the scalability of the login process

DescriptionAfter improving the scalability of the login process[1] there are some jobs which fails randomly in CI.

[1] http://wiki.openbravo.com/wiki/Projects:Login_Process_Perfomance_Improvements [^]

Steps To ReproduceSee [1] and [2]

[1] https://ci.openbravo.com/job/int-gui-pgsql/2139/ [^]
[2] https://ci.openbravo.com/job/int-modules-pgsql/2127 [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by feature request 0035553 closedcaristu Improve scalability of the login process 

-  Notes
(0096024)
hgbot (developer)
2017-04-12 12:34

Repository: erp/devel/pi
Changeset: dcd984fd5b2f43ef917928f28bd1d0d723dce563
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Apr 12 12:33:01 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/dcd984fd5b2f43ef917928f28bd1d0d723dce563 [^]

fixes issue 35769: do registry before to fix unestabilities in CI

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-user-profile-widget.js
---
(0096032)
hgbot (developer)
2017-04-12 16:46

Repository: erp/devel/pi
Changeset: 901e4bf394d84224755da354bbda7c57f01500c4
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Apr 12 16:45:57 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/901e4bf394d84224755da354bbda7c57f01500c4 [^]

related to issue 35769: do registry before calling super

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-quick-launch.js
---
(0096051)
hgbot (developer)
2017-04-18 13:54

Repository: erp/devel/pi
Changeset: 0777d3f3f9b0b22a8441eec3a7ff46e662698f51
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Apr 18 13:53:45 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/0777d3f3f9b0b22a8441eec3a7ff46e662698f51 [^]

related to issue 35769: improvements in application component and workspace

Two changes have been done in order to try to make failing jobs in CI more stable:

1) Instead of assigning a map in the ftl, the map is cached in the java component (ApplicationComponent). Together with this, the activation key instance is being cached.
2) The heartbeat/registration popups are opened before calling reloadWidgets() for the Workspace.

---
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/ApplicationComponent.java
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/templates/application-js.ftl
M modules/org.openbravo.client.myob/web/org.openbravo.client.myob/js/ob-myopenbravo.js
---
(0096061)
hgbot (developer)
2017-04-19 10:32

Repository: erp/devel/pi
Changeset: a3c3c35ba91c0f127598d2e8fb429485037862e9
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Apr 19 10:26:04 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/a3c3c35ba91c0f127598d2e8fb429485037862e9 [^]

related to issue 35769: register navigation bar elements after initWidget()

Some automatic tests were failing because of some navigation bar elements seemed not to be properly initialized inside the TestRegistry. For this reason these elements are now registered in the TestRegister when they are going to be added into the navigation bar, i.e., after their initWidget method.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/alert-management/ob-alert-manager.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-layout.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-application-menu.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-help-about-widget.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-quick-launch.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-user-profile-widget.js
---
(0096073)
hgbot (developer)
2017-04-20 08:19

Repository: erp/devel/pi
Changeset: 8ddb3fb72e07fba2d2ad02ef697a22854ed6ad09
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Apr 20 08:18:19 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/8ddb3fb72e07fba2d2ad02ef697a22854ed6ad09 [^]

related to issue 35769: disable heartbeat pop-up temporarily

---
M modules/org.openbravo.client.myob/web/org.openbravo.client.myob/js/ob-myopenbravo.js
---
(0096081)
hgbot (developer)
2017-04-20 08:56

Repository: erp/devel/pi
Changeset: f105b4fc8be0b2a4f4b6feda062d968a6e094ecc
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Apr 20 08:55:57 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f105b4fc8be0b2a4f4b6feda062d968a6e094ecc [^]

related to issue 35769: revert changes related with TestRegistry

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/alert-management/ob-alert-manager.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-layout.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-application-menu.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-help-about-widget.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-quick-launch.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-user-profile-widget.js
---
(0096105)
hgbot (developer)
2017-04-21 14:33

Repository: erp/devel/pi
Changeset: 9c529a8c8b8ddbbba648d3ba0cde0c98b4a981dd
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Apr 21 14:28:27 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/9c529a8c8b8ddbbba648d3ba0cde0c98b4a981dd [^]

fixes issue 35769: Firefox browser freezed sometimes after showing some pop-ups

After the changes introduced in project [1], there was a race condition reproducible in Firefox (not in Chrome).

The heartbeat/registration pop-ups are now displayed before the moment they were shown. Together with this, when generating the content of the pop-up, the standard document.write() is used since the very beginning, and according to the documentation[2] it is recommended to call document.close() to tell the browser to finish loading the page.

The document.close() was not being used and this seems to be the root cause of the race condition: by adding this function Firefox is not getting blocked and the instabilities in CI are gone.

[1] http://wiki.openbravo.com/wiki/Projects:Login_Process_Perfomance_Improvements [^]
[2] https://developer.mozilla.org/en-US/docs/Web/API/Document/write [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/classic/ob-classic-compatibility.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-layout.js
M modules/org.openbravo.client.myob/web/org.openbravo.client.myob/js/ob-myopenbravo.js
---
(0096126)
alostale (developer)
2017-04-24 12:21

code reviewed + tested

- Issue History
Date Modified Username Field Change
2017-04-12 12:30 caristu New Issue
2017-04-12 12:30 caristu Assigned To => platform
2017-04-12 12:30 caristu Modules => Core
2017-04-12 12:30 caristu Triggers an Emergency Pack => No
2017-04-12 12:34 hgbot Checkin
2017-04-12 12:34 hgbot Note Added: 0096024
2017-04-12 12:34 hgbot Status new => resolved
2017-04-12 12:34 hgbot Resolution open => fixed
2017-04-12 12:34 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/dcd984fd5b2f43ef917928f28bd1d0d723dce563 [^]
2017-04-12 12:36 caristu Description Updated View Revisions
2017-04-12 12:36 caristu Steps to Reproduce Updated View Revisions
2017-04-12 12:36 caristu Summary Unestable job in CI => Unestable job in CI after improving the scalability of the login process
2017-04-12 12:37 caristu Relationship added caused by 0035553
2017-04-12 13:06 caristu Summary Unestable job in CI after improving the scalability of the login process => Unestable jobs in CI after improving the scalability of the login process
2017-04-12 13:12 caristu Assigned To platform => caristu
2017-04-12 16:14 caristu Summary Unestable jobs in CI after improving the scalability of the login process => Unstable jobs in CI after improving the scalability of the login process
2017-04-12 16:46 hgbot Checkin
2017-04-12 16:46 hgbot Note Added: 0096032
2017-04-18 13:54 hgbot Checkin
2017-04-18 13:54 hgbot Note Added: 0096051
2017-04-19 10:32 hgbot Checkin
2017-04-19 10:32 hgbot Note Added: 0096061
2017-04-20 08:19 hgbot Checkin
2017-04-20 08:19 hgbot Note Added: 0096073
2017-04-20 08:56 hgbot Checkin
2017-04-20 08:56 hgbot Note Added: 0096081
2017-04-21 14:33 hgbot Checkin
2017-04-21 14:33 hgbot Note Added: 0096105
2017-04-21 14:33 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/dcd984fd5b2f43ef917928f28bd1d0d723dce563 [^] => http://code.openbravo.com/erp/devel/pi/rev/9c529a8c8b8ddbbba648d3ba0cde0c98b4a981dd [^]
2017-04-21 14:34 caristu Review Assigned To => alostale
2017-04-24 12:21 alostale Note Added: 0096126
2017-04-24 12:21 alostale Status resolved => closed
2017-04-24 12:21 alostale Fixed in Version => 3.0PR17Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker