Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037289
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2017-11-14 13:452018-01-03 12:39
ReportermalsasuaView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revision63b2919451b9
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2017-04-06
Regression introduced in release3.0PR17Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/c4a5973bba10 [^]
Triggers an Emergency PackNo
Summary

0037289: It is not possible to do login using a role if the role has got a deactivated organization

Descriptionwhen a role has got one deactivate organization, in Role > Org Access, it is not possible to do login. Error is returned:
Error occured: org.openbravo.base.exception.OBException: java.lang.IllegalArgumentException: Error when saving default values
Steps To Reproducein F&B:
. do login with user Openbravo
. go to Role:
  . record: F&B España, S.A - Employee
  . go to org access tab:
     . record: F&B España - Región Norte
       active='N'
. change the role to F&B España, S.A - Employee
Error is returned
Proposed SolutionTake into account the "is active" flag in the queries launched by RoleInfo class. Since the changeset[1] it is using a Query instead of an OBQuery to retrieve the role's organization and warehouses data.

[1] https://code.openbravo.com/erp/devel/pi/rev/c4a5973bba10 [^]
TagsNo tags attached.
Attached Filespng file icon errorWithDeactivatedOrg.png [^] (17,110 bytes) 2017-11-14 13:52

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0032869 acknowledgedplatform cannot switch to a role that's being defined in current session 
related to defect 0037278 closedinigosanchez Deactivated roles are displayed in the role dropdown of user section 
depends on backport 00372933.0PR17Q4 closedinigosanchez It is not possible to do login using a role if the role has got a deactivated organization 
depends on backport 00372943.0PR17Q3.2 closedinigosanchez It is not possible to do login using a role if the role has got a deactivated organization 
caused by feature request 0035553 closedcaristu Improve scalability of the login process 

-  Notes
(0100517)
caristu (developer)
2017-11-14 14:06
edited on: 2017-11-14 18:19

Note that before PR17Q3, this situation could be solved if after the role is completely defined, log out is done before using it.

Now even doing log-out before using the updated role, the problem is still reproducible because the deactivated organization remains for the role within the profile widget.

(0100547)
hgbot (developer)
2017-11-16 12:32

Repository: erp/devel/pi
Changeset: e7913c7e9ed0b954f35dda23bb4db88e9176ecd8
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Nov 16 12:32:13 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e7913c7e9ed0b954f35dda23bb4db88e9176ecd8 [^]

Related with issue 37289: Added tests and some improvements in test class

---
A src-test/src/org/openbravo/test/security/UserInfoSessionDataTest.java
R src-test/src/org/openbravo/test/security/RoleListForTheCurrentUser.java
---
(0100548)
hgbot (developer)
2017-11-16 12:33

Repository: erp/devel/pi
Changeset: 63b2919451b9007643c3c539c5df57ba49664e71
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Nov 16 12:33:12 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/63b2919451b9007643c3c539c5df57ba49664e71 [^]

Fixed issue 37289: Deactivated orgs are displayed in the user profile widget

The problem was caused by the "Improve scalability of the login process" project. When improving the performance
of the query that return the complete organizations list for the current user, the OBQuery instance used to generate it was
replaced with a Query instance. The first includes by default the filter by is active.

To fix the problem this filter must be added manually in the query. Now the problem has been resolved by take into
account this filter. Besides the same problem is detected in other query related with deactivated warehouses so it is fixed too.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/navigationbarcomponents/RoleInfo.java
---
(0100551)
hgbot (developer)
2017-11-16 13:27

Repository: erp/devel/pi
Changeset: e270716dc0046b29c1f17461e1e99cbfa6652d08
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Nov 16 13:27:38 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e270716dc0046b29c1f17461e1e99cbfa6652d08 [^]

Related with issue 37289: Renamed the test in the suite

---
M src-test/src/org/openbravo/test/AllWebserviceTests.java
---
(0100624)
hgbot (developer)
2017-11-20 16:40

Repository: erp/devel/pi
Changeset: ce438d697ac449897f373271995e0cbf295a7f4c
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Mon Nov 20 16:38:44 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/ce438d697ac449897f373271995e0cbf295a7f4c [^]

Related with issue 37289: Some minor improvements in test

---
M src-test/src/org/openbravo/test/security/UserInfoSessionDataTest.java
---
(0100626)
caristu (developer)
2017-11-20 16:51

Code reviewed + tested OK
(0101426)
hudsonbot (developer)
2018-01-03 12:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test
(0101427)
hudsonbot (developer)
2018-01-03 12:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test
(0101428)
hudsonbot (developer)
2018-01-03 12:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test
(0101441)
hudsonbot (developer)
2018-01-03 12:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-11-14 13:45 malsasua New Issue
2017-11-14 13:45 malsasua Assigned To => platform
2017-11-14 13:45 malsasua Modules => Core
2017-11-14 13:45 malsasua Triggers an Emergency Pack => No
2017-11-14 13:52 caristu Steps to Reproduce Updated View Revisions
2017-11-14 13:52 caristu File Added: errorWithDeactivatedOrg.png
2017-11-14 13:59 caristu Review Assigned To => caristu
2017-11-14 13:59 caristu Relationship added duplicate of 0032869
2017-11-14 13:59 caristu Note Added: 0100516
2017-11-14 13:59 caristu Status new => closed
2017-11-14 13:59 caristu Resolution open => duplicate
2017-11-14 14:00 caristu Severity major => minor
2017-11-14 14:00 caristu Type defect => design defect
2017-11-14 14:04 caristu Status closed => new
2017-11-14 14:04 caristu Resolution duplicate => open
2017-11-14 14:04 caristu Severity minor => major
2017-11-14 14:04 caristu Type design defect => defect
2017-11-14 14:04 caristu Relationship deleted 0032869
2017-11-14 14:04 caristu Relationship added related to 0032869
2017-11-14 14:04 caristu Note Deleted: 0100516
2017-11-14 14:06 caristu Note Added: 0100517
2017-11-14 17:30 caristu Relationship added related to 0037278
2017-11-14 18:01 caristu Regression level => Production - QA Approved
2017-11-14 18:01 caristu Regression date => 2017-04-06
2017-11-14 18:01 caristu Regression introduced in release => 3.0PR17Q3
2017-11-14 18:01 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/c4a5973bba10 [^]
2017-11-14 18:17 caristu Proposed Solution updated
2017-11-14 18:19 caristu Note Edited: 0100517 View Revisions
2017-11-14 18:20 caristu Relationship added caused by 0035553
2017-11-14 18:22 caristu Status new => scheduled
2017-11-14 18:22 caristu Assigned To platform => inigosanchez
2017-11-16 12:32 hgbot Checkin
2017-11-16 12:32 hgbot Note Added: 0100547
2017-11-16 12:33 hgbot Checkin
2017-11-16 12:33 hgbot Note Added: 0100548
2017-11-16 12:33 hgbot Status scheduled => resolved
2017-11-16 12:33 hgbot Resolution open => fixed
2017-11-16 12:33 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/63b2919451b9007643c3c539c5df57ba49664e71 [^]
2017-11-16 13:27 hgbot Checkin
2017-11-16 13:27 hgbot Note Added: 0100551
2017-11-16 16:44 caristu Severity major => minor
2017-11-20 16:40 hgbot Checkin
2017-11-20 16:40 hgbot Note Added: 0100624
2017-11-20 16:51 caristu Note Added: 0100626
2017-11-20 16:51 caristu Status resolved => closed
2017-11-20 16:51 caristu Fixed in Version => 3.0PR18Q1
2018-01-03 12:39 hudsonbot Checkin
2018-01-03 12:39 hudsonbot Note Added: 0101426
2018-01-03 12:39 hudsonbot Checkin
2018-01-03 12:39 hudsonbot Note Added: 0101427
2018-01-03 12:39 hudsonbot Checkin
2018-01-03 12:39 hudsonbot Note Added: 0101428
2018-01-03 12:39 hudsonbot Checkin
2018-01-03 12:39 hudsonbot Note Added: 0101441


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker