Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035825
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2017-04-24 18:322017-05-29 17:43
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q3
StatusclosedFix in branchFixed in SCM revisiona49574c6de23
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelAutomated tests
Regression date2017-04-12
Regression introduced in releasepi
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/c17655a6fb3ffb29cdd5d73073615ba9d60cd941 [^]
Triggers an Emergency PackNo
Summary

0035825: Default org/warehouse not sorted properly in profile widget

DescriptionAfter the changes introduced in the following project[1]. The default organization/warehouse selected when changing the role in the user profile window is not taken using the alphabetical order. This is causing failures in some CI tests[2],[3].


[1] http://wiki.openbravo.com/wiki/Projects:Login_Process_Perfomance_Improvements [^]
[2] http://ci.openbravo.com/view/qa/job/qa-pi-aprinreg-pgsql/714/ [^]
[3] http://ci.openbravo.com/view/qa/job/qa-pi-aproutreg-pgsql/719/ [^]
Steps To Reproduce1) Log-in
2) In the user profile window, select the "F&B España, S.A. - Finance" role.
3) The organization taken by default is "F&B España, S.A" instead of "F&B España - Región Norte"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by feature request 0035553 closedcaristu Improve scalability of the login process 

-  Notes
(0096139)
hgbot (developer)
2017-04-24 18:46

Repository: erp/devel/pi
Changeset: a49574c6de23574338713a7e36086476e5fce9fe
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Apr 24 18:41:02 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/a49574c6de23574338713a7e36086476e5fce9fe [^]

fixes bug 35825: Default org/warehouse not sorted properly in profile widget

After the changes introduced on issue 0035553, the content of the profile widget fields (role, organization, warehouse) is sorted in the client side. The sorting was already being done when displaying the pick lists, but the value map used by those fields was not being sorted.

The default value of the org/warehouse fields when changing the role is the first value of their respective value maps. For this reason, since now the value maps for those fields is always sorted: the OB.User.userInfo object is instantiated with the mentioned value maps sorted by identifier, thanks to the call to 'sortByProperty' added in the user-info.js.ftl template.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/navigationbarcomponents/templates/user-info.js.ftl
---
(0096250)
alostale (developer)
2017-04-28 08:50

code reviewed + tested
(0096903)
hudsonbot (developer)
2017-05-29 17:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1ee70113bdc4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-04-24 18:32 caristu New Issue
2017-04-24 18:32 caristu Assigned To => caristu
2017-04-24 18:32 caristu Modules => Core
2017-04-24 18:32 caristu Regression level => Automated tests
2017-04-24 18:32 caristu Regression date => 2017-04-12
2017-04-24 18:32 caristu Regression introduced in release => pi
2017-04-24 18:32 caristu Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/c17655a6fb3ffb29cdd5d73073615ba9d60cd941 [^]
2017-04-24 18:32 caristu Triggers an Emergency Pack => No
2017-04-24 18:32 caristu Relationship added caused by 0035553
2017-04-24 18:46 hgbot Checkin
2017-04-24 18:46 hgbot Note Added: 0096139
2017-04-24 18:46 hgbot Status new => resolved
2017-04-24 18:46 hgbot Resolution open => fixed
2017-04-24 18:46 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a49574c6de23574338713a7e36086476e5fce9fe [^]
2017-04-24 18:46 caristu Review Assigned To => alostale
2017-04-28 08:50 alostale Note Added: 0096250
2017-04-28 08:50 alostale Status resolved => closed
2017-04-28 08:50 alostale Fixed in Version => 3.0PR17Q3
2017-05-29 17:43 hudsonbot Checkin
2017-05-29 17:43 hudsonbot Note Added: 0096903


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker