Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037624
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2018-01-11 18:122018-02-22 18:18
ReporterJONHMView Statuspublic 
Assigned Toinigosanchez 
PriorityimmediateResolutionfixedFixed in Version3.0PR18Q2
StatusclosedFix in branchFixed in SCM revision2c78dc4d9f1b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2017-04-12
Regression introduced in release3.0PR17Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/c17655a6fb3ffb29cdd5d73073615ba9d60cd941 [^]
Triggers an Emergency PackNo
Summary

0037624: Filter on quick launch menu is not accent sensitive

DescriptionFilter on quick launch menu is not accent sensitive since 17Q3.
Steps To Reproduce1) As System administrator, open 'Menu' window and modify 'ABC Activity' > 'ÁBC Activity' (set an accent)
2) Switch to 'F&B International Group Admin' role and seek for "ABC Activity" on menu's quick launch.
> No items to show
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0018283 closeddbaz 0016891: "Quick Launch" and "Create New" sensitivity Description: accents 
related to defect 0037704 closedplatform Ignore accents in filters and selectors 
depends on backport 00376843.0PR18Q1 closedinigosanchez Filter on quick launch menu is not accent sensitive 
depends on backport 00376853.0PR17Q4.1 closedinigosanchez Filter on quick launch menu is not accent sensitive 
depends on backport 00376863.0PR17Q3.3 closedinigosanchez Filter on quick launch menu is not accent sensitive 
caused by feature request 0035553 closedcaristu Improve scalability of the login process 

-  Notes
(0101800)
hgbot (developer)
2018-01-19 14:42

Repository: erp/devel/pi
Changeset: 2c78dc4d9f1b5fcda9b10408f4fba394888cbd01
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri Jan 19 14:41:38 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/2c78dc4d9f1b5fcda9b10408f4fba394888cbd01 [^]

Fixed issue 37624: Filter on quick launch menu is not accent sensitive

After the changes introduced in the "Improve scalability of the login process" project on issue 0035553, the quick launch menu no longer used the specific datasource. The datasource has a fieldMatchesFilter method that allow searchs not distinguish between accent or non-accent words. Since the changes were introduced, the data is filter in the client instead of in the datasource and for this reason the fieldMatchesFilter method is not executed.

To fix the problem two main actions have been done:
- Small clean code moving the functionality of fieldMatchesFilter method to ob-utilities in order to avoid duplicated code.
- The getQuickMenuItems method must be save the identifiers without accents using the method previosuly created in ob-utilities. It has been done the same with the value returned in the getPickListFilterCriteria method.

Removing the accents in the items of the filter in ob-quick-launch.js the problem has been resolved. The accents are now ignored in Quick launch Menu' suggestion combobox.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-quick-launch.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities.js
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/js/ob-smartclient.js
---
(0101819)
caristu (developer)
2018-01-22 10:54
edited on: 2018-01-22 10:57

Accents are being removed also in the displayed name of the menu entries.

We are now setting the identifier without accents in order to return the expected results when filtering. Therefore we now can't use it as the displayed field.

To fix this problem we can make use of the 'title' field instead.

See: https://docs.google.com/spreadsheets/d/18l2biKWeG6iGDIPqO6VuYQ_TtP_6YxyQU4KSrPvQlJ8/edit#gid=0 [^]

(0101835)
hgbot (developer)
2018-01-22 12:50

Repository: erp/devel/pi
Changeset: b9693156c2c734b53032858826fdffd352a82a0d
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Jan 22 12:49:53 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/b9693156c2c734b53032858826fdffd352a82a0d [^]

related to bug 37624: use title field as the display value for the menu entries

  As now the _identifier contains the title text but without accents, it can not be used as the display field because in that case it would not be possible to show menu entries with accents. For this reason we now use the title field as the display field.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-quick-launch.js
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/templates/application-js.ftl
---
(0101893)
AugustoMauch (developer)
2018-01-23 10:53

Code reviewed and verified
(0102668)
hudsonbot (developer)
2018-02-22 18:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/980a6ad5bbf5 [^]
Maturity status: Test
(0102675)
hudsonbot (developer)
2018-02-22 18:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/980a6ad5bbf5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-01-11 18:12 JONHM New Issue
2018-01-11 18:12 JONHM Assigned To => platform
2018-01-11 18:12 JONHM Modules => Core
2018-01-11 18:12 JONHM Triggers an Emergency Pack => No
2018-01-11 18:20 Practics Issue Monitored: Practics
2018-01-15 14:19 inigosanchez Assigned To platform => inigosanchez
2018-01-15 14:19 inigosanchez Status new => acknowledged
2018-01-16 10:58 inigosanchez Relationship added related to 0018283
2018-01-16 11:17 inigosanchez Relationship added caused by 0035553
2018-01-16 11:20 inigosanchez Regression level => Production - Confirmed Stable
2018-01-16 11:20 inigosanchez Regression date => 2017-04-12
2018-01-16 11:20 inigosanchez Regression introduced in release => 3.0PR17Q3
2018-01-16 11:20 inigosanchez Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/c17655a6fb3ffb29cdd5d73073615ba9d60cd941 [^]
2018-01-19 10:42 inigosanchez Status acknowledged => scheduled
2018-01-19 14:41 inigosanchez Review Assigned To => caristu
2018-01-19 14:42 hgbot Checkin
2018-01-19 14:42 hgbot Note Added: 0101800
2018-01-19 14:42 hgbot Status scheduled => resolved
2018-01-19 14:42 hgbot Resolution open => fixed
2018-01-19 14:42 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2c78dc4d9f1b5fcda9b10408f4fba394888cbd01 [^]
2018-01-22 10:54 caristu Note Added: 0101819
2018-01-22 10:54 caristu Status resolved => new
2018-01-22 10:54 caristu Resolution fixed => open
2018-01-22 10:57 caristu Note Edited: 0101819 View Revisions
2018-01-22 12:50 hgbot Checkin
2018-01-22 12:50 hgbot Note Added: 0101835
2018-01-22 12:51 caristu Status new => acknowledged
2018-01-22 12:51 caristu Status acknowledged => scheduled
2018-01-22 12:51 caristu Status scheduled => resolved
2018-01-22 12:51 caristu Resolution open => fixed
2018-01-22 12:51 caristu Review Assigned To caristu => AugustoMauch
2018-01-23 10:23 AugustoMauch Relationship added related to 0037704
2018-01-23 10:53 AugustoMauch Note Added: 0101893
2018-01-23 10:53 AugustoMauch Status resolved => closed
2018-01-23 10:53 AugustoMauch Fixed in Version => 3.0PR18Q2
2018-02-22 18:18 hudsonbot Checkin
2018-02-22 18:18 hudsonbot Note Added: 0102668
2018-02-22 18:18 hudsonbot Checkin
2018-02-22 18:18 hudsonbot Note Added: 0102675


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker