Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037686
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminoralways2018-01-11 18:122018-01-23 10:28
ReporterJONHMView Statuspublic 
Assigned Toinigosanchez 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q3.3
StatusclosedFix in branchFixed in SCM revision55749dea3711
ProjectionnoneETAnoneTarget Version3.0PR17Q3.3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2017-04-12
Regression introduced in release3.0PR17Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/c17655a6fb3ffb29cdd5d73073615ba9d60cd941 [^]
Triggers an Emergency PackNo
Summary

0037686: Filter on quick launch menu is not accent sensitive

DescriptionFilter on quick launch menu is not accent sensitive since 17Q3.
Steps To Reproduce1) As System administrator, open 'Menu' window and modify 'ABC Activity' > 'ÁBC Activity' (set an accent)
2) Switch to 'F&B International Group Admin' role and seek for "ABC Activity" on menu's quick launch.
> No items to show
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0037624 closedinigosanchez Filter on quick launch menu is not accent sensitive 

-  Notes
(0101793)
hgbot (developer)
2018-01-19 14:08

Repository: erp/backports/3.0PR17Q3.3
Changeset: 55749dea37114c018ae820b696f30258788566fb
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri Jan 19 14:08:00 2018 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR17Q3.3/rev/55749dea37114c018ae820b696f30258788566fb [^]

Fixed issue 37686: Filter on quick launch menu is not accent sensitive

After the changes introduced in the "Improve scalability of the login process" project on issue 0035553, the quick launch menu no longer used the specific datasource. The datasource has a fieldMatchesFilter method that allow searchs not distinguish between accent or non-accent words. Since the changes were introduced, the data is filter in the client instead of in the datasource and for this reason the fieldMatchesFilter method is not executed.

To fix the problem two main actions have been done:
- Small clean code moving the functionality of fieldMatchesFilter method to ob-utilities in order to avoid duplicated code.
- The getQuickMenuItems method must be save the identifiers without accents using the method previosuly created in ob-utilities. It has been done the same with the value returned in the getPickListFilterCriteria method.

Removing the accents in the items of the filter in ob-quick-launch.js the problem has been resolved. The accents are now ignored in Quick launch Menu' suggestion combobox.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-quick-launch.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities.js
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/js/ob-smartclient.js
---
(0101822)
caristu (developer)
2018-01-22 11:03

See: https://docs.google.com/spreadsheets/d/18l2biKWeG6iGDIPqO6VuYQ_TtP_6YxyQU4KSrPvQlJ8/edit#gid=0 [^] [^]
(0101853)
hgbot (developer)
2018-01-22 16:17

Repository: erp/backports/3.0PR17Q3.3
Changeset: 8bb37cf0509becfe81b5da582d94f60687f1c84d
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Jan 22 12:49:53 2018 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR17Q3.3/rev/8bb37cf0509becfe81b5da582d94f60687f1c84d [^]

related to bug 37686: use title field as the display value for the menu entries

  As now the _identifier contains the title text but without accents, it can not be used as the display field because in that case it would not be possible to show menu entries with accents. For this reason we now use the title field as the display field.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-quick-launch.js
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/templates/application-js.ftl
---
(0101890)
AugustoMauch (developer)
2018-01-23 10:28

Code reviewed and verified

- Issue History
Date Modified Username Field Change
2018-01-19 10:42 inigosanchez Type defect => backport
2018-01-19 10:42 inigosanchez Target Version => 3.0PR17Q3.3
2018-01-19 14:07 inigosanchez Review Assigned To => caristu
2018-01-19 14:08 hgbot Checkin
2018-01-19 14:08 hgbot Note Added: 0101793
2018-01-19 14:08 hgbot Status scheduled => resolved
2018-01-19 14:08 hgbot Resolution open => fixed
2018-01-19 14:08 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR17Q3.3/rev/55749dea37114c018ae820b696f30258788566fb [^]
2018-01-22 11:03 caristu Note Added: 0101822
2018-01-22 11:03 caristu Status resolved => new
2018-01-22 11:03 caristu Resolution fixed => open
2018-01-22 16:17 hgbot Checkin
2018-01-22 16:17 hgbot Note Added: 0101853
2018-01-22 16:18 caristu Status new => acknowledged
2018-01-22 16:18 caristu Status acknowledged => scheduled
2018-01-22 16:18 caristu Status scheduled => resolved
2018-01-22 16:18 caristu Resolution open => fixed
2018-01-22 16:18 caristu Review Assigned To caristu => AugustoMauch
2018-01-23 10:28 AugustoMauch Note Added: 0101890
2018-01-23 10:28 AugustoMauch Status resolved => closed
2018-01-23 10:28 AugustoMauch Fixed in Version => 3.0PR17Q3.3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker