Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037685
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminoralways2018-01-11 18:122018-01-23 10:34
ReporterJONHMView Statuspublic 
Assigned Toinigosanchez 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q4.1
StatusclosedFix in branchFixed in SCM revision2980f02e5193
ProjectionnoneETAnoneTarget Version3.0PR17Q4.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2017-04-12
Regression introduced in release3.0PR17Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/c17655a6fb3ffb29cdd5d73073615ba9d60cd941 [^]
Triggers an Emergency PackNo
Summary

0037685: Filter on quick launch menu is not accent sensitive

DescriptionFilter on quick launch menu is not accent sensitive since 17Q3.
Steps To Reproduce1) As System administrator, open 'Menu' window and modify 'ABC Activity' > 'ÁBC Activity' (set an accent)
2) Switch to 'F&B International Group Admin' role and seek for "ABC Activity" on menu's quick launch.
> No items to show
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0037624 closedinigosanchez Filter on quick launch menu is not accent sensitive 

-  Notes
(0101794)
hgbot (developer)
2018-01-19 14:28

Repository: erp/backports/3.0PR17Q4.1
Changeset: 8d914985ce24392daa532104e947f8d6a53373b1
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri Jan 19 14:27:19 2018 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR17Q4.1/rev/8d914985ce24392daa532104e947f8d6a53373b1 [^]

Related to issue 37685: Fix jslint error by adding missing semicolon

---
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/js/ob-smartclient.js
---
(0101795)
hgbot (developer)
2018-01-19 14:28

Repository: erp/backports/3.0PR17Q4.1
Changeset: 2980f02e519337ae823ef3ca1338c4460a58e86a
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri Jan 19 14:27:38 2018 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR17Q4.1/rev/2980f02e519337ae823ef3ca1338c4460a58e86a [^]

Fixed issue 37685: Filter on quick launch menu is not accent sensitive

After the changes introduced in the "Improve scalability of the login process" project on issue 0035553, the quick launch menu no longer used the specific datasource. The datasource has a fieldMatchesFilter method that allow searchs not distinguish between accent or non-accent words. Since the changes were introduced, the data is filter in the client instead of in the datasource and for this reason the fieldMatchesFilter method is not executed.

To fix the problem two main actions have been done:
- Small clean code moving the functionality of fieldMatchesFilter method to ob-utilities in order to avoid duplicated code.
- The getQuickMenuItems method must be save the identifiers without accents using the method previosuly created in ob-utilities. It has been done the same with the value returned in the getPickListFilterCriteria method.

Removing the accents in the items of the filter in ob-quick-launch.js the problem has been resolved. The accents are now ignored in Quick launch Menu' suggestion combobox.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-quick-launch.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities.js
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/js/ob-smartclient.js
---
(0101821)
caristu (developer)
2018-01-22 11:03

See: https://docs.google.com/spreadsheets/d/18l2biKWeG6iGDIPqO6VuYQ_TtP_6YxyQU4KSrPvQlJ8/edit#gid=0 [^] [^]
(0101855)
hgbot (developer)
2018-01-22 16:49

Repository: erp/backports/3.0PR17Q4.1
Changeset: a4a2c816e68623875800aaab70a8af1761bb079c
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Jan 22 12:49:53 2018 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR17Q4.1/rev/a4a2c816e68623875800aaab70a8af1761bb079c [^]

related to bug 37685: use title field as the display value for the menu entries

  As now the _identifier contains the title text but without accents, it can not be used as the display field because in that case it would not be possible to show menu entries with accents. For this reason we now use the title field as the display field.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-quick-launch.js
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/templates/application-js.ftl
---
(0101891)
AugustoMauch (developer)
2018-01-23 10:34

Code reviewed and verified

- Issue History
Date Modified Username Field Change
2018-01-19 10:42 inigosanchez Type defect => backport
2018-01-19 10:42 inigosanchez Target Version => 3.0PR17Q4.1
2018-01-19 14:17 inigosanchez Review Assigned To => caristu
2018-01-19 14:28 hgbot Checkin
2018-01-19 14:28 hgbot Note Added: 0101794
2018-01-19 14:28 hgbot Checkin
2018-01-19 14:28 hgbot Note Added: 0101795
2018-01-19 14:28 hgbot Status scheduled => resolved
2018-01-19 14:28 hgbot Resolution open => fixed
2018-01-19 14:28 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR17Q4.1/rev/2980f02e519337ae823ef3ca1338c4460a58e86a [^]
2018-01-22 11:03 caristu Note Added: 0101821
2018-01-22 11:03 caristu Status resolved => new
2018-01-22 11:03 caristu Resolution fixed => open
2018-01-22 16:49 hgbot Checkin
2018-01-22 16:49 hgbot Note Added: 0101855
2018-01-22 16:50 caristu Status new => acknowledged
2018-01-22 16:50 caristu Status acknowledged => scheduled
2018-01-22 16:50 caristu Status scheduled => resolved
2018-01-22 16:50 caristu Resolution open => fixed
2018-01-22 16:50 caristu Review Assigned To caristu => AugustoMauch
2018-01-23 10:34 AugustoMauch Note Added: 0101891
2018-01-23 10:34 AugustoMauch Status resolved => closed
2018-01-23 10:34 AugustoMauch Fixed in Version => 3.0PR17Q4.1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker