Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031989
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2016-01-22 11:032016-08-25 15:08
ReportermaiteView Statuspublic 
Assigned Tocaristu 
PriorityurgentResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revision905bb6ff4ee7
ProjectionnoneETAnoneTarget Version3.0PR16Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031989: Wrong behavior in order/invoices grid in Add Payment process definition when having >100 records selected

DescriptionWhen you select >100 records, different inconsistent behavior is observed:

- only first 100 records are selected
- no proper filtering is performed
- when sorting, "loading data" infinite message is shown
Steps To Reproduce1. Access as System Administrator and configure "Grid filtering at window/tab/field level" to obtain better performance experience:
  * Tab: Order Invoices - Order Invoice P&E
  * Filter on change= no
2. Access Payment In window and create header record
3. Run Add details process and select 103 records, for example. Process and realize that all details have been properly added
4. Run reactivate selecting "Reactivate" option
5. Run Add details process again. Your 100 first records are loaded and selected. Scroll down and realize that next page is loaded but only 100 are selected instead of 103 (ERROR 1)
6. At this point, try to filter by an invoice document number (for example) which will return several results (you will need to change focus to execute filtering) and realize that only 2 records are obtained (ERROR 2)
7. Click on Invoice field to sort grid and realize that more values matching previous filtering criteria are obtained (ERROR 3)
8. Modify invoice document number value to run different filtering and "loading data" message will be shown (ERROR 4)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00320913.0PR16Q2 closedcaristu The Order/Invoices grid in Add Details must always sort by selected records first 
related to defect 0032193 closedcaristu Selection is not working properly in P&E grids having filter on change option set to N 
related to defect 0033622 closedcaristu Wrong behavior in Select Payment Pick/Execute Window when having >100 records selected 
related to design defect 0036140 newplatform Pick/edit grid is not compatible with high volumes: number of selected records is limited by MAX_PAGE_SIZE_INCREASE 
related to defect 0040381 closedalostale incorrect warn message logged by ReadOnlyDataSourceService for P&E  
causes defect 0035396 closedmcobas Cannot remove an orphan line from a return to vendor or a return from customer document 

-  Notes
(0083534)
maite (developer)
2016-01-22 11:16

I can provide environment where problem is reproducible
(0083902)
hgbot (developer)
2016-02-03 19:31

Repository: erp/devel/pi
Changeset: 905bb6ff4ee73e47c6fe246490ba5fb6df11b7ea
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Feb 03 19:26:25 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/905bb6ff4ee73e47c6fe246490ba5fb6df11b7ea [^]

fixes issue 31989: Wrong behavior in P&E grids having > 100 records selected
After performing a filter/ordering action, the selected records could go out of the first page, causing the Add Payment process crash inside updateInvOrderTotal function (executed on grid load), because the selected record could not be found on the local data.
To avoid the problem now the ReadOnlyDataSource fetches all the selected records in the first page, increasing the page size if necessary. Together with this, all the P&E processes must ensure that the data is always ordered by showing first the selected records.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/templates/application-js.ftl
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/ReadOnlyDataSourceService.java
---
(0083944)
alostale (developer)
2016-02-05 08:46

code reviewed + tested
(0085101)
hudsonbot (developer)
2016-03-17 10:55

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-01-22 11:03 maite New Issue
2016-01-22 11:03 maite Assigned To => platform
2016-01-22 11:03 maite Web browser => Apple Safari
2016-01-22 11:03 maite Modules => Core
2016-01-22 11:03 maite Triggers an Emergency Pack => No
2016-01-22 11:16 maite Issue Monitored: networkb
2016-01-22 11:16 maite Web browser Apple Safari => Apple Safari
2016-01-22 11:16 maite Note Added: 0083534
2016-01-22 12:30 heccam Issue Monitored: heccam
2016-01-22 14:54 maite Web browser Apple Safari =>
2016-01-29 10:06 alostale Status new => acknowledged
2016-01-29 14:23 caristu Status acknowledged => scheduled
2016-01-29 14:23 caristu Assigned To platform => caristu
2016-02-02 13:33 caristu Relationship added related to 0032091
2016-02-03 19:31 hgbot Checkin
2016-02-03 19:31 hgbot Note Added: 0083902
2016-02-03 19:31 hgbot Status scheduled => resolved
2016-02-03 19:31 hgbot Resolution open => fixed
2016-02-03 19:31 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/905bb6ff4ee73e47c6fe246490ba5fb6df11b7ea [^]
2016-02-03 19:32 caristu Review Assigned To => alostale
2016-02-03 19:33 caristu Issue Monitored: alostale
2016-02-05 08:46 alostale Note Added: 0083944
2016-02-05 08:46 alostale Status resolved => closed
2016-02-05 08:46 alostale Fixed in Version => 3.0PR16Q2
2016-02-11 11:55 caristu Relationship added related to 0032193
2016-03-17 10:55 hudsonbot Checkin
2016-03-17 10:55 hudsonbot Note Added: 0085101
2016-08-12 15:20 caristu Relationship added related to 0033622
2016-08-25 10:24 hgbot Checkin
2016-08-25 10:24 hgbot Note Added: 0089376
2016-08-25 10:48 caristu Note Deleted: 0089376
2016-08-25 15:08 hudsonbot Checkin
2016-08-25 15:08 hudsonbot Note Added: 0089400
2016-08-25 15:08 caristu Note Deleted: 0089400
2017-03-02 20:24 markmm82 Relationship added causes 0035396
2017-05-31 12:41 caristu Relationship added related to 0036140
2019-03-22 10:06 alostale Relationship added related to 0040381


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker