Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040381
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementminoralways2019-03-14 12:172019-03-28 14:56
Reporterinaki_garciaView Statuspublic 
Assigned Toalostale 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q2
StatusclosedFix in branchFixed in SCM revisiona810b4994a69
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040381: incorrect warn message logged by ReadOnlyDataSourceService for P&E

DescriptionIn Return to Vendor window, Pick/Edit a warning message is logged when it is opened having Lines records previously selected.

This issue has been identified by qa-pi-returnto-pgsql job of the QA tab in CI when the job is set to perform "install.source", and is also manually reproducible.
Steps To Reproduce1. Log in as Group Admin
2. Create a new header in Return to Vendor window
3. Click on Pick/Edit button
4. Select one record and click on Done
5. Click again on Pick/Edit button
  -> Check log:

2019-03-13 10:09:46,615 [http-2] WARN org.openbravo.service.datasource.ReadOnlyDataSourceService - The amount of selected records is higher than the maximum page size allowed.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0036193 closedalostale DefaultJsonDataService logs an exception if property *obSelected* is not found in the Entity when fetching data for PickAndEdit 
related to defect 0039644 closedalostale Add product p&e is not sorting the selected records when clearing filters 
related to defect 00319893.0PR16Q2 closedcaristu Wrong behavior in order/invoices grid in Add Payment process definition when having >100 records selected 
related to defect 0035396 closedmcobas Cannot remove an orphan line from a return to vendor or a return from customer document 
blocks design defect 0036162 acknowledgedplatform clean up openbravo.log 

-  Notes
(0110585)
hgbot (developer)
2019-03-22 11:02

Repository: erp/devel/pi
Changeset: a810b4994a69de230e1966a37e360e646246121a
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Mar 22 10:56:16 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/a810b4994a69de230e1966a37e360e646246121a [^]

fixed bug 40381: incorrect warn logged by ReadOnlyDataSourceService for P&E

  RODSS increases page size up to a limit in case last record is selected in
  order to retrieve all selected records. The logic to detect whether this
  increase is necessary was not considering the case of all records being
  selected because the filter is restrictive enough.

  This is now fixed by increasing it only in case the amount of selected records
  is bigger than the actual page size.

---
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/ReadOnlyDataSourceService.java
---
(0110586)
hgbot (developer)
2019-03-22 11:02

Repository: erp/devel/pi
Changeset: 38f6527079acc33e22045fb6ab9c08206e99ba51
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Mar 22 11:01:34 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/38f6527079acc33e22045fb6ab9c08206e99ba51 [^]

related to bug 40381: add some context info to the log

---
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/ReadOnlyDataSourceService.java
---
(0110673)
hgbot (developer)
2019-03-27 11:12

Repository: erp/devel/pi
Changeset: 0f7bd818ce073affb38125539eced37449f140f9
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Mar 27 11:11:53 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/0f7bd818ce073affb38125539eced37449f140f9 [^]

related to bug 40381: minor code improvements

  - Use instanceof to check the type of the obSelected field
  - Use constant instead of using "Only fetch is supported" literal 3 times

---
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/ReadOnlyDataSourceService.java
---
(0110683)
caristu (developer)
2019-03-27 13:04

Reviewed + tested OK.
(0110883)
hudsonbot (developer)
2019-03-28 14:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test
(0110884)
hudsonbot (developer)
2019-03-28 14:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test
(0110895)
hudsonbot (developer)
2019-03-28 14:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-03-14 12:17 inaki_garcia New Issue
2019-03-14 12:17 inaki_garcia Assigned To => platform
2019-03-14 12:17 inaki_garcia Modules => Core
2019-03-14 12:17 inaki_garcia Triggers an Emergency Pack => No
2019-03-14 12:29 inaki_garcia Assigned To platform => aferraz
2019-03-14 12:29 inaki_garcia Category A. Platform => 09. Financial management
2019-03-14 13:21 Sandrahuguet Assigned To aferraz => markmm82
2019-03-14 13:25 aferraz Assigned To markmm82 => Triage Finance
2019-03-14 13:28 Sandrahuguet Assigned To Triage Finance => markmm82
2019-03-14 17:19 markmm82 Status new => scheduled
2019-03-22 09:13 alostale Assigned To markmm82 => platform
2019-03-22 09:13 alostale Status scheduled => feedback
2019-03-22 09:13 alostale Summary ReadOnlyDataSourceService throws a warning in Tomcat log when editting/deleting an RTV line on a newly set up context => incorrect warn message logged by ReadOnlyDataSourceService for P&E
2019-03-22 09:13 alostale Description Updated View Revisions
2019-03-22 09:13 alostale Steps to Reproduce Updated View Revisions
2019-03-22 09:13 alostale Status feedback => new
2019-03-22 09:14 alostale Relationship added blocks 0036162
2019-03-22 09:14 alostale Status new => acknowledged
2019-03-22 09:57 alostale Relationship added related to 0036193
2019-03-22 10:05 alostale Relationship added related to 0039644
2019-03-22 10:06 alostale Relationship added related to 0031989
2019-03-22 10:52 alostale Assigned To platform => alostale
2019-03-22 10:53 alostale Review Assigned To => caristu
2019-03-22 11:02 hgbot Checkin
2019-03-22 11:02 hgbot Note Added: 0110585
2019-03-22 11:02 hgbot Status acknowledged => resolved
2019-03-22 11:02 hgbot Resolution open => fixed
2019-03-22 11:02 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a810b4994a69de230e1966a37e360e646246121a [^]
2019-03-22 11:02 hgbot Checkin
2019-03-22 11:02 hgbot Note Added: 0110586
2019-03-27 10:54 caristu Relationship added related to 0035396
2019-03-27 11:12 hgbot Checkin
2019-03-27 11:12 hgbot Note Added: 0110673
2019-03-27 13:04 caristu Note Added: 0110683
2019-03-27 13:04 caristu Status resolved => closed
2019-03-27 13:04 caristu Fixed in Version => 3.0PR19Q2
2019-03-28 14:56 hudsonbot Checkin
2019-03-28 14:56 hudsonbot Note Added: 0110883
2019-03-28 14:56 hudsonbot Checkin
2019-03-28 14:56 hudsonbot Note Added: 0110884
2019-03-28 14:56 hudsonbot Checkin
2019-03-28 14:56 hudsonbot Note Added: 0110895


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker