Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035396
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2017-03-01 15:092017-03-15 20:21
ReporterngarciaView Statuspublic 
Assigned Tomcobas 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revision9d671a527e68
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarkmm82
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2016-02-03
Regression introduced in release3.0PR16Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/905bb6ff4ee7 [^]
Triggers an Emergency PackNo
Summary

0035396: Cannot remove an orphan line from a return to vendor or a return from customer document

DescriptionCannot remove an orphan line from a return to vendor or a return from customer document
Steps To ReproduceAs group admin role:
   Set the 'RM Allow Orphan Line' to Y
   Log out and log in
   Create a Return To Vendor header
   Insert Orphan Line
   Click Pick/Edit Lines button
   Check No Items to Show is shown in Orphan Lines section

   Create a Return From Customer header
   Insert Orphan Line
   Click Pick/Edit Lines button
   Check 'No Items to Show' is shown in Orphan Lines section
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00354193.0PR17Q1 closedmcobas Cannot remove an orphan line from a return to vendor or a return from customer document 
depends on backport 00354203.0PR16Q4.3 closedmcobas Cannot remove an orphan line from a return to vendor or a return from customer document 
depends on backport 00354213.0PR16Q3.6 closedmcobas Cannot remove an orphan line from a return to vendor or a return from customer document 
caused by defect 00319893.0PR16Q2 closedcaristu Wrong behavior in order/invoices grid in Add Payment process definition when having >100 records selected 

-  Notes
(0094700)
markmm82 (developer)
2017-03-02 20:00

As group admin role:
   Set the 'RM Allow Orphan Line' to Y
   Log out and log in
   Create a Return To Vendor header
   Insert Orphan Line
   Click Pick/Edit Lines button
   Check the previous created line is shown in Orphan Lines section
   Uncheck and DONE
   Notice the orphan line has been deleted from the RTV

   Create a Return From Customer header
   Insert Orphan Line
   Click Pick/Edit Lines button
   Check the previous created line is shown in Orphan Lines section
   Uncheck and DONE
   Notice the orphan line has been deleted from the RFC
(0094755)
hgbot (developer)
2017-03-04 14:40

Repository: erp/devel/pi
Changeset: 9d671a527e68e81acd632c9ec28a5af06f59084a
Author: Miguel <martencobasmiguel <at> gmail.com>
Date: Thu Mar 02 13:32:12 2017 -0500
URL: http://code.openbravo.com/erp/devel/pi/rev/9d671a527e68e81acd632c9ec28a5af06f59084a [^]

Fixes issue 35396:Cannot remove an orphan line in Return to/from vendor/customer

Was not able to remove an orphan line from a return to vendor or a return from
customer document because an incorrect casting to boolean.

When is validating tha Last record is selected inside the Orphan grid lines, the
lastRecord.get("obSelected") object gets as String instead of a Boolean object,
in other case it gets as Boolean.

Now, conditions are rightly validated depending of the class of the object.

---
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/ReadOnlyDataSourceService.java
---
(0094762)
markmm82 (developer)
2017-03-04 14:53

Code review + Testing OK
(0095270)
hudsonbot (developer)
2017-03-15 20:21

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-03-01 15:09 ngarcia New Issue
2017-03-01 15:09 ngarcia Assigned To => Triage Finance
2017-03-01 15:09 ngarcia Modules => Core
2017-03-01 15:09 ngarcia Triggers an Emergency Pack => No
2017-03-01 15:10 ngarcia Issue Monitored: networkb
2017-03-01 15:40 Practics Issue Monitored: Practics
2017-03-01 15:43 heccam Issue Monitored: heccam
2017-03-01 17:09 markmm82 Assigned To Triage Finance => mcobas
2017-03-02 19:54 markmm82 Status new => scheduled
2017-03-02 20:00 markmm82 Note Added: 0094700
2017-03-02 20:12 markmm82 Regression level => Production - Confirmed Stable
2017-03-02 20:12 markmm82 Regression date => 2016-02-03
2017-03-02 20:12 markmm82 Regression introduced in release => 3.0PR16Q2
2017-03-02 20:12 markmm82 Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/905bb6ff4ee7 [^]
2017-03-02 20:24 markmm82 Relationship added caused by 0031989
2017-03-04 14:40 hgbot Checkin
2017-03-04 14:40 hgbot Note Added: 0094755
2017-03-04 14:40 hgbot Status scheduled => resolved
2017-03-04 14:40 hgbot Resolution open => fixed
2017-03-04 14:40 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9d671a527e68e81acd632c9ec28a5af06f59084a [^]
2017-03-04 14:53 markmm82 Review Assigned To => markmm82
2017-03-04 14:53 markmm82 Note Added: 0094762
2017-03-04 14:53 markmm82 Status resolved => closed
2017-03-04 14:53 markmm82 Fixed in Version => 3.0PR17Q2
2017-03-15 20:21 hudsonbot Checkin
2017-03-15 20:21 hudsonbot Note Added: 0095270


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker