Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033622
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2016-08-04 10:232016-08-31 15:12
ReporterJONHMView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR16Q4
StatusclosedFix in branchFixed in SCM revision70c67cc6cf8b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0PR16Q2.1SCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0033622: Wrong behavior in Select Payment Pick/Execute Window when having >100 records selected

DescriptionWhen having selected >100 payments from "Select Payment" button of [Remmitance] window, if you press that button again and select some others and click "Done", it loses some of the records previously selected
Steps To Reproduce*** Install Remittances infrastructure module and apply dataset
1) Create a new remmitance (http://wiki.openbravo.com/wiki/Projects/Remittances [^])
   1.1) Select "Remittance" from the "Document Type" dropdown.
2) Create a Payment In and select a Bussiness Partner (Make sure to create a linked Financial Account and modify its "Payment Method Tab" as "Deferred", see the video attached")
3) Create a new line of this Payment In (pressing "Add Details" button) -> Select GL Items a create a new one
4) Replicate this record, and its linked line, up to 100 more (with the attached PL script).
5) Create another Payment In from a different Bussiness Partner.
6) Open [Remittance] window and select the line previously created, click into "Select Payments" button and select every record except one. Click Done
7) Then press again into "Select Payments" button and clear the filters. Select the last record and click "Done" again.
8) When pressing one last time into "Select Payments" button and clear the filters. Some records are not selected.
TagsNo tags attached.
Attached Files? file icon lostLinesRemittance.mp4 [^] (3,653,686 bytes) 2016-08-04 10:23
? file icon duplica_function.sql [^] (1,500 bytes) 2016-08-18 13:40

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00319893.0PR16Q2 closedcaristu Wrong behavior in order/invoices grid in Add Payment process definition when having >100 records selected 
related to defect 0036193 closedalostale DefaultJsonDataService logs an exception if property *obSelected* is not found in the Entity when fetching data for PickAndEdit 
related to defect 0039644 closedalostale Add product p&e is not sorting the selected records when clearing filters 
related to defect 0039821 closedalostale StackOverflowError in P&E having 100+ records selected 

-  Notes
(0089215)
NaroaIriarte (developer)
2016-08-18 14:48

This issue is failing although the issue https://issues.openbravo.com/view.php?id=31989 [^] fixes the cases of the datasources which extend from the "ReadOnlyDatasourceService".
This is because the datasource of the Select Payments process is a view based datasource and these cases are not handled by the ReadOnlyDatasourceService, these are handled by the DefaultDataSourceService.
One approach to fix this problem could be to apply the fix on the "DefaultJsonDataService" class.
(0089331)
hgbot (developer)
2016-08-24 10:13

Repository: erp/devel/pi
Changeset: a064f77cbfb91a154149ee935a4ee83e2984b829
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Aug 24 10:12:12 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/a064f77cbfb91a154149ee935a4ee83e2984b829 [^]

related to issue 33622: apply correct format

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DefaultJsonDataService.java
---
(0089347)
hudsonbot (developer)
2016-08-24 15:00

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/3713f446b3f8 [^]
Maturity status: Test
(0089377)
hgbot (developer)
2016-08-25 10:24

Repository: erp/devel/pi
Changeset: 70c67cc6cf8b69ca2e6cc6b062cad5f9cd97476b
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Aug 25 10:23:29 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/70c67cc6cf8b69ca2e6cc6b062cad5f9cd97476b [^]

fixes issue 33622: Selection lost on table/view based P&E having >100 records

Selection could be lost on P&E windows based on a table or a view, having more than 100 records selected. This problem was solved on issue 31989 for those P&E windows based on HQL query tables (this kind of P&E windows make use of a ReadOnlyDataSourceService).

P&E windows based on a table or a view make use of the DefaultDataSourceService which uses DefaultJsonDataService to retrieve data. So, in order to solve the problem, a similar mechanism to the existing one on ReadOnlyDataSourceService has been implemented within DefaultJsonDataService.

Thus, those P&E which use DefaultDataSourceService to retrieve data, now increase the page size dynamically in order to get all selected records in the same request.

---
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/DataSourceUtils.java
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/ReadOnlyDataSourceService.java
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DefaultJsonDataService.java
M modules/org.openbravo.service.json/src/org/openbravo/service/json/JsonConstants.java
---
(0089399)
hudsonbot (developer)
2016-08-25 15:08

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/e502a641a2e5 [^]
Maturity status: Test
(0089548)
alostale (developer)
2016-08-30 12:26

code reviewed + tested
(0089575)
hgbot (developer)
2016-08-31 08:39

Repository: erp/devel/pi
Changeset: 71d43f621ba58afff3f91b3a4b9b49ef9b4dbaa6
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Aug 31 08:37:02 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/71d43f621ba58afff3f91b3a4b9b49ef9b4dbaa6 [^]

related to issue 33622: added javadoc to explain how the new methods work

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DefaultJsonDataService.java
---
(0089620)
hudsonbot (developer)
2016-08-31 15:12

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5d428c349064 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-08-04 10:23 JONHM New Issue
2016-08-04 10:23 JONHM Assigned To => platform
2016-08-04 10:23 JONHM File Added: lostLinesRemittance.mp4
2016-08-04 10:23 JONHM Modules => Core
2016-08-04 10:23 JONHM Triggers an Emergency Pack => No
2016-08-04 10:23 JONHM Note Added: 0088810
2016-08-12 15:20 caristu Relationship added related to 0031989
2016-08-16 14:39 NaroaIriarte Assigned To platform => NaroaIriarte
2016-08-16 14:39 NaroaIriarte Status new => acknowledged
2016-08-18 12:06 NaroaIriarte Note Deleted: 0088810
2016-08-18 13:40 NaroaIriarte File Added: duplica_function.sql
2016-08-18 13:41 NaroaIriarte Steps to Reproduce Updated View Revisions
2016-08-18 14:48 NaroaIriarte Note Added: 0089215
2016-08-18 14:53 NaroaIriarte Steps to Reproduce Updated View Revisions
2016-08-18 15:02 NaroaIriarte Steps to Reproduce Updated View Revisions
2016-08-18 15:03 NaroaIriarte Assigned To NaroaIriarte => caristu
2016-08-24 08:21 caristu Status acknowledged => scheduled
2016-08-24 10:13 hgbot Checkin
2016-08-24 10:13 hgbot Note Added: 0089331
2016-08-24 15:00 hudsonbot Checkin
2016-08-24 15:00 hudsonbot Note Added: 0089347
2016-08-25 10:24 hgbot Checkin
2016-08-25 10:24 hgbot Note Added: 0089377
2016-08-25 10:24 hgbot Status scheduled => resolved
2016-08-25 10:24 hgbot Resolution open => fixed
2016-08-25 10:24 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/70c67cc6cf8b69ca2e6cc6b062cad5f9cd97476b [^]
2016-08-25 10:31 caristu Review Assigned To => alostale
2016-08-25 10:31 caristu Issue Monitored: alostale
2016-08-25 15:08 hudsonbot Checkin
2016-08-25 15:08 hudsonbot Note Added: 0089399
2016-08-30 12:26 alostale Note Added: 0089548
2016-08-30 12:26 alostale Status resolved => closed
2016-08-30 12:26 alostale Fixed in Version => 3.0PR16Q4
2016-08-31 08:39 hgbot Checkin
2016-08-31 08:39 hgbot Note Added: 0089575
2016-08-31 15:12 hudsonbot Checkin
2016-08-31 15:12 hudsonbot Note Added: 0089620
2017-06-07 17:53 adrianromero Relationship added related to 0036193
2018-12-03 16:35 alostale Relationship added related to 0039644
2018-12-17 14:17 alostale Relationship added related to 0039821


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker