Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041228
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] Z. OthersmajorN/A2019-07-02 13:142019-08-22 14:44
ReportervmromanosView Statuspublic 
Assigned Tovmromanos 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q4
StatusclosedFix in branchFixed in SCM revisionff5106481e82
ProjectionnoneETAnoneTarget Version3.0PR19Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0041228: One-to-many clean up of existing columns (Functional)

DescriptionSince 19Q3 the one-to-many child properties automatically generated by DAL can be configured (see http://wiki.openbravo.com/wiki/Data_Access_Layer#Business_Object [^]). By default any new window won't have this relationship. However the existing columns will keep it.

It would be nice to review all the existing columns and remove this relationship where it doesn't make sense, therefore creating a controlled API change that will reduce the model complexity and will improve performance.
Steps To ReproduceNA
Proposed Solutionhttps://docs.google.com/spreadsheets/d/1hdwjGM4_3TJ-9Bcylh_w_MM54_1T_cUlicaPfEyH1MQ [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
has duplicate design defect 0040914 closedTriage Finance functional: review FK columns to set which ones shouldn't generate one-to-many property in parent entity 
causes defect 00412273.0PR19Q4 closedvmromanos API Change: One-to-many cleanup (Functional team) 
causes defect 0042023 closedinigo_lerga In End Year Close window Accounting Tab FinancialMgmtPeriod.getfinancialMgmtPeriodControlList is needed 

-  Notes
(0113171)
hgbot (developer)
2019-07-04 10:11

Repository: erp/devel/pi
Changeset: ff5106481e824ee169ac43f2f5b2d42fdf93104a
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Thu Jul 04 10:03:15 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ff5106481e824ee169ac43f2f5b2d42fdf93104a [^]

Fixed issue 41228: One-to-many clean up of existing columns (Functional)

Reviewed all the existing columns (Functional) and removed the one-to-many relationship where it doesn't make sense, therefore creating a controlled API change that will reduce the model complexity and will improve performance.

See for details: https://docs.google.com/spreadsheets/d/1hdwjGM4_3TJ-9Bcylh_w_MM54_1T_cUlicaPfEyH1MQ [^]

---
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.client.widgets/src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0113172)
hgbot (developer)
2019-07-04 12:10

Repository: erp/devel/pi
Changeset: 794d0f20f14a9961d255cd32ce1f38e0dc56a6e9
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Thu Jul 04 12:03:02 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/794d0f20f14a9961d255cd32ce1f38e0dc56a6e9 [^]

Related to issue 41228: One-to-many cleanup (Functional) finetune

Reverted back relationship beetween Order and Quotation list because it is used by a JUnit tests,
and on the other hand it might makes sense from a Functional POV

---
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0113217)
Sandrahuguet (developer)
2019-07-08 15:26

Repository: erp/devel/pi
Changeset: fecfb6360b22
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Thu Jul 05 14:39:02 2019 +0200
URL: https://code.openbravo.com/erp/devel/pi/rev/fecfb6360b22 [^]

Related to 41228: Removed Costing related columns

---
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0113219)
Sandrahuguet (developer)
2019-07-08 15:27

verified
(0114133)
hudsonbot (developer)
2019-08-22 14:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad3efd3bd07c [^]
Maturity status: Test
(0114134)
hudsonbot (developer)
2019-08-22 14:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad3efd3bd07c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-07-02 13:14 vmromanos New Issue
2019-07-02 13:14 vmromanos Assigned To => Triage Finance
2019-07-02 13:14 vmromanos Modules => Core
2019-07-02 13:14 vmromanos Triggers an Emergency Pack => No
2019-07-02 13:14 vmromanos Relationship added causes 0041227
2019-07-02 13:14 vmromanos Status new => scheduled
2019-07-02 13:14 vmromanos Assigned To Triage Finance => vmromanos
2019-07-02 13:14 vmromanos Target Version => 3.0PR19Q4
2019-07-04 10:11 hgbot Checkin
2019-07-04 10:11 hgbot Note Added: 0113171
2019-07-04 10:11 hgbot Status scheduled => resolved
2019-07-04 10:11 hgbot Resolution open => fixed
2019-07-04 10:11 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ff5106481e824ee169ac43f2f5b2d42fdf93104a [^]
2019-07-04 12:10 hgbot Checkin
2019-07-04 12:10 hgbot Note Added: 0113172
2019-07-05 09:11 vmromanos Review Assigned To => Sandrahuguet
2019-07-08 15:26 Sandrahuguet Note Added: 0113217
2019-07-08 15:27 Sandrahuguet Note Added: 0113219
2019-07-08 15:27 Sandrahuguet Status resolved => closed
2019-07-08 15:27 Sandrahuguet Fixed in Version => 3.0PR19Q4
2019-07-23 15:43 vmromanos Relationship added has duplicate 0040914
2019-08-22 14:44 hudsonbot Checkin
2019-08-22 14:44 hudsonbot Note Added: 0114133
2019-08-22 14:44 hudsonbot Checkin
2019-08-22 14:44 hudsonbot Note Added: 0114134
2019-10-15 15:33 Sandrahuguet Relationship added causes 0042023


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker