Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0042023
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajorhave not tried2019-10-15 13:562019-12-12 23:01
ReporterAtulOpenbravoView Statuspublic 
Assigned Toinigo_lerga 
PrioritynormalResolutionfixedFixed in Version3.0PR20Q1
StatusclosedFix in branchFixed in SCM revisionf6687b97b12c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression levelPackaging and release
Regression date2019-07-04
Regression introduced in releasemain
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/ff5106481e824ee169ac43f2f5b2d42fdf93104a [^]
Triggers an Emergency PackNo
Summary

0042023: In End Year Close window Accounting Tab FinancialMgmtPeriod.getfinancialMgmtPeriodControlList is needed

DescriptionIn End Year Close window Accounting Tab FinancialMgmtPeriod.getfinancialMgmtPeriodControlList is needed but As part of this issue [1], some one-to-many child methods were removed, assuming that they were not in use.

[1] https://issues.openbravo.com/view.php?id=40906 [^] [^]
Steps To ReproduceIn livebuilds
- Navigate to End Year Close window
- Select any record
- Realize that error is shown in Accounting Tab message box and no records are shown. See attached screenshot.
Proposed SolutionProposed solution is attached. It sets C_PeriodControl table's C_Period_ID column's is_child_property_in_parent flag = Yes, so that child property i.e financialMgmtPeriodControlList is included in its parent i.e FinancialMgmtPeriod
TagsNo tags attached.
Attached Filespng file icon IsChildPropertyInParentEntity_Affected.png [^] (166,053 bytes) 2019-10-15 13:56


diff file icon Raw_0042023_proposal.diff [^] (662 bytes) 2019-10-15 13:58 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00420283.0PR19Q4 closedinigo_lerga In End Year Close window Accounting Tab FinancialMgmtPeriod.getfinancialMgmtPeriodControlList is needed 
caused by feature request 00412283.0PR19Q4 closedvmromanos One-to-many clean up of existing columns (Functional) 

-  Notes
(0115135)
inigo_lerga (developer)
2019-10-17 09:48

Test Plan:
As group admin role:
   Go to End Year Close window and select any record.

   Realize that error is shown in Accounting Tab message box and no records are
   shown.
(0115198)
hgbot (developer)
2019-10-22 09:01

Repository: erp/devel/pi
Changeset: f6687b97b12c26c8e7cfecccb91bd87440a888f4
Author: IƱigo Lerga <inigo.lerga <at> openbravo.com>
Date: Wed Oct 16 14:05:16 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f6687b97b12c26c8e7cfecccb91bd87440a888f4 [^]

Fixes issue 42023: C_PeriodControl table's C_Period_ID column's is_child_property_in_parent flag set to Yes

It sets C_PeriodControl table's C_Period_ID column's is_child_property_in_parent flag = Yes, so that child property i.e financialMgmtPeriodControlList is included in its parent i.e FinancialMgmtPeriod

---
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0115200)
Sandrahuguet (developer)
2019-10-22 09:03

code review + testing ok
(0116257)
hudsonbot (developer)
2019-12-12 23:01

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/954d2b7a66fb [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-10-15 13:56 AtulOpenbravo New Issue
2019-10-15 13:56 AtulOpenbravo Assigned To => platform
2019-10-15 13:56 AtulOpenbravo File Added: IsChildPropertyInParentEntity_Affected.png
2019-10-15 13:56 AtulOpenbravo Modules => Core
2019-10-15 13:56 AtulOpenbravo Regression level => Production - QA Approved
2019-10-15 13:56 AtulOpenbravo Regression date => 2019-05-21
2019-10-15 13:56 AtulOpenbravo Regression introduced in release => 3.0PR19Q3
2019-10-15 13:56 AtulOpenbravo Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/4dc58edab48f2f9e20cfce74f557827e43919803 [^]
2019-10-15 13:56 AtulOpenbravo Triggers an Emergency Pack => No
2019-10-15 13:58 AtulOpenbravo File Added: Raw_0042023_proposal.diff
2019-10-15 15:21 Sandrahuguet Assigned To platform => inigo_lerga
2019-10-15 15:22 Sandrahuguet Status new => scheduled
2019-10-15 15:31 Sandrahuguet Regression introduced by commit https://code.openbravo.com/erp/devel/pi/rev/4dc58edab48f2f9e20cfce74f557827e43919803 [^] => https://code.openbravo.com/erp/devel/pi/rev/ff5106481e824ee169ac43f2f5b2d42fdf93104a [^]
2019-10-15 15:33 Sandrahuguet Relationship added caused by 0041228
2019-10-16 13:01 inigo_lerga Regression level Production - QA Approved => Packaging and release
2019-10-16 13:01 inigo_lerga Regression date 2019-05-21 => 2019-07-04
2019-10-16 13:01 inigo_lerga Regression introduced in release 3.0PR19Q3 => main
2019-10-17 09:48 inigo_lerga Note Added: 0115135
2019-10-22 09:01 hgbot Checkin
2019-10-22 09:01 hgbot Note Added: 0115198
2019-10-22 09:01 hgbot Status scheduled => resolved
2019-10-22 09:01 hgbot Resolution open => fixed
2019-10-22 09:01 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f6687b97b12c26c8e7cfecccb91bd87440a888f4 [^]
2019-10-22 09:03 Sandrahuguet Review Assigned To => Sandrahuguet
2019-10-22 09:03 Sandrahuguet Note Added: 0115200
2019-10-22 09:03 Sandrahuguet Status resolved => closed
2019-10-22 09:03 Sandrahuguet Fixed in Version => 3.0PR20Q1
2019-12-12 23:01 hudsonbot Checkin
2019-12-12 23:01 hudsonbot Note Added: 0116257


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker