Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032396
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminoralways2016-03-03 14:022016-03-17 10:56
ReporterJONHMView Statuspublic 
Assigned Toinigosanchez 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revision97035bb00ab3
ProjectionnoneETAnoneTarget Version3.0PR16Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2015-05-18
Regression introduced in release3.0PR15Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/2d6b8e5005b29bbca7ae4fd977ba6e18d8ac5201 [^]
Triggers an Emergency PackNo
Summary

0032396: cannot filter grid when it is grouped by a column

DescriptionWe cannot filter results after grouping by date in Multiphase Project view. We got some error on Chrome's debugging window:
"Uncaught TypeError: this.data.willFetchData is not a function"
"isc.OBViewGrid.addProperties.handleFilterEditorSubmit"
Steps To Reproduce1) Enter some data with dates in "Multiphase Project" view
2) Group by date column
3) Filter by some column (for example, name)

The filter doesn't work

This is reproducible for any window
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00323993.0PR16Q1 closedinigosanchez cannot filter grid when it is grouped by a column 
depends on backport 00324003.0PR15Q4.5 closedinigosanchez cannot filter grid when it is grouped by a column 
depends on backport 00324013.0PR15Q3.7 closedplatform cannot filter grid when it is grouped by a column 
caused by defect 0029896 closedAugustoMauch double grid request when filtering grid after scrolling to 2nd page 

-  Notes
(0084694)
alostale (developer)
2016-03-03 17:20

Severity downgraded to minor accordingly to Reporting Guidelines [1]

[1] http://wiki.openbravo.com/wiki/QA_Processes/Defects_Severity_Priority [^]
(0084779)
hgbot (developer)
2016-03-07 15:43

Repository: erp/devel/pi
Changeset: 97035bb00ab31cb0d520dbb5edbe330450f5d69d
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Mon Mar 07 11:31:44 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/97035bb00ab31cb0d520dbb5edbe330450f5d69d [^]

Fixes issue 32396: cannot filter grid when it is grouped by a column.

Having a column grouped, if a filter was applied in a grid, it was not
possible to apply it.A js error was thrown:
Uncaught TypeError: this.data.willFetchData is not a function.

The problem was in:"this.data.willFetchData(....))" statement which
incorrectly assumed this.data to be an object and willFetchData a function
within it. This is not true when in this situation where this.data is a
Tree class.

It has been fixed by taking into account this case by checking that "this.data" defines the
function.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0084780)
inigosanchez (developer)
2016-03-07 15:44

Test case created in TestLink > Platform > Summary, Grouping and Filter > Filter > Test: Filtering does not work when a column is grouped.

See https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-10005 [^]
(0084808)
alostale (developer)
2016-03-08 10:00

code reviewed

tested:
* grouping by different fields (date, numeric, FK) filters work in grouped column as well as in other ones
* related issues (0029896 and 0031187) are still not reproducible
(0085186)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-03-03 14:02 JONHM New Issue
2016-03-03 14:02 JONHM Assigned To => platform
2016-03-03 14:02 JONHM Modules => Core
2016-03-03 14:02 JONHM Triggers an Emergency Pack => No
2016-03-03 17:20 alostale Note Added: 0084694
2016-03-03 17:20 alostale Severity major => minor
2016-03-03 17:20 alostale Status new => acknowledged
2016-03-03 17:21 alostale Summary Error filtering on "Multiphase Project" view while grouping by date => cannot filter grid when it is grouped by a column
2016-03-03 17:21 alostale Steps to Reproduce Updated View Revisions
2016-03-03 17:22 alostale Regression level => Production - Confirmed Stable
2016-03-03 17:22 alostale Regression introduced in release => 3.0PR15Q3
2016-03-03 17:22 alostale Priority urgent => immediate
2016-03-03 17:24 alostale Status acknowledged => scheduled
2016-03-03 17:25 alostale Assigned To platform => inigosanchez
2016-03-04 08:38 inigosanchez Regression date => 2015-05-18
2016-03-04 08:38 inigosanchez Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/2d6b8e5005b29bbca7ae4fd977ba6e18d8ac5201 [^]
2016-03-04 10:52 alostale Relationship added caused by 0029896
2016-03-07 15:42 inigosanchez Issue Monitored: alostale
2016-03-07 15:43 hgbot Checkin
2016-03-07 15:43 hgbot Note Added: 0084779
2016-03-07 15:43 hgbot Status scheduled => resolved
2016-03-07 15:43 hgbot Resolution open => fixed
2016-03-07 15:43 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/97035bb00ab31cb0d520dbb5edbe330450f5d69d [^]
2016-03-07 15:44 inigosanchez Note Added: 0084780
2016-03-07 15:44 inigosanchez Review Assigned To => alostale
2016-03-08 10:00 alostale Note Added: 0084808
2016-03-08 10:00 alostale Status resolved => closed
2016-03-08 10:00 alostale Fixed in Version => 3.0PR16Q2
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085186


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker