Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029896
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2015-05-15 09:032015-05-26 09:48
ReporteralostaleView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revision2d6b8e5005b2
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029896: double grid request when filtering grid after scrolling to 2nd page

DescriptionIf the user scrolls down a grid till reaching the second page, and then performs a filter that returns less than a page, the filtered records will be shown but a second grid requests will be done.
Steps To Reproduce- Open the Country and Region window
- Scroll down until you see Iraq
- Open the browser developer tools and select the Network tab
- Enter Q in the name filter editor
   -> 2 identical requests are performed to the grid datasource, 2nd one is not necessary
TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0029835 closedAugustoMauch Unlimited grid datasource request under certain circumstances 
related to defect 0031434 closedcaristu Error thrown when refreshing the grid after canceling the creation of a record in a child tab 
causes defect 0031187 closedalostale [PR15Q4] Lazy filtering does not work when filtering the first time 
causes defect 00323963.0PR16Q2 closedinigosanchez cannot filter grid when it is grouped by a column 

-  Notes
(0077482)
hgbot (developer)
2015-05-15 10:03

Repository: erp/devel/pi
Changeset: e5e79f23f31356be0a5acb7a9f0b182a5d60fc3d
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri May 15 09:58:34 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/e5e79f23f31356be0a5acb7a9f0b182a5d60fc3d [^]

Fixes issue 29896: Prevents unneded datasource request when filtering

When the grid was filtered in a scrolled down grid, two datasource requests to load the grid were bein
g done instead of one. This happened due to two reasons:
- The function scrollTo of the grid's body was being invoked while the grid was being filtered. This f
unction can be skipped in this case because when a datasource request is triggered due to a filter eve
nt, the grid is always automatically scrolled up to the top
- If the OBViewGrid.getRecord function was invoked in the middle of a datasource request, an additiona
l request was done. To prevent this, in this case the function returns Array.LOADING

To detect if the grid is in the process of doing a datasource request, the isFilteringExternally flag
is used. This flag is set in the handleFilterEditorSubmit function, and only if the change in the filt
er editor is going to trigger a datasource request. The flag is reset in the callback of that function
.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0077486)
alostale (developer)
2015-05-15 11:27

code reviewed

Tested by combining scroll, filter and refresh both in grid and form views. In all the cases no extra requests were observed.
(0077505)
hgbot (developer)
2015-05-15 18:29

Repository: erp/devel/pi
Changeset: ef5d66aa84cc8ece0e810d69cc5d80c2741e652c
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri May 15 18:27:18 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ef5d66aa84cc8ece0e810d69cc5d80c2741e652c [^]

Related with issue 29896: Fix backed out because it is breaks int-initial tests

A side effect of the changeset is making Selenium unable to know when a grid has been loaded under certain circumstances.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0077510)
hudsonbot (developer)
2015-05-16 05:21

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/33b0ebaa36ae [^]
Maturity status: Test
(0077513)
hudsonbot (developer)
2015-05-16 05:21

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/33b0ebaa36ae [^]
Maturity status: Test
(0077544)
hgbot (developer)
2015-05-18 18:22

Repository: erp/devel/pi
Changeset: 2d6b8e5005b29bbca7ae4fd977ba6e18d8ac5201
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon May 18 18:20:40 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/2d6b8e5005b29bbca7ae4fd977ba6e18d8ac5201 [^]

Fixes issue 29896: Prevents unneded datasource request when filtering

When the grid was filtered in a scrolled down grid, two datasource requests to load the grid were being done instead of one. This happened due to two reasons:
- The function scrollTo of the grid's body was being invoked while the grid was being filtered. This function can be skipped in this case because when a datasource request is triggered due to a filter event, the grid is always automatically scrolled up to the top
- If the OBViewGrid.getRecord function was invoked in the middle of a datasource request, an additional request was done. To prevent this, in this case the function returns Array.LOADING

To detect if the grid is in the process of doing a datasource request, the isFilteringExternally flag is used. This flag is set in the handleFilterEditorSubmit function, and only if the change in the filter editor is going to trigger a datasource request. The flag is reset in the callback of that function.

This previous fix did not work properly, as the criteria passed to the willFetchData function was not proper, it needed to the processed in the convertCriteria function.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0077589)
hudsonbot (developer)
2015-05-19 18:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/877209d1525b [^]
Maturity status: Test
(0077735)
alostale (developer)
2015-05-26 09:48

code reviewed

tested with different combinations of scrolling, filtering and refreshing

- Issue History
Date Modified Username Field Change
2015-05-15 09:03 alostale New Issue
2015-05-15 09:03 alostale Assigned To => platform
2015-05-15 09:03 alostale Modules => Core
2015-05-15 09:03 alostale Triggers an Emergency Pack => No
2015-05-15 09:04 alostale Tag Attached: Performance
2015-05-15 09:04 alostale Relationship added related to 0029835
2015-05-15 09:05 alostale Status new => scheduled
2015-05-15 09:05 alostale Assigned To platform => AugustoMauch
2015-05-15 10:03 hgbot Checkin
2015-05-15 10:03 hgbot Note Added: 0077482
2015-05-15 10:03 hgbot Status scheduled => resolved
2015-05-15 10:03 hgbot Resolution open => fixed
2015-05-15 10:03 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e5e79f23f31356be0a5acb7a9f0b182a5d60fc3d [^]
2015-05-15 11:02 AugustoMauch Issue Monitored: alostale
2015-05-15 11:02 AugustoMauch Review Assigned To => alostale
2015-05-15 11:27 alostale Note Added: 0077486
2015-05-15 11:27 alostale Status resolved => closed
2015-05-15 11:27 alostale Fixed in Version => 3.0PR15Q3
2015-05-15 18:29 hgbot Checkin
2015-05-15 18:29 hgbot Note Added: 0077505
2015-05-16 05:21 hudsonbot Checkin
2015-05-16 05:21 hudsonbot Note Added: 0077510
2015-05-16 05:21 hudsonbot Checkin
2015-05-16 05:21 hudsonbot Note Added: 0077513
2015-05-18 09:00 alostale Status closed => new
2015-05-18 09:00 alostale Resolution fixed => open
2015-05-18 09:00 alostale Fixed in Version 3.0PR15Q3 =>
2015-05-18 18:22 hgbot Checkin
2015-05-18 18:22 hgbot Note Added: 0077544
2015-05-18 18:22 hgbot Status new => resolved
2015-05-18 18:22 hgbot Resolution open => fixed
2015-05-18 18:22 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/e5e79f23f31356be0a5acb7a9f0b182a5d60fc3d [^] => http://code.openbravo.com/erp/devel/pi/rev/2d6b8e5005b29bbca7ae4fd977ba6e18d8ac5201 [^]
2015-05-19 18:39 hudsonbot Checkin
2015-05-19 18:39 hudsonbot Note Added: 0077589
2015-05-26 09:48 alostale Note Added: 0077735
2015-05-26 09:48 alostale Status resolved => closed
2015-05-26 09:48 alostale Fixed in Version => 3.0PR15Q3
2015-10-27 08:21 alostale Relationship added causes 0031187
2015-11-11 18:31 caristu Relationship added related to 0031434
2016-03-04 10:52 alostale Relationship added causes 0032396


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker