Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031434
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-11-11 18:292015-11-23 21:17
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR16Q1
StatusclosedFix in branchFixed in SCM revisionbc003391103b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031434: Error thrown when refreshing the grid after canceling the creation of a record in a child tab

DescriptionThe following error appears in the interface:

"Data was tried to be fetched from server without pagination. Request was aborted to prevent server performance issues. This is most likely a bug, please contact your System Administrator."

when refreshing the grid after canceling the creation of a record in a child tab
Steps To Reproduce1) Go to the [Sales Order] window
2) Create a new record in the header
3) Navigate to the [Lines] tab
4) Create a new record in grid view, cancel the edition (without saving)
5) Click on the refresh button. Notice that the error appears.
TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0029896 closedAugustoMauch double grid request when filtering grid after scrolling to 2nd page 
related to defect 0029259 closedcaristu WARN: Datasource request with targetRecordId but without directNavigation detected when reloading Sales Invoice form view 
has duplicate defect 0028321 closedcaristu Request without pagination when refreshing the grid 
related to defect 0036459 closedcaristu error thrown when refreshing after cancelling row creation before FIC response is processed 

-  Notes
(0081726)
hgbot (developer)
2015-11-11 19:14

Repository: erp/devel/pi
Changeset: bc003391103bb456428563231196609f946172cc
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Nov 11 19:12:51 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/bc003391103bb456428563231196609f946172cc [^]

fixes issue 31434: Error after cancel record creation in grid view and refresh

The problem was that when refreshing after cancelling the record creation in grid view, the refresh request was done considering that an existing record was selected. To avoid this problem, now after canceling, the getSelectedRecord() is cleared if the canceled record is a new one.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0081727)
hgbot (developer)
2015-11-11 19:21

Repository: erp/devel/pi
Changeset: 760f25c01ef4cfdab3be2a58e7c43e6875e48063
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Nov 11 19:20:24 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/760f25c01ef4cfdab3be2a58e7c43e6875e48063 [^]

related to issue 31434: improvement to not execute the same method two times

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0081871)
alostale (developer)
2015-11-16 12:47

Code review -> reopening selectedRecord variable is declared within if statement, according to JavaScript Coding Conventions, it should be declared on top of the function [1].

[1] http://wiki.openbravo.com/wiki/JavaScript_Coding_Conventions#Variable_Declaration [^]
(0081873)
hgbot (developer)
2015-11-16 13:16

Repository: erp/devel/pi
Changeset: 6adee27906f6141ac9b3ac1a8717e3fd04023d22
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Nov 16 13:15:27 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/6adee27906f6141ac9b3ac1a8717e3fd04023d22 [^]

related to issue 31434: code review improvements

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0081876)
alostale (developer)
2015-11-16 13:31

code reviewed + tested
(0082199)
hudsonbot (developer)
2015-11-23 21:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test
(0082200)
hudsonbot (developer)
2015-11-23 21:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test
(0082231)
hudsonbot (developer)
2015-11-23 21:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-11-11 18:29 caristu New Issue
2015-11-11 18:29 caristu Assigned To => platform
2015-11-11 18:29 caristu Modules => Core
2015-11-11 18:29 caristu Triggers an Emergency Pack => No
2015-11-11 18:29 caristu Issue Monitored: networkb
2015-11-11 18:31 caristu Relationship added related to 0029896
2015-11-11 19:06 caristu Assigned To platform => caristu
2015-11-11 19:07 caristu Review Assigned To => alostale
2015-11-11 19:07 caristu Issue Monitored: alostale
2015-11-11 19:14 hgbot Checkin
2015-11-11 19:14 hgbot Note Added: 0081726
2015-11-11 19:14 hgbot Status new => resolved
2015-11-11 19:14 hgbot Resolution open => fixed
2015-11-11 19:14 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/bc003391103bb456428563231196609f946172cc [^]
2015-11-11 19:21 hgbot Checkin
2015-11-11 19:21 hgbot Note Added: 0081727
2015-11-12 18:58 caristu Relationship added has duplicate 0028321
2015-11-16 12:41 alostale Tag Attached: Performance
2015-11-16 12:45 alostale Relationship added related to 0029259
2015-11-16 12:47 alostale Note Added: 0081871
2015-11-16 12:47 alostale Status resolved => new
2015-11-16 12:47 alostale Resolution fixed => open
2015-11-16 13:16 hgbot Checkin
2015-11-16 13:16 hgbot Note Added: 0081873
2015-11-16 13:20 caristu Status new => scheduled
2015-11-16 13:21 caristu Status scheduled => resolved
2015-11-16 13:21 caristu Resolution open => fixed
2015-11-16 13:31 alostale Note Added: 0081876
2015-11-16 13:31 alostale Status resolved => closed
2015-11-16 13:31 alostale Fixed in Version => 3.0PR16Q1
2015-11-23 21:17 hudsonbot Checkin
2015-11-23 21:17 hudsonbot Note Added: 0082199
2015-11-23 21:17 hudsonbot Checkin
2015-11-23 21:17 hudsonbot Note Added: 0082200
2015-11-23 21:17 hudsonbot Checkin
2015-11-23 21:17 hudsonbot Note Added: 0082231
2017-07-11 14:58 alostale Relationship added related to 0036459


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker