Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036459
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2017-07-11 14:572017-09-21 16:49
ReporteralostaleView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revisiona8a4aa776122
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036459: error thrown when refreshing after cancelling row creation before FIC response is processed

DescriptionWhen creating a new record in grid, if edition is cancelled before a FIC request is processed and after that, refresh grid is clicked, error about unpaged request is thrown.
Steps To Reproduce1. Add artificial delay in SL_Order_Product callout code: Thread.sleep(5_000L);
2. Create a [Sales Quotation] header
3. Move to the [Lines] tab. Insert Row in grid mode
4. Select a product
5. Before callout response is received click on cancel changes button
6. Click on refresh
  -> Error about unpaged request is thrown
Proposed SolutionIn discardEdits function in ob-view-grid.js there are 2 code branches:

if (!preventConfirm && ((editForm && editForm.hasChanged) || this.rowHasErrors(rowNum))) {
  ...
} else {
  ...
}

Both of them were initially very similar (need to check for diffs), but after time, they have diverged most probably due to mistakes. Ie. for this case, code that fixes 0031434 was forgotten to be included also in 1st branch.

These 2 branches should be merged, so that the code is centrally maintained.
TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0036457 closedalostale inconsistent grid state if cancelling changes before receiving FIC response 
related to defect 0031434 closedcaristu Error thrown when refreshing the grid after canceling the creation of a record in a child tab 
related to defect 00281883.0PR15Q1 closedAugustoMauch Wrong information displayed after refresh a tab having an error when saving in grid view 
related to defect 0033626 closedNaroaIriarte Unneeded datasource request after cancelling a newly created record in grid view having summary functions 
has duplicate defect 0035986 closedplatform Wrong behavior after cancelling a record edition in grid view having the focus on a numeric field 

-  Notes
(0098555)
caristu (developer)
2017-08-21 13:02
edited on: 2017-08-22 09:37

Summary of the changes involved in the differences currently present between the two branches: https://docs.google.com/spreadsheets/d/1n7ydqkvNZdCJbERiq1tqP7yoemey6sCT6HV5Tf7XQ3I/edit#gid=0 [^]

(0098571)
hgbot (developer)
2017-08-22 10:09

Repository: erp/devel/pi
Changeset: a8a4aa77612230fd18bc49f3d69e12bb2f9c3565
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Aug 22 09:43:37 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/a8a4aa77612230fd18bc49f3d69e12bb2f9c3565 [^]

fixes bug 36459: error when refresh after discard changes before FIC response

This problem was solved with the code that fixes issue 0031434 just for the case of cancelling a record which does not contain any change. Otherwise, the issue could be still reproduced because of the fact of having an if statement with two code branches inside the discardEdits function. That code was forgotten to be included also in the first branch.

That if statement was created in order to identify if the record being cancelled contained changes. In that case, a dialog was being shown to the user in order to ask for confirmation to discard the changes.

After some time, that dialog was removed (see revision 92ecb7ac760a). That means that since that point the if statement is no longer needed. For this reason, the two branches have been merged.

Note that this change also fixes completely issues 0031434 and 0033626, as they were partially fixed (fix only present in one of the branches).

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0098676)
alostale (developer)
2017-08-29 08:13

reviewed + tested
(0099317)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-07-11 14:57 alostale New Issue
2017-07-11 14:57 alostale Assigned To => platform
2017-07-11 14:57 alostale Modules => Core
2017-07-11 14:57 alostale Triggers an Emergency Pack => No
2017-07-11 14:57 alostale Tag Attached: Performance
2017-07-11 14:58 alostale Relationship added related to 0036457
2017-07-11 14:58 alostale Relationship added related to 0031434
2017-07-11 14:58 alostale Assigned To platform => caristu
2017-07-11 14:58 alostale Status new => scheduled
2017-08-21 10:28 caristu Relationship added related to 0028188
2017-08-21 12:09 caristu Steps to Reproduce Updated View Revisions
2017-08-21 13:02 caristu Note Added: 0098555
2017-08-22 09:18 caristu Relationship added related to 0033626
2017-08-22 09:37 caristu Note Edited: 0098555 View Revisions
2017-08-22 09:37 caristu Note Edited: 0098555 View Revisions
2017-08-22 10:09 hgbot Checkin
2017-08-22 10:09 hgbot Note Added: 0098571
2017-08-22 10:09 hgbot Status scheduled => resolved
2017-08-22 10:09 hgbot Resolution open => fixed
2017-08-22 10:09 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a8a4aa77612230fd18bc49f3d69e12bb2f9c3565 [^]
2017-08-22 10:11 caristu Review Assigned To => alostale
2017-08-23 09:04 caristu Relationship added has duplicate 0035986
2017-08-29 08:13 alostale Note Added: 0098676
2017-08-29 08:13 alostale Status resolved => closed
2017-08-29 08:13 alostale Fixed in Version => 3.0PR17Q4
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099317


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker