Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031187
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2015-10-20 12:532015-11-23 21:16
ReporterplujanView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q1
StatusclosedFix in branchFixed in SCM revision3a698bde90ad
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2015-05-18
Regression introduced in release3.0PR15Q3
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/2d6b8e5005b29bbca7ae4fd977ba6e18d8ac5201 [^]
Triggers an Emergency PackNo
Summary

0031187: [PR15Q4] Lazy filtering does not work when filtering the first time

DescriptionIf the first action taken on a grid is to change a filter, applying the filtering does nothing. If first the records are shown, it works as expected.
Steps To Reproduce0. In Grid Configuration set Preference window to do Lazy Filtering on Grid

1. As System Administrator, go to Preference window
2. Click the check button to show the data. It shows the data.
3. Close the window
4. Reopen the Preference window
5. Seek for a preference on the list and check it to have the filter active
6. Click the check button to show the data. It does not work.
   -> js error can be seen in developers tool:
       Uncaught TypeError: this.data.willFetchData is not a function
         isc.OBViewGrid.addProperties.handleFilterEditorSubmit @ abac3df8aa23bfef1d3ab745040cf492.js:2087
7. Refresh the window, the data is loaded unfiltered. Repeat steps 5 and 6 and check that now it works.
A video showing the behaviour:
https://drive.google.com/open?id=0B6HEkyuFoid8SnJJaWpLY0MzQXc [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00312553.0PR15Q4 closedalostale [PR15Q4] Lazy filtering does not work when filtering the first time 
depends on backport 00312563.0PR15Q3.3 closedalostale [PR15Q4] Lazy filtering does not work when filtering the first time 
caused by defect 0029896 closedAugustoMauch double grid request when filtering grid after scrolling to 2nd page 
related to defect 00311043.0PR16Q1 closedcaristu [PR15Q4] [Lazy filtering] Lazy filtering feature also affects column sorting 

-  Notes
(0081324)
hgbot (developer)
2015-10-27 08:29

Repository: erp/devel/pi
Changeset: 3a698bde90ad5354ff9e7ceabfeebf1bf6e89d4a
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Oct 27 08:28:58 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/3a698bde90ad5354ff9e7ceabfeebf1bf6e89d4a [^]

fixed bug 31187: Lazy filtering does not work when filtering the first time

  Having lazy filtering configured, if a filter was applied in a grid as first
  action, it was not possible to apply it. A js error was thrown:
     Uncaught TypeError: this.data.willFetchData is not a function

  The problem was in "if (this.data.willFetchData(this.convertCriteria(criteria)))"
  statement which incorrectly assumed this.data to be an object and willFetchData
  a function within it. This is not true when in this situation where this.data is
  an array.

  It has been fixed by taking into account this case by checking wether this.data
  is an array.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0081330)
alostale (developer)
2015-10-27 09:37

Test case created in TestLink: https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-9881 [^]
(0081333)
AugustoMauch (developer)
2015-10-27 09:45

Code reviewed and verified in pi@3a698bde90ad
(0082159)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-10-20 12:53 plujan New Issue
2015-10-20 12:53 plujan Assigned To => platform
2015-10-20 12:53 plujan Modules => Core
2015-10-20 12:53 plujan Triggers an Emergency Pack => No
2015-10-20 12:56 plujan Summary Lazy filtering does not work when filtering the first time => [PR15Q4] Lazy filtering does not work when filtering the first time
2015-10-27 07:50 alostale Regression level => Production - QA Approved
2015-10-27 07:50 alostale Regression introduced in release => 3.0PR15Q3
2015-10-27 07:50 alostale Priority normal => immediate
2015-10-27 07:50 alostale Status new => acknowledged
2015-10-27 07:50 alostale Steps to Reproduce Updated View Revisions
2015-10-27 07:52 alostale Review Assigned To => caristu
2015-10-27 07:52 alostale Assigned To platform => alostale
2015-10-27 07:52 alostale Status acknowledged => scheduled
2015-10-27 08:21 alostale Relationship added caused by 0029896
2015-10-27 08:21 alostale Review Assigned To caristu => AugustoMauch
2015-10-27 08:21 alostale Regression date => 2015-05-18
2015-10-27 08:21 alostale Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/2d6b8e5005b29bbca7ae4fd977ba6e18d8ac5201 [^]
2015-10-27 08:29 hgbot Checkin
2015-10-27 08:29 hgbot Note Added: 0081324
2015-10-27 08:29 hgbot Status scheduled => resolved
2015-10-27 08:29 hgbot Resolution open => fixed
2015-10-27 08:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3a698bde90ad5354ff9e7ceabfeebf1bf6e89d4a [^]
2015-10-27 09:37 alostale Note Added: 0081330
2015-10-27 09:42 alostale Relationship added related to 0031104
2015-10-27 09:45 AugustoMauch Note Added: 0081333
2015-10-27 09:45 AugustoMauch Status resolved => closed
2015-10-27 09:45 AugustoMauch Fixed in Version => 3.0PR16Q1
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082159


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker