Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032399
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] B. User interfaceminoralways2016-03-03 14:022016-03-08 10:00
ReporterJONHMView Statuspublic 
Assigned Toinigosanchez 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q1
StatusclosedFix in branchFixed in SCM revisione7f592a04326
ProjectionnoneETAnoneTarget Version3.0PR16Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date
Regression introduced in release3.0PR15Q3
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032399: cannot filter grid when it is grouped by a column

DescriptionWe cannot filter results after grouping by date in Multiphase Project view. We got some error on Chrome's debugging window:
"Uncaught TypeError: this.data.willFetchData is not a function"
"isc.OBViewGrid.addProperties.handleFilterEditorSubmit"
Steps To Reproduce1) Enter some data with dates in "Multiphase Project" view
2) Group by date column
3) Filter by some column (for example, name)

The filter doesn't work

This is reproducible for any window
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00323963.0PR16Q2 closedinigosanchez cannot filter grid when it is grouped by a column 

-  Notes
(0084781)
hgbot (developer)
2016-03-07 15:48

Repository: erp/backports/3.0PR16Q1
Changeset: e7f592a043260ec5da1fe3ea28e66865d1e210c1
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Mon Mar 07 15:46:50 2016 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR16Q1/rev/e7f592a043260ec5da1fe3ea28e66865d1e210c1 [^]

Fixes issue 32399: cannot filter grid when it is grouped by a column.

Having a column grouped, if a filter was applied in a grid, it was not possible to apply it.
A js error was thrown: Uncaught TypeError: this.data.willFetchData is not a function.

The problem was in "if (..... || (this.data.willFetchData(this.convertCriteria(criteria)))"
statement which incorrectly assumed this.data to be an object and willFetchData a function
within it. This is not true when in this situation where this.data is a Tree class.

It has been fixed by taking into account this case by checking that "this.data" defines the
function.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0084809)
alostale (developer)
2016-03-08 10:00

code reviewed

tested:
* grouping by different fields (date, numeric, FK) filters work in grouped column as well as in other ones
* related issues (0029896 and 0031187) are still not reproducible

- Issue History
Date Modified Username Field Change
2016-03-03 17:24 alostale Type defect => backport
2016-03-03 17:24 alostale Target Version 3.0PR16Q2 => 3.0PR16Q1
2016-03-07 15:45 inigosanchez Issue Monitored: alostale
2016-03-07 15:48 hgbot Checkin
2016-03-07 15:48 hgbot Note Added: 0084781
2016-03-07 15:48 hgbot Status scheduled => resolved
2016-03-07 15:48 hgbot Resolution open => fixed
2016-03-07 15:48 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR16Q1/rev/e7f592a043260ec5da1fe3ea28e66865d1e210c1 [^]
2016-03-07 15:48 inigosanchez Review Assigned To => alostale
2016-03-08 09:53 alostale Assigned To platform => inigosanchez
2016-03-08 10:00 alostale Note Added: 0084809
2016-03-08 10:00 alostale Status resolved => closed
2016-03-08 10:00 alostale Fixed in Version => 3.0PR16Q1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker