Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029388
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajoralways2015-03-24 16:192015-04-22 10:15
ReporterngarciaView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revision9216d290b2f2
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-06-19
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/f94f08e02e3a [^]
Triggers an Emergency PackYes
Summary

0029388: Duplicated records in Used Credit Source tab when clicking Done more than once in Add Details pop-up

DescriptionDuplicated records in Used Credit Source tab when clicking Done more than once in Add Details pop-up
Steps To ReproduceAs group admin:
   Create a Payment In to generate credit to a Customer
   Create a Sales Invoice for a bigger amount than the credit generated
   Create a Payment In, select the previously created credit and click on Done repeatedly
   Check more than one record is introduced in Used Credit Source tab
   Reactivate the Payment In and check the Used Credit field of the payment in which the credit was generated is negative
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00294163.0PR15Q1.3 closedalostale Duplicated records in Used Credit Source tab when clicking Done more than once in Add Details pop-up 
depends on defect 00294183.0PR15Q2 closedalostale API change in process definition client side validation function 
caused by design defect 0025978 closededuardo_Argal Performance problems in APRM manual screens 
caused by feature request 0029391 closedSandrahuguet Add Payment refactor project 
related to defect 0029426 closedalostale unneeded param in callback for client side validation of process definition 
causes defect 0029439 closedalostale Process Definition popup is not closed after executing the process behind 

-  Notes
(0075992)
hgbot (developer)
2015-03-26 10:33

Repository: erp/devel/pi
Changeset: 9216d290b2f207e748568dc7430aaf7ca41d5033
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Mar 26 10:26:30 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/9216d290b2f207e748568dc7430aaf7ca41d5033 [^]

fixed bug 29388, related to issue 29418: Done can be clicked more than once

  In process definition Done button was enabled and clickable while client side
  validations were being evaluated. This was specially noticeable if those validations
  perform backend requests to be completed (which is the case of Add Payment).

  Fixed by disabling Done button as first step before executing any validation.

---
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-addPayment.js
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-addTransaction.js
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-findTransaction.js
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-matchStatement.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-parameter-window-view.js
M web/js/validateCostingRuleProcess.js
---
(0076022)
hudsonbot (developer)
2015-03-26 16:35

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/74bd53f51456 [^]
Maturity status: Test
(0076032)
AugustoMauch (developer)
2015-03-26 18:24

Code reviewed and verified in pi@9a240957107d
(0076033)
AugustoMauch (developer)
2015-03-26 18:26

The data was fixed in this issue [1]

[1] https://issues.openbravo.com/view.php?id=29145 [^]

- Issue History
Date Modified Username Field Change
2015-03-24 16:19 ngarcia New Issue
2015-03-24 16:19 ngarcia Assigned To => umartirena
2015-03-24 16:19 ngarcia Modules => Core
2015-03-24 16:19 ngarcia Triggers an Emergency Pack => No
2015-03-24 16:19 ngarcia Issue Monitored: networkb
2015-03-24 16:38 jpcalvente Issue Monitored: jpcalvente
2015-03-24 17:03 umartirena Assigned To umartirena => ngarcia
2015-03-24 17:03 umartirena Assigned To ngarcia => platform
2015-03-24 17:23 umartirena Regression introduced in release => 3.0PR14Q3
2015-03-24 17:23 umartirena Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/f94f08e02e3a [^]
2015-03-24 17:23 umartirena Triggers an Emergency Pack No => Yes
2015-03-24 19:19 alostale Priority urgent => immediate
2015-03-25 08:28 alostale Regression level => Production - Confirmed Stable
2015-03-25 08:28 alostale Regression date => 2014-06-19
2015-03-26 08:18 alostale Status new => scheduled
2015-03-26 08:18 alostale Assigned To platform => alostale
2015-03-26 08:44 alostale Relationship added depends on 0029418
2015-03-26 10:33 hgbot Checkin
2015-03-26 10:33 hgbot Note Added: 0075992
2015-03-26 10:33 hgbot Status scheduled => resolved
2015-03-26 10:33 hgbot Resolution open => fixed
2015-03-26 10:33 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9216d290b2f207e748568dc7430aaf7ca41d5033 [^]
2015-03-26 10:35 dmitry_mezentsev Relationship added caused by 0025978
2015-03-26 11:29 alostale Relationship added related to 0029426
2015-03-26 11:54 alostale Review Assigned To => alostale
2015-03-26 16:26 alostale Review Assigned To alostale => AugustoMauch
2015-03-26 16:35 hudsonbot Checkin
2015-03-26 16:35 hudsonbot Note Added: 0076022
2015-03-26 18:24 AugustoMauch Note Added: 0076032
2015-03-26 18:24 AugustoMauch Status resolved => closed
2015-03-26 18:24 AugustoMauch Fixed in Version => 3.0PR15Q2
2015-03-26 18:26 AugustoMauch Note Added: 0076033
2015-03-30 09:57 alostale Relationship added causes 0029439
2015-04-22 10:15 dmitry_mezentsev Relationship added caused by 0029391


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker