Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029439
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2015-03-27 12:232015-03-31 00:07
ReporterumartirenaView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revision478c2849361a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2014-03-26
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/9216d290b2f2 [^]
Triggers an Emergency PackNo
Summary

0029439: Process Definition popup is not closed after executing the process behind

DescriptionProcess Definition popup is not closed after executing the process behind. The popup keeps opened even the process finishes successfully or raises any error. So it is impossible to know what has happened.
Steps To ReproduceIn Live Builds:

Go to Organization window:
 * Select F&B España, S.A org and remove its currency

Go to Costing Rule window and create a new record:
 * Org: F&B España, S.A
 * Costing Algorithm: Average Algorithm
 * Select Backdated Transactions Fixed.

Save and Click on Validate Costing Rule.

Notice that the popup keeps opened forever and it does not display nor success neither error.
If look at the log you will see that the following error has been raised:

ERROR org.openbravo.base.exception.OBException - @NoCurrencyInCostingRuleOrg@
org.openbravo.base.exception.OBException: @NoCurrencyInCostingRuleOrg@
    at org.openbravo.costing.CostingRuleProcess.execute(CostingRuleProcess.java:81)
    at org.openbravo.costing.CostingRuleProcessActionHandler.doExecute(CostingRuleProcessActionHandler.java:66)
    at org.openbravo.client.application.process.BaseProcessActionHandler.execute(BaseProcessActionHandler.java:152)
    at org.openbravo.client.kernel.BaseActionHandler.execute(BaseActionHandler.java:71)
    at org.openbravo.client.kernel.KernelServlet.processActionRequest(KernelServlet.java:294)
    at org.openbravo.client.kernel.KernelServlet.doGet(KernelServlet.java:186)
    at org.openbravo.client.kernel.KernelServlet.doPost(KernelServlet.java:267)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00294533.0PR15Q1.3 closedalostale Process Definition popup is not closed after executing the process behind 
caused by defect 0029388 closedalostale Duplicated records in Used Credit Source tab when clicking Done more than once in Add Details pop-up 

-  Notes
(0076115)
hgbot (developer)
2015-03-30 10:08

Repository: erp/devel/pi
Changeset: 478c2849361a33e647657cec11eb3bc91c7c6807
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Mar 30 10:07:10 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/478c2849361a33e647657cec11eb3bc91c7c6807 [^]

fixed bug 29439: Process Definition without params popup is not closed

  When a process defintion has no parameters, it is not closed after execution/failure.

  The problem was due the invokation of allRequiredParametersSet which now is performed
  after validation, this method incorretly assumed there was a form with paramters.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-parameter-window-view.js
---
(0076146)
AugustoMauch (developer)
2015-03-30 14:15

Code reviewed and verified in pi@8f36b14dbc05
(0076161)
hudsonbot (developer)
2015-03-31 00:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/34da08f135b8 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-03-27 12:23 umartirena New Issue
2015-03-27 12:23 umartirena Assigned To => alostale
2015-03-27 12:23 umartirena Modules => Core
2015-03-27 12:23 umartirena Regression level => Pre packaging ( pi )
2015-03-27 12:23 umartirena Regression introduced in release => pi
2015-03-27 12:23 umartirena Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/9216d290b2f2 [^]
2015-03-27 12:23 umartirena Triggers an Emergency Pack => No
2015-03-30 09:57 alostale Relationship added caused by 0029388
2015-03-30 10:04 alostale Status new => scheduled
2015-03-30 10:08 alostale Review Assigned To => AugustoMauch
2015-03-30 10:08 alostale Regression date => 2014-03-26
2015-03-30 10:08 hgbot Checkin
2015-03-30 10:08 hgbot Note Added: 0076115
2015-03-30 10:08 hgbot Status scheduled => resolved
2015-03-30 10:08 hgbot Resolution open => fixed
2015-03-30 10:08 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/478c2849361a33e647657cec11eb3bc91c7c6807 [^]
2015-03-30 14:15 AugustoMauch Note Added: 0076146
2015-03-30 14:15 AugustoMauch Status resolved => closed
2015-03-30 14:15 AugustoMauch Fixed in Version => 3.0PR15Q2
2015-03-31 00:07 hudsonbot Checkin
2015-03-31 00:07 hudsonbot Note Added: 0076161


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker