Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029453
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformmajorhave not tried2015-03-27 12:232015-04-08 18:40
ReporterumartirenaView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q1.3
StatusclosedFix in branchFixed in SCM revision7113377f5e9f
ProjectionnoneETAnoneTarget Version3.0PR15Q1.3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/9216d290b2f2 [^]
Triggers an Emergency PackNo
Summary

0029453: Process Definition popup is not closed after executing the process behind

DescriptionProcess Definition popup is not closed after executing the process behind. The popup keeps opened even the process finishes successfully or raises any error. So it is impossible to know what has happened.
Steps To ReproduceIn Live Builds:

Go to Organization window:
 * Select F&B España, S.A org and remove its currency

Go to Costing Rule window and create a new record:
 * Org: F&B España, S.A
 * Costing Algorithm: Average Algorithm
 * Select Backdated Transactions Fixed.

Save and Click on Validate Costing Rule.

Notice that the popup keeps opened forever and it does not display nor success neither error.
If look at the log you will see that the following error has been raised:

ERROR org.openbravo.base.exception.OBException - @NoCurrencyInCostingRuleOrg@
org.openbravo.base.exception.OBException: @NoCurrencyInCostingRuleOrg@
    at org.openbravo.costing.CostingRuleProcess.execute(CostingRuleProcess.java:81)
    at org.openbravo.costing.CostingRuleProcessActionHandler.doExecute(CostingRuleProcessActionHandler.java:66)
    at org.openbravo.client.application.process.BaseProcessActionHandler.execute(BaseProcessActionHandler.java:152)
    at org.openbravo.client.kernel.BaseActionHandler.execute(BaseActionHandler.java:71)
    at org.openbravo.client.kernel.KernelServlet.processActionRequest(KernelServlet.java:294)
    at org.openbravo.client.kernel.KernelServlet.doGet(KernelServlet.java:186)
    at org.openbravo.client.kernel.KernelServlet.doPost(KernelServlet.java:267)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to backport 00294163.0PR15Q1.3 closedalostale Duplicated records in Used Credit Source tab when clicking Done more than once in Add Details pop-up 
blocks defect 0029439 closedalostale Process Definition popup is not closed after executing the process behind 

-  Notes
(0076346)
hgbot (developer)
2015-04-07 07:58

Repository: erp/backports/3.0PR15Q1.3
Changeset: 7113377f5e9f3aee9e0989ebfc14369328ec3214
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Mar 30 10:07:10 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q1.3/rev/7113377f5e9f3aee9e0989ebfc14369328ec3214 [^]

fixed bug 29453: Process Definition without params popup is not closed

  When a process defintion has no parameters, it is not closed after execution/failure.

  The problem was due the invokation of allRequiredParametersSet which now is performed
  after validation, this method incorretly assumed there was a form with paramters.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-parameter-window-view.js
---
(0076390)
AugustoMauch (developer)
2015-04-08 18:40

Code reviewed and verified in [1]@eda5123f66b0

[1] https://code.openbravo.com/erp/backports/3.0PR15Q1.3/ [^] [^]

- Issue History
Date Modified Username Field Change
2015-03-30 10:04 alostale Type defect => backport
2015-03-30 10:04 alostale Target Version => 3.0PR15Q1.3
2015-03-30 10:04 alostale Relationship added related to 0029416
2015-03-30 11:53 ngarcia Issue Monitored: ngarcia
2015-04-07 07:58 hgbot Checkin
2015-04-07 07:58 hgbot Note Added: 0076346
2015-04-07 07:58 hgbot Status scheduled => resolved
2015-04-07 07:58 hgbot Resolution open => fixed
2015-04-07 07:58 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q1.3/rev/7113377f5e9f3aee9e0989ebfc14369328ec3214 [^]
2015-04-07 08:00 alostale Review Assigned To => AugustoMauch
2015-04-08 18:40 AugustoMauch Note Added: 0076390
2015-04-08 18:40 AugustoMauch Status resolved => closed
2015-04-08 18:40 AugustoMauch Fixed in Version => 3.0PR15Q1.3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker