Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029416
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] Z. Othersmajoralways2015-03-24 16:192015-04-08 18:39
ReporterngarciaView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q1.3
StatusclosedFix in branchFixed in SCM revision4b69ed748583
ProjectionnoneETAnoneTarget Version3.0PR15Q1.3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-06-19
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/f94f08e02e3a [^]
Triggers an Emergency PackYes
Summary

0029416: Duplicated records in Used Credit Source tab when clicking Done more than once in Add Details pop-up

DescriptionDuplicated records in Used Credit Source tab when clicking Done more than once in Add Details pop-up
Steps To ReproduceAs group admin:
   Create a Payment In to generate credit to a Customer
   Create a Sales Invoice for a bigger amount than the credit generated
   Create a Payment In, select the previously created credit and click on Done repeatedly
   Check more than one record is introduced in Used Credit Source tab
   Reactivate the Payment In and check the Used Credit field of the payment in which the credit was generated is negative
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on defect 00294183.0PR15Q2 closedalostale API change in process definition client side validation function 
related to backport 00294533.0PR15Q1.3 closedalostale Process Definition popup is not closed after executing the process behind 
blocks defect 0029388 closedalostale Duplicated records in Used Credit Source tab when clicking Done more than once in Add Details pop-up 

-  Notes
(0075988)
alostale (developer)
2015-03-26 08:23

The problem is that UI is locked to prevent extra clicks on Done button when the process begins, but this lock is not done while client side validations are performed, allowing multiple clicks during this lapse of time. This is specially noticeable in processes like Add Payment where validation requires to be completed in backend.
(0076345)
hgbot (developer)
2015-04-07 07:58

Repository: erp/backports/3.0PR15Q1.3
Changeset: 4b69ed748583e4f001c5f91d8994eaafaf9fb6f8
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Mar 26 10:26:30 2015 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR15Q1.3/rev/4b69ed748583e4f001c5f91d8994eaafaf9fb6f8 [^]

fixed bug 29416, related to issue 29424: Done can be clicked more than once

  In process definition Done button was enabled and clickable while client side
  validations were being evaluated. This was specially noticeable if those validations
  perform backend requests to be completed (which is the case of Add Payment).

  Fixed by disabling Done button as first step before executing any validation.

---
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-addPayment.js
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-addTransaction.js
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-findTransaction.js
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-matchStatement.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-parameter-window-view.js
M web/js/validateCostingRuleProcess.js
---
(0076389)
AugustoMauch (developer)
2015-04-08 18:39

Code reviewed and verified in [1]@eda5123f66b0

[1] https://code.openbravo.com/erp/backports/3.0PR15Q1.3/ [^] [^]

- Issue History
Date Modified Username Field Change
2015-03-26 08:18 alostale Type defect => backport
2015-03-26 08:18 alostale Target Version => 3.0PR15Q1.3
2015-03-26 08:18 alostale Assigned To platform => alostale
2015-03-26 08:23 alostale Note Added: 0075988
2015-03-26 08:44 alostale Relationship added depends on 0029418
2015-03-26 10:34 dmitry_mezentsev Tag Attached: Approved
2015-03-26 11:44 ngarcia Issue Monitored: ngarcia
2015-03-30 10:04 alostale Relationship added related to 0029453
2015-04-07 07:58 hgbot Checkin
2015-04-07 07:58 hgbot Note Added: 0076345
2015-04-07 07:58 hgbot Status scheduled => resolved
2015-04-07 07:58 hgbot Resolution open => fixed
2015-04-07 07:58 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q1.3/rev/4b69ed748583e4f001c5f91d8994eaafaf9fb6f8 [^]
2015-04-07 08:00 alostale Review Assigned To => AugustoMauch
2015-04-08 18:39 AugustoMauch Note Added: 0076389
2015-04-08 18:39 AugustoMauch Status resolved => closed
2015-04-08 18:39 AugustoMauch Fixed in Version => 3.0PR15Q1.3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker