Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026444
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2014-05-02 14:282014-09-29 17:04
ReporterngarciaView Statuspublic 
Assigned Tomalsasua 
PriorityimmediateResolutionfixedFixed in VersionRR14Q4
StatusclosedFix in branchFixed in SCM revision29e8b1f5fcf2
ProjectionnoneETAnoneTarget VersionRR14Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToOrekaria
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0026444: Invoices with total gross amount of 0 should not have a payment plan

DescriptionInvoices with total gross amount of 0 should not have a payment plan
Steps To ReproduceIn the back office:
   Check the POS Terminal Type has the Group Orders in One Invoice selected
In the POS Terminal:
   Create an order and invoice it
In the back office:
   Reactivate the associated invoice
In the POS Terminal:
   Create the same order but as a return
   Do not invoice it
   Do the Cash Up
In the back office:
   Check the created invoice total amount is 0
   Navigate to the Payment associated to the first order
   Reactivate the reconciliation and delete the financial account transaction related to it
   Try to reactivate the payment and check the following error message is shown:
      Error: / by zero
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0027695 closedmarvintm "Invoice Paid" field at Payment schedule Details level is not properly set by Cash Up process 
related to defect 0028419RR15Q1 closedmtaal Module script 26444 not running as preference check is incorrect 
causes defect 0027425 closedOrekaria Cash up invoices are created as not paid since Q2.2 
causes defect 0027815RR15Q1 closedmario_castello Negative and positive orders referenced for a zero invoice should have fin_payment_schedule_detail 

-  Notes
(0067766)
szapata (developer)
2014-06-05 02:00

Not able to reproduce. We talked with maite and still not reproducible.
If you can provide more information in order to reproduce the issue or if you can attach some logs it could help.
Best regards
(0068282)
maite (developer)
2014-06-24 17:51

Alternative steps to reproduce:

- Run "cash up" process to ensure that no previous data is pending
- Create a new receipt for any product and pay it
- Run "verified returns", search previous receipt and return it
- Run "cash up" process
- Access to back-end and search for last Sales Invoice created and related with your order and return. Realize that invoice's total is zero but it has Payment Plan record
(0068322)
hgbot (developer)
2014-06-25 23:01

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: fe1da9af1efad1dc07babe00326eb4e574526281
Author: Salvador Zapata <salvador.zapata <at> gmail.com>
Date: Wed Jun 25 18:00:45 2014 -0300
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/fe1da9af1efad1dc07babe00326eb4e574526281 [^]

fixed issue 26444: Invoice with grand total amount should not have payment plan

---
M src/org/openbravo/retail/posterminal/OrderGroupingProcessor.java
---
(0068429)
hgbot (developer)
2014-06-27 19:30

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: d9851ae39b2cc416f35e3da4765a93aa96b614e5
Author: Salvador Zapata <salvador.zapata <at> gmail.com>
Date: Fri Jun 27 14:28:31 2014 -0300
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d9851ae39b2cc416f35e3da4765a93aa96b614e5 [^]

fixed issue 26444: Invoice with grand total amount should not have payment plan

---
M src/org/openbravo/retail/posterminal/OrderGroupingProcessor.java
---
(0068445)
Orekaria (administrator)
2014-06-30 13:33

tested in rev. 3693
(0069909)
hgbot (developer)
2014-09-02 12:35

Repository: tools/automation/pi-mobile
Changeset: ba366135abe7c26ae9fc5e155a9dde0dcdd02fb3
Author: Rafa Alonso <rafael.alonso <at> openbravo.com>
Date: Tue Sep 02 11:17:26 2014 +0200
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/ba366135abe7c26ae9fc5e155a9dde0dcdd02fb3 [^]

Related to issue 26444 and issue 27425: added regression related tests:
- I26444_InvoicesWithTotalGross0ShouldNotHavePaymentPlan
- I27425_InvoicesWronglyCreatedAsNotPaid

---
M src-test/org/openbravo/retail/integrationtest/tests/issues/RetailIssuesTestSuite.java
A src-test/org/openbravo/retail/integrationtest/tests/issues/I26444_InvoicesWithTotalGross0ShouldNotHavePaymentPlan.java
A src-test/org/openbravo/retail/integrationtest/tests/issues/I27425_InvoicesWronglyCreatedAsNotPaid.java
R src-test/org/openbravo/retail/integrationtest/tests/issues/pending/I26444_InvoicesWithTotalGross0ShouldNotHavePaymentPlan.java
---
(0070180)
hgbot (developer)
2014-09-17 14:40

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: e065cbc029edad948c0404eb9c0d4f97753c595d
Author: Salvador Zapata <salvador.zapata <at> gmail.com>
Date: Wed Sep 17 13:20:34 2014 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e065cbc029edad948c0404eb9c0d4f97753c595d [^]

Fixed issue 26444: modulescript added

---
A build/classes/org/openbravo/retail/posterminal/modulescript/FixDataIssue26444.class
A src-db/database/model/functions/OBPOS_FIXISSUE26444.xml
A src-util/modulescript/src/org/openbravo/retail/posterminal/modulescript/FixDataIssue26444.java
---
(0070193)
hgbot (developer)
2014-09-18 09:41

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 79500303f4b7a3ea2b2c714ef1781fb0d22a84c9
Author: Salvador Zapata <salvador.zapata <at> gmail.com>
Date: Thu Sep 18 09:39:36 2014 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/79500303f4b7a3ea2b2c714ef1781fb0d22a84c9 [^]

Fixed issue 26444: changed license

---
M src-util/modulescript/src/org/openbravo/retail/posterminal/modulescript/FixDataIssue26444.java
---
(0070249)
hgbot (developer)
2014-09-22 18:44

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: c5f9a5093290f1442bea6a005bd73e7de1c95c60
Author: Salvador Zapata <salvador.zapata <at> gmail.com>
Date: Mon Sep 22 11:01:27 2014 -0300
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/c5f9a5093290f1442bea6a005bd73e7de1c95c60 [^]

Fixed issue 26444: refactor modulescript

---
M build/classes/org/openbravo/retail/posterminal/modulescript/FixDataIssue26444.class
M src-util/modulescript/src/org/openbravo/retail/posterminal/modulescript/FixDataIssue26444.java
A src-util/modulescript/src/org/openbravo/retail/posterminal/modulescript/FixDataIssue26444_Data.xsql
---
(0070250)
hgbot (developer)
2014-09-22 18:44

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 92e02a9b07ef87ec292c42c22b8ccbb693ed2a1f
Author: Salvador Zapata <salvador.zapata <at> gmail.com>
Date: Mon Sep 22 12:23:11 2014 -0300
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/92e02a9b07ef87ec292c42c22b8ccbb693ed2a1f [^]

Fixed issue 26444: refactor

---
M build/classes/org/openbravo/retail/posterminal/modulescript/FixDataIssue26444.class
A build/classes/org/openbravo/retail/posterminal/modulescript/FixDataIssue26444Data.class
---
(0070251)
hgbot (developer)
2014-09-22 19:17

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 72f4d98842c2b8aefd666c198ddfbdf485ea7d84
Author: Salvador Zapata <salvador.zapata <at> gmail.com>
Date: Mon Sep 22 14:15:59 2014 -0300
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/72f4d98842c2b8aefd666c198ddfbdf485ea7d84 [^]

Fixed issue 26444: fixed oracle alias

---
M build/classes/org/openbravo/retail/posterminal/modulescript/FixDataIssue26444Data.class
M src-util/modulescript/src/org/openbravo/retail/posterminal/modulescript/FixDataIssue26444_Data.xsql
---
(0070288)
hgbot (developer)
2014-09-23 22:10

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 29e8b1f5fcf2b7d3ee0fbf84c34ab4a3a2fe4c8c
Author: Salvador Zapata <salvador.zapata <at> gmail.com>
Date: Tue Sep 23 17:09:44 2014 -0300
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/29e8b1f5fcf2b7d3ee0fbf84c34ab4a3a2fe4c8c [^]

Fixed issue 26444: Optimized execution of the modulescript due to a massive tables are involved

---
M build/classes/org/openbravo/retail/posterminal/modulescript/FixDataIssue26444.class
M build/classes/org/openbravo/retail/posterminal/modulescript/FixDataIssue26444Data.class
M src-util/modulescript/src/org/openbravo/retail/posterminal/modulescript/FixDataIssue26444.java
M src-util/modulescript/src/org/openbravo/retail/posterminal/modulescript/FixDataIssue26444_Data.xsql
---

- Issue History
Date Modified Username Field Change
2014-05-02 14:28 ngarcia New Issue
2014-05-02 14:28 ngarcia Assigned To => malsasua
2014-05-02 14:28 ngarcia Triggers an Emergency Pack => No
2014-05-02 14:28 ngarcia Issue Monitored: networkb
2014-06-05 02:00 szapata Note Added: 0067766
2014-06-05 02:00 szapata Status new => feedback
2014-06-24 17:51 maite Note Added: 0068282
2014-06-24 17:52 maite Issue Monitored: maite
2014-06-24 18:01 ngarcia Status feedback => scheduled
2014-06-24 18:01 ngarcia fix_in_branch => pi
2014-06-24 19:08 maite Priority urgent => immediate
2014-06-24 19:08 maite fix_in_branch pi =>
2014-06-25 23:01 hgbot Checkin
2014-06-25 23:03 hgbot Note Added: 0068322
2014-06-25 23:03 hgbot Status scheduled => resolved
2014-06-25 23:03 hgbot Resolution open => fixed
2014-06-25 23:03 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/fe1da9af1efad1dc07babe00326eb4e574526281 [^]
2014-06-27 19:30 hgbot Checkin
2014-06-27 19:30 hgbot Note Added: 0068429
2014-06-27 19:30 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/fe1da9af1efad1dc07babe00326eb4e574526281 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d9851ae39b2cc416f35e3da4765a93aa96b614e5 [^]
2014-06-30 13:33 Orekaria Review Assigned To => Orekaria
2014-06-30 13:33 Orekaria Note Added: 0068445
2014-06-30 13:33 Orekaria Status resolved => closed
2014-06-30 13:33 Orekaria Fixed in Version => RR14Q3
2014-09-01 19:49 Orekaria Relationship added causes 0027425
2014-09-02 12:35 hgbot Checkin
2014-09-02 12:35 hgbot Note Added: 0069909
2014-09-02 14:10 ngarcia Issue Monitored: ngarcia
2014-09-17 14:40 hgbot Checkin
2014-09-17 14:40 hgbot Note Added: 0070180
2014-09-17 14:40 hgbot Status closed => resolved
2014-09-17 14:40 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d9851ae39b2cc416f35e3da4765a93aa96b614e5 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e065cbc029edad948c0404eb9c0d4f97753c595d [^]
2014-09-18 09:41 hgbot Checkin
2014-09-18 09:41 hgbot Note Added: 0070193
2014-09-18 09:41 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e065cbc029edad948c0404eb9c0d4f97753c595d [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/79500303f4b7a3ea2b2c714ef1781fb0d22a84c9 [^]
2014-09-22 18:44 hgbot Checkin
2014-09-22 18:44 hgbot Note Added: 0070249
2014-09-22 18:44 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/79500303f4b7a3ea2b2c714ef1781fb0d22a84c9 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/c5f9a5093290f1442bea6a005bd73e7de1c95c60 [^]
2014-09-22 18:44 hgbot Checkin
2014-09-22 18:44 hgbot Note Added: 0070250
2014-09-22 18:44 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/c5f9a5093290f1442bea6a005bd73e7de1c95c60 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/92e02a9b07ef87ec292c42c22b8ccbb693ed2a1f [^]
2014-09-22 19:17 hgbot Checkin
2014-09-22 19:17 hgbot Note Added: 0070251
2014-09-22 19:17 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/92e02a9b07ef87ec292c42c22b8ccbb693ed2a1f [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/72f4d98842c2b8aefd666c198ddfbdf485ea7d84 [^]
2014-09-23 22:10 hgbot Checkin
2014-09-23 22:10 hgbot Note Added: 0070288
2014-09-23 22:10 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/72f4d98842c2b8aefd666c198ddfbdf485ea7d84 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/29e8b1f5fcf2b7d3ee0fbf84c34ab4a3a2fe4c8c [^]
2014-09-26 15:09 Orekaria Relationship added related to 0027695
2014-09-29 17:04 marvintm Status resolved => closed
2014-09-29 17:04 marvintm Fixed in Version RR14Q3 => RR14Q4
2014-10-09 13:38 maite Relationship added causes 0027815
2014-12-16 01:33 mtaal Relationship added related to 0028419


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker