Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027815
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2014-10-09 13:352014-11-05 18:05
ReportermaiteView Statuspublic 
Assigned Tomario_castello 
PriorityimmediateResolutionfixedFixed in VersionRR14Q4
StatusclosedFix in branchFixed in SCM revision4a0c275a4916
ProjectionnoneETAnoneTarget VersionRR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomalsasua
Regression levelPackaging and release
Regression date
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/fe1da9af1efad1dc07babe00326eb4e574526281 [^]
Triggers an Emergency PackNo
Summary

0027815: Negative and positive orders referenced for a zero invoice should have fin_payment_schedule_detail

DescriptionNegative and positive orders related to a zero invoice should have fin_payment_schedule_detail
Steps To Reproduce- Run "cash up" process to ensure that no previous data is pending
- Create a new receipt for any product and pay it
- Run "verified returns", search previous receipt and return it
- Run "cash up" process
- Access to back-end and search for your sales order and return order. Navigate to Payment Plan tab and Payment Details tab and realize that there is no record in Payment Details tab when should be a detail related with that order
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0026444RR14Q3 closedmalsasua Invoices with total gross amount of 0 should not have a payment plan 

-  Notes
(0071441)
hgbot (developer)
2014-11-05 17:50

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 4a0c275a4916024664e23d76eb9bedbd4b419c53
Author: Mario Castello <mario.castello <at> peoplewalking.com>
Date: Wed Nov 05 10:49:52 2014 -0600
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/4a0c275a4916024664e23d76eb9bedbd4b419c53 [^]

fixed issue 27815: Negative and positive orders referenced for a zero invoice should have fin_payment_schedule_detail

---
M src/org/openbravo/retail/posterminal/OrderGroupingProcessor.java
---
(0071443)
malsasua (developer)
2014-11-05 18:05

verified

- Issue History
Date Modified Username Field Change
2014-10-09 13:35 maite New Issue
2014-10-09 13:35 maite Assigned To => marvintm
2014-10-09 13:35 maite Regression level => Packaging and release
2014-10-09 13:35 maite Triggers an Emergency Pack => No
2014-10-09 13:37 maite Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/fe1da9af1efad1dc07babe00326eb4e574526281 [^]
2014-10-09 13:37 maite Issue Monitored: networkb
2014-10-09 13:38 maite Relationship added caused by 0026444
2014-10-09 14:16 ngarcia Issue Monitored: ngarcia
2014-10-13 13:08 jonalegriaesarte Priority urgent => immediate
2014-10-13 13:08 jonalegriaesarte Target Version => RR15Q1
2014-11-03 16:31 mario_castello Assigned To marvintm => mario_castello
2014-11-05 17:50 hgbot Checkin
2014-11-05 17:50 hgbot Note Added: 0071441
2014-11-05 17:50 hgbot Status new => resolved
2014-11-05 17:50 hgbot Resolution open => fixed
2014-11-05 17:50 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/4a0c275a4916024664e23d76eb9bedbd4b419c53 [^]
2014-11-05 18:05 malsasua Review Assigned To => malsasua
2014-11-05 18:05 malsasua Note Added: 0071443
2014-11-05 18:05 malsasua Status resolved => closed
2014-11-05 18:05 malsasua Fixed in Version => RR14Q4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker