Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027695
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Cash upmajoralways2014-09-26 12:442014-10-10 14:40
ReportermaiteView Statuspublic 
Assigned Tomarvintm 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision757cfec4416f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027695: "Invoice Paid" field at Payment schedule Details level is not properly set by Cash Up process

Description"Invoice Paid" field at Payment schedule Details level is not properly set by Cash Up process
Steps To Reproduce1. Access retail terminal and run "Cash Up" process in order to "clean" previous data
2. From retail terminal, register any order and pay it
3. Run "Cash Up" process again to create invoice related with previous order
4. Go to Back Office and access "Sales Invoice" window. Navigate to "Payment Plan | Payment Details" tab and realize that "Invoice Paid" field is set to N when it should be Y as invoice is paid (you could need to show Invoice Paid field in grid mode to verify it)

NOTE: Invoice Paid field is properly set to Y if invoice is created using option "Invoice this receipt"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0027425 closedOrekaria Cash up invoices are created as not paid since Q2.2 
related to defect 0026444RR14Q3 closedmalsasua Invoices with total gross amount of 0 should not have a payment plan 
related to defect 0027492RR14Q4 closedszapata Invoices created with wrong totals at line level and also header level 

-  Notes
(0070798)
hgbot (developer)
2014-10-08 12:06

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 757cfec4416f527a8de7c01e371422a772284213
Author: Miguel A. Alsasua <miguel.alsasua <at> openbravo.com>
Date: Wed Oct 08 12:05:34 2014 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/757cfec4416f527a8de7c01e371422a772284213 [^]

fixed issue 27695:in cashup process, the payment details related to sales order as set as invoicePaid=Y and new module script is created to fix old data

---
M src/org/openbravo/retail/posterminal/OrderGroupingProcessor.java
A build/classes/org/openbravo/retail/posterminal/modulescript/FixDataIssue27695.class
A build/classes/org/openbravo/retail/posterminal/modulescript/FixDataIssue27695Data.class
A src-util/modulescript/src/org/openbravo/retail/posterminal/modulescript/FixDataIssue27695.java
A src-util/modulescript/src/org/openbravo/retail/posterminal/modulescript/FixDataIssue27695_Data.xsql
---
(0070879)
maite (developer)
2014-10-10 14:40

verified

- Issue History
Date Modified Username Field Change
2014-09-26 12:44 maite New Issue
2014-09-26 12:44 maite Assigned To => marvintm
2014-09-26 12:44 maite Triggers an Emergency Pack => No
2014-09-26 12:45 maite Steps to Reproduce Updated View Revisions
2014-09-26 12:46 maite Issue Monitored: networkb
2014-09-26 15:08 Orekaria Relationship added related to 0027425
2014-09-26 15:09 Orekaria Relationship added related to 0026444
2014-09-26 15:10 Orekaria Relationship added related to 0027492
2014-10-06 05:52 eintelau Issue Monitored: eintelau
2014-10-08 12:06 hgbot Checkin
2014-10-08 12:06 hgbot Note Added: 0070798
2014-10-08 12:06 hgbot Status new => resolved
2014-10-08 12:06 hgbot Resolution open => fixed
2014-10-08 12:06 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/757cfec4416f527a8de7c01e371422a772284213 [^]
2014-10-10 14:40 maite Note Added: 0070879
2014-10-10 14:40 maite Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker