Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027425
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POScriticalalways2014-08-22 18:492014-12-07 21:40
ReporterjecharriView Statuspublic 
Assigned ToOrekaria 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisione1d732f9f524
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toszapata
Regression levelProduction - Confirmed Stable
Regression date2014-06-27
Regression introduced in releaseRR14Q2.2
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d9851ae39b2cc416f35e3da4765a93aa96b614e5 [^]
Triggers an Emergency PackYes
Summary

0027425: Cash up invoices are created as not paid since Q2.2

DescriptionCash up invoices are created as not paid since Q2.2
Steps To Reproduce-Login to Web POS
-create an order
-do the cash up

Go to ERP and verify that the invoice is as not paid. Payment plan is telling that the received amount is 0 however the payment is related.

The fix must have a modulesscript
TagsNo tags attached.
Attached Filespng file icon not_paid.png [^] (142,505 bytes) 2014-08-22 18:52


? file icon 27425_modulescript.sql [^] (4,748 bytes) 2014-09-03 13:52

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0026444RR14Q3 closedmalsasua Invoices with total gross amount of 0 should not have a payment plan 
related to defect 0027695 closedmarvintm "Invoice Paid" field at Payment schedule Details level is not properly set by Cash Up process 
related to defect 0027793 closedmarvintm Modulescript FixDataIssue27425 fails sometimes in Oracle 
related to defect 0030190 closedRetail Modulescript for issue 27425 has performance problems 
causes defect 0027910RR14Q4 closedOrekaria The modulescript in issue 27425 will mark credit ticket as paid 

-  Notes
(0069902)
hgbot (developer)
2014-09-02 11:07

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 1619864e819d75839e90499b5b7f3fd6fc485d70
Author: Rafa Alonso <rafael.alonso <at> openbravo.com>
Date: Tue Sep 02 11:07:16 2014 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/1619864e819d75839e90499b5b7f3fd6fc485d70 [^]

Fixes issue 27425: Cashup invoices are created as paid

---
M src/org/openbravo/retail/posterminal/OrderGroupingProcessor.java
---
(0069910)
hgbot (developer)
2014-09-02 12:35

Repository: tools/automation/pi-mobile
Changeset: ba366135abe7c26ae9fc5e155a9dde0dcdd02fb3
Author: Rafa Alonso <rafael.alonso <at> openbravo.com>
Date: Tue Sep 02 11:17:26 2014 +0200
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/ba366135abe7c26ae9fc5e155a9dde0dcdd02fb3 [^]

Related to issue 26444 and issue 27425: added regression related tests:
- I26444_InvoicesWithTotalGross0ShouldNotHavePaymentPlan
- I27425_InvoicesWronglyCreatedAsNotPaid

---
M src-test/org/openbravo/retail/integrationtest/tests/issues/RetailIssuesTestSuite.java
A src-test/org/openbravo/retail/integrationtest/tests/issues/I26444_InvoicesWithTotalGross0ShouldNotHavePaymentPlan.java
A src-test/org/openbravo/retail/integrationtest/tests/issues/I27425_InvoicesWronglyCreatedAsNotPaid.java
R src-test/org/openbravo/retail/integrationtest/tests/issues/pending/I26444_InvoicesWithTotalGross0ShouldNotHavePaymentPlan.java
---
(0069913)
hgbot (developer)
2014-09-02 13:14

Repository: tools/automation/pi-mobile
Changeset: 5ac93a6db640f44593027df2b65729d42c48c400
Author: Rafa Alonso <rafael.alonso <at> openbravo.com>
Date: Tue Sep 02 13:14:23 2014 +0200
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/5ac93a6db640f44593027df2b65729d42c48c400 [^]

Related to issue 27425: added CreateSaleWithInvoice test for regular invoiced sales

---
M src-test/org/openbravo/retail/integrationtest/tests/RetailTestSuite.java
A src-test/org/openbravo/retail/integrationtest/tests/smoke/sales/CreateSaleWithInvoice.java
---
(0069950)
hgbot (developer)
2014-09-03 22:03

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: b0f48be3005029a24c7d6dce8978bb6e913a6dfd
Author: Rafa Alonso <rafael.alonso <at> openbravo.com>
Date: Wed Sep 03 22:02:34 2014 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b0f48be3005029a24c7d6dce8978bb6e913a6dfd [^]

Fixes issue 27425: Added modulescript to fix WebPOS cashup invoices wrongly created as not paid and with wrong amounts

---
A build/classes/org/openbravo/retail/posterminal/modulescript/FixDataIssue27425.class
A build/classes/org/openbravo/retail/posterminal/modulescript/FixDataIssue27425Data.class
A src-util/modulescript/src/org/openbravo/retail/posterminal/modulescript/FixDataIssue27425.java
A src-util/modulescript/src/org/openbravo/retail/posterminal/modulescript/FixDataIssue27425_Data.xsql
---
(0069957)
hgbot (developer)
2014-09-04 10:39

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: e1d732f9f524f136529843fe8e926d1215226f15
Author: Rafa Alonso <rafael.alonso <at> openbravo.com>
Date: Thu Sep 04 10:37:24 2014 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e1d732f9f524f136529843fe8e926d1215226f15 [^]

Fixes issue 27425: Added modulescript to fix WebPOS cashup invoices wrongly created as not paid and with wrong amounts.
- Commercial license text
- Compiled for Java 6

---
M build/classes/org/openbravo/retail/posterminal/modulescript/FixDataIssue27425.class
M build/classes/org/openbravo/retail/posterminal/modulescript/FixDataIssue27425Data.class
M src-util/modulescript/src/org/openbravo/retail/posterminal/modulescript/FixDataIssue27425.java
M src-util/modulescript/src/org/openbravo/retail/posterminal/modulescript/FixDataIssue27425_Data.xsql
---
(0072318)
mtaal (manager)
2014-12-07 21:40

There can be a situation that the grandtotal is only slightly different from the payment plan total. Like one or 2 cents difference. This can occur when the POS precision has not been set. Therefore below 2 queries which can be used in that case:
UPDATE fin_payment_schedule a
        SET paidamt = amount
        WHERE exists (
        SELECT c_invoice.c_invoice_id
        FROM c_invoice
        INNER JOIN c_invoiceline ON c_invoice.c_invoice_id = c_invoiceline.c_invoice_id
        LEFT JOIN fin_payment_schedule ON c_invoice.c_invoice_id = fin_payment_schedule.c_invoice_id
        INNER JOIN fin_payment_scheduledetail on fin_payment_schedule.fin_payment_schedule_id=fin_payment_scheduledetail.fin_payment_schedule_invoice
        INNER JOIN fin_payment_detail det on fin_payment_scheduledetail.fin_payment_detail_id=det.fin_payment_detail_id
        INNER JOIN c_orderline ON c_invoiceline.c_orderline_id = c_orderline.c_orderline_id
        INNER JOIN c_order ON c_orderline.c_order_id = c_order.c_order_id
        WHERE c_order.em_obpos_app_cashup_id IS NOT null AND c_invoice.c_invoice_id=a.c_invoice_id AND fin_payment_schedule.fin_payment_schedule_id IS NOT NULL AND c_invoice.ispaid = 'N'
        AND abs(c_invoice.grandtotal - (SELECT sum(pd.amount) from fin_payment_scheduledetail psd, fin_payment_detail pd WHERE pd.fin_payment_detail_id=psd.fin_payment_detail_id
     and psd.fin_payment_schedule_invoice =fin_payment_schedule.fin_payment_schedule_id))<1)

UPDATE c_invoice a
        SET totalpaid = grandtotal,
            outstandingamt = 0,
            finalsettlement = created,
            ispaid = 'Y'
        WHERE exists (
        SELECT c_invoice.c_invoice_id
        FROM c_invoice
        INNER JOIN c_invoiceline ON c_invoice.c_invoice_id = c_invoiceline.c_invoice_id
        LEFT JOIN fin_payment_schedule ON c_invoice.c_invoice_id = fin_payment_schedule.c_invoice_id
        INNER JOIN fin_payment_scheduledetail on fin_payment_schedule.fin_payment_schedule_id=fin_payment_scheduledetail.fin_payment_schedule_invoice
        INNER JOIN fin_payment_detail det on fin_payment_scheduledetail.fin_payment_detail_id=det.fin_payment_detail_id
        INNER JOIN c_orderline ON c_invoiceline.c_orderline_id = c_orderline.c_orderline_id
        INNER JOIN c_order ON c_orderline.c_order_id = c_order.c_order_id
        WHERE c_order.em_obpos_app_cashup_id IS NOT null AND c_invoice.c_invoice_id=a.c_invoice_id AND fin_payment_schedule.fin_payment_schedule_id IS NOT NULL AND c_invoice.ispaid = 'N'
        AND abs((SELECT sum(pd.amount) from fin_payment_scheduledetail psd, fin_payment_detail pd WHERE pd.fin_payment_detail_id=psd.fin_payment_detail_id
     and psd.fin_payment_schedule_invoice =fin_payment_schedule.fin_payment_schedule_id)-c_invoice.grandtotal)<1)
        )

- Issue History
Date Modified Username Field Change
2014-08-22 18:49 jecharri New Issue
2014-08-22 18:49 jecharri Assigned To => marvintm
2014-08-22 18:49 jecharri Regression level => Production - Confirmed Stable
2014-08-22 18:49 jecharri Regression introduced in release => RR14Q2.3
2014-08-22 18:49 jecharri Triggers an Emergency Pack => No
2014-08-22 18:52 jecharri File Added: not_paid.png
2014-08-28 10:29 Orekaria Assigned To marvintm => Orekaria
2014-08-28 12:12 gorka_gil Issue Monitored: gorka_gil
2014-09-01 16:04 eintelau Issue Monitored: eintelau
2014-09-01 18:51 Orekaria Regression introduced in release RR14Q2.3 => RR14Q2.2
2014-09-01 19:49 Orekaria Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d9851ae39b2cc416f35e3da4765a93aa96b614e5 [^]
2014-09-01 19:49 Orekaria Relationship added caused by 0026444
2014-09-02 11:07 hgbot Checkin
2014-09-02 11:07 hgbot Note Added: 0069902
2014-09-02 11:07 hgbot Status new => resolved
2014-09-02 11:07 hgbot Resolution open => fixed
2014-09-02 11:07 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/1619864e819d75839e90499b5b7f3fd6fc485d70 [^]
2014-09-02 12:35 hgbot Checkin
2014-09-02 12:35 hgbot Note Added: 0069910
2014-09-02 13:14 hgbot Checkin
2014-09-02 13:14 hgbot Note Added: 0069913
2014-09-02 14:10 ngarcia Issue Monitored: ngarcia
2014-09-03 13:52 Orekaria Status resolved => new
2014-09-03 13:52 Orekaria Resolution fixed => open
2014-09-03 13:52 Orekaria File Added: 27425_modulescript.sql
2014-09-03 13:52 Orekaria Status new => scheduled
2014-09-03 13:52 Orekaria fix_in_branch => pi
2014-09-03 13:54 Orekaria Triggers an Emergency Pack No => Yes
2014-09-03 13:54 Orekaria fix_in_branch pi =>
2014-09-03 13:54 Orekaria Status scheduled => resolved
2014-09-03 13:54 Orekaria Fixed in Version => RR14Q4
2014-09-03 13:54 Orekaria Resolution open => fixed
2014-09-03 17:31 Orekaria Status resolved => new
2014-09-03 17:31 Orekaria Resolution fixed => open
2014-09-03 17:31 Orekaria Fixed in Version RR14Q4 =>
2014-09-03 17:32 Orekaria Summary Cash up invoices are created as not paid since Q2 => Cash up invoices are created as not paid since Q2.2
2014-09-03 17:32 Orekaria Description Updated View Revisions
2014-09-03 22:03 hgbot Checkin
2014-09-03 22:03 hgbot Note Added: 0069950
2014-09-03 22:03 hgbot Status new => resolved
2014-09-03 22:03 hgbot Resolution open => fixed
2014-09-03 22:03 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/1619864e819d75839e90499b5b7f3fd6fc485d70 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b0f48be3005029a24c7d6dce8978bb6e913a6dfd [^]
2014-09-04 10:39 hgbot Checkin
2014-09-04 10:39 hgbot Note Added: 0069957
2014-09-04 10:39 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b0f48be3005029a24c7d6dce8978bb6e913a6dfd [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e1d732f9f524f136529843fe8e926d1215226f15 [^]
2014-09-11 01:41 szapata Review Assigned To => szapata
2014-09-11 01:41 szapata Status resolved => closed
2014-09-26 15:08 Orekaria Relationship added related to 0027695
2014-10-01 15:42 plujan Regression date => 2014-06-27
2014-10-08 12:24 mtaal Relationship added related to 0027793
2014-10-17 19:11 jecharri Relationship added causes 0027910
2014-12-07 21:40 mtaal Note Added: 0072318
2015-06-16 15:10 marvintm Relationship added related to 0030190


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker