Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027910
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2014-10-17 19:102014-10-23 15:59
ReporterjecharriView Statuspublic 
Assigned ToOrekaria 
PriorityimmediateResolutionfixedFixed in VersionRR14Q4
StatusclosedFix in branchFixed in SCM revision54e8be8ebf45
ProjectionnoneETAnoneTarget VersionRR14Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomalsasua
Regression levelProduction - Confirmed Stable
Regression date2014-09-03
Regression introduced in releaseRR14Q2.3
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b0f48be3005029a24c7d6dce8978bb6e913a6dfd [^]
Triggers an Emergency PackNo
Summary

0027910: The modulescript in issue 27425 will mark credit ticket as paid

DescriptionThe modulescript in issue 27425 will mark credit ticket as paid

If you have an order created created in Web POS and you chose to pay on credit the invoice will be created as not paid. This is something that it is fine.

The problem is that the modulescript will mark the invoice as paid and also updating related fields to mark the invoice as paid
Steps To Reproduce-Go to Web POS
-Create and order and pay on credit

Execute the module script, verify that invoice is changed to payed status

Only completely paid invoices should be affected
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0027425 closedOrekaria Cash up invoices are created as not paid since Q2.2 

-  Notes
(0071044)
hgbot (developer)
2014-10-20 12:33

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 54e8be8ebf45f16b40a8a7d6e47e6c42008362f5
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon Oct 20 12:32:54 2014 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/54e8be8ebf45f16b40a8a7d6e47e6c42008362f5 [^]

Fixed issue 27910. The modulescript will mark as paid not all invoices, but only the ones whose payments sum the grand total amount of the invoice.

---
M build/classes/org/openbravo/retail/posterminal/modulescript/FixDataIssue27425Data.class
M src-util/modulescript/src/org/openbravo/retail/posterminal/modulescript/FixDataIssue27425_Data.xsql
---
(0071053)
hgbot (developer)
2014-10-20 17:20

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 3f42693e337fd7bee327922872d5ecb33ef7e9f3
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon Oct 20 17:20:12 2014 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/3f42693e337fd7bee327922872d5ecb33ef7e9f3 [^]

Related to issue 27910. Fixed small typo in Oracle.

---
M build/classes/org/openbravo/retail/posterminal/modulescript/FixDataIssue27425Data.class
M src-util/modulescript/src/org/openbravo/retail/posterminal/modulescript/FixDataIssue27425_Data.xsql
---
(0071054)
jecharri (developer)
2014-10-20 17:20

Also it will be necessary to create a script to fix the data that previous one broke
(0071063)
hgbot (developer)
2014-10-20 18:44

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: dc09f9595d0b511939e6bdf60f1968d84cc2d69a
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon Oct 20 18:44:41 2014 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/dc09f9595d0b511939e6bdf60f1968d84cc2d69a [^]

Related to issue 27910. Corrected query to take into account the case of multiple orders included in the invoice.

---
M build/classes/org/openbravo/retail/posterminal/modulescript/FixDataIssue27425Data.class
M src-util/modulescript/src/org/openbravo/retail/posterminal/modulescript/FixDataIssue27425_Data.xsql
---
(0071066)
malsasua (developer)
2014-10-20 22:16

verified

- Issue History
Date Modified Username Field Change
2014-10-17 19:10 jecharri New Issue
2014-10-17 19:10 jecharri Assigned To => Orekaria
2014-10-17 19:10 jecharri Regression level => Production - Confirmed Stable
2014-10-17 19:10 jecharri Regression date => 2014-09-03
2014-10-17 19:10 jecharri Regression introduced in release => RR14Q2.3
2014-10-17 19:10 jecharri Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b0f48be3005029a24c7d6dce8978bb6e913a6dfd [^]
2014-10-17 19:10 jecharri Triggers an Emergency Pack => No
2014-10-17 19:11 jecharri Relationship added caused by 0027425
2014-10-17 19:15 jecharri Steps to Reproduce Updated View Revisions
2014-10-20 12:33 hgbot Checkin
2014-10-20 12:33 hgbot Note Added: 0071044
2014-10-20 12:33 hgbot Status new => resolved
2014-10-20 12:33 hgbot Resolution open => fixed
2014-10-20 12:33 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/54e8be8ebf45f16b40a8a7d6e47e6c42008362f5 [^]
2014-10-20 17:20 hgbot Checkin
2014-10-20 17:20 hgbot Note Added: 0071053
2014-10-20 17:20 jecharri Note Added: 0071054
2014-10-20 18:44 hgbot Checkin
2014-10-20 18:44 hgbot Note Added: 0071063
2014-10-20 22:16 malsasua Review Assigned To => malsasua
2014-10-20 22:16 malsasua Note Added: 0071066
2014-10-20 22:16 malsasua Status resolved => closed
2014-10-20 22:16 malsasua Fixed in Version => RR14Q4
2014-10-23 15:59 ngarcia Issue Monitored: ngarcia


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker