Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024705
TypeCategorySeverityReproducibilityDate SubmittedLast Update
design defect[Openbravo ERP] A. Platformmajoralways2013-09-05 18:352014-05-22 22:16
ReporteregoitzView Statuspublic 
Assigned Todbaz 
PriorityurgentResolutionfixedFixed in Version3.0PR14Q3
StatusclosedFix in branchFixed in SCM revisionb6eadf200426
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024705: The windows takes long to be loaed when there are a lot of tabs and a lot of columns on the grid.

DescriptionThe windows takes long to be loaed when there are a lot of tabs and a lot of columns on the grid.

When you click on a menu item to open a window first of all the window is created and then the datasource is called.
When there are many tabs it takes long to creaet the tab, so the request to the datasource is done after some seconds.

It produces a delay on the window load.

ON computer (client side) with a big amount of resources the creating of the window is fater.




Steps To Reproduce
-Create several tabs on product window
-Open the window having the developers tool opened.
-See that after click it takes some seconds to do the request to the datasource.

-Without creating tabs, you can see that the request to the datasource is done faster on windows with a unique tab (Preferences) than on other tabs with more tabs (Product, Partner)
Proposed Solution-Not to create the window every time that you open it, have it on the cache.
or
-Do the request to the datasource at the same time that the window is created (asynchronous)
TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00253873.0MP31 closedalostale unneeded flushes in view generation 
related to defect 0026660 closedguillermogil Read Only tabs are editable when tab level is 2 
related to defect 00269903.0PR14Q2.3 closeddbaz Field access tab logic is not working 
related to defect 00270083.0PR14Q4 closedshankarb "Recent Documents" is not working under some circumstances 
related to defect 0028501 closedAugustoMauch Not possible to open a window in read only mode more than once 
related to defect 00288933.0PR15Q2 closedalostale Not possible to nullify fields in grid view using window personalization 
related to defect 0037109 closedcaristu Parent form shown in blank when direct opening a record in a child tab having parent tab configured as "Default Edit Mode" 
related to defect 0039269 acknowledgedplatform Form Personalization > Restore Defaults button does not work properly in some tabs 
causes defect 00271213.0PR14Q4 closeddbaz Windows personalization open always the subtab hidding the header if you save in a special situation 
causes defect 00275033.0PR14Q4 closedAugustoMauch Form view is not working fine when using views 
causes defect 0028454 closedalostale can't nullify fields when 1st edition is in grid 

-  Notes
(0064021)
hgbot (developer)
2014-02-07 15:16

Repository: erp/devel/pi
Changeset: 09050a5b416213987340319de2dba42c481ca18e
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Fri Feb 07 15:16:17 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/09050a5b416213987340319de2dba42c481ca18e [^]

Related to issue 24705: Lazy evaluation of viewForm
Now most of the elements and the logic of the viewForm is loaded when the form needs to be visualized

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-window.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/personalization/ob-manage-views.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/personalization/ob-personalization.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/personalization/ob-personalize-form.js
---
(0064032)
hgbot (developer)
2014-02-10 16:48

Repository: erp/devel/pi
Changeset: 200ca8a32147615c0f0ca35c3ee84197721b1f3a
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Mon Feb 10 16:47:58 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/200ca8a32147615c0f0ca35c3ee84197721b1f3a [^]

Related to issue 24705: Lazy evaluation of viewForm - microfix

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0064174)
hudsonbot (developer)
2014-02-12 18:30

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d1a5bb862230 [^]
Maturity status: Test
(0064180)
hudsonbot (developer)
2014-02-12 18:30

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d1a5bb862230 [^]
Maturity status: Test
(0066518)
hgbot (developer)
2014-04-21 15:27

Repository: erp/devel/pi
Changeset: cb6171e6cd94ffc8e2004c26159a82f60fc35de3
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Mon Apr 21 15:19:02 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/cb6171e6cd94ffc8e2004c26159a82f60fc35de3 [^]

Fixed issue 26316: Status bar fields are shown again in saved views
Related to issue 24705: 'getPersonalizationDataFromForm' now takes into account existing form fields

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/personalization/ob-manage-views.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/personalization/ob-personalization.js
---
(0066801)
hgbot (developer)
2014-05-05 10:47

Repository: erp/devel/pi
Changeset: cd8dfb19562674d797f83a6327f16e230029b005
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Mon May 05 10:46:51 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/cd8dfb19562674d797f83a6327f16e230029b005 [^]

fixed issue 24705: improved client side performance when loading windows

lazy loading of grid fields, now grids and their fields are loaded only when
the tabs containing them are opened by user

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-window.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-tab.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/personalization/ob-manage-views.js
---
(0066804)
alostale (developer)
2014-05-05 11:18

code reviewed + tested
(0066830)
hgbot (developer)
2014-05-06 10:09

Repository: erp/devel/pi
Changeset: 3a3619678a3c9d34c1bb4d13c2ff79d493d95e74
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue May 06 10:08:33 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3a3619678a3c9d34c1bb4d13c2ff79d493d95e74 [^]

related to issue 24705: backed out grid lazy load changeset

  it was causing CI to fail

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-window.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-tab.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/personalization/ob-manage-views.js
---
(0066831)
alostale (developer)
2014-05-06 10:10

Reopening it because last changeset has been to be backed out as it was causing CI to fail
(0066954)
hudsonbot (developer)
2014-05-07 18:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/02ca2648bcdc [^]
Maturity status: Test
(0066995)
hudsonbot (developer)
2014-05-07 18:12

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/02ca2648bcdc [^]
Maturity status: Test
(0067000)
hudsonbot (developer)
2014-05-07 18:12

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/02ca2648bcdc [^]
Maturity status: Test
(0067037)
hgbot (developer)
2014-05-09 10:09

Repository: erp/devel/pi
Changeset: b6eadf2004263b2719ae7d003a3ae7ba60424be9
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri May 09 10:08:25 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b6eadf2004263b2719ae7d003a3ae7ba60424be9 [^]

fixed issue 24705: reaplying changeset after CI modifications

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-window.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-tab.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/personalization/ob-manage-views.js
---
(0067081)
alostale (developer)
2014-05-12 08:28

closed after successful CI
(0067086)
hgbot (developer)
2014-05-12 11:46

Repository: erp/devel/pi
Changeset: 9fa863bf7f350fcec062b7899d5fe546536ed1cd
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Mon May 12 11:45:41 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/9fa863bf7f350fcec062b7899d5fe546536ed1cd [^]

Related to issue 24705: Add some comments/help

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0067095)
hudsonbot (developer)
2014-05-12 17:35

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8bdb56ba8f66 [^]
Maturity status: Test
(0067159)
hudsonbot (developer)
2014-05-15 17:34

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8d6658b982c0 [^]
Maturity status: Test
(0067390)
dbaz (developer)
2014-05-22 22:16

The lazy loading of form view saves at least a 25% of the total time required to load the tab.

The lazy loading of the grid view saves at least another 25% of the total time required to load the tab.

Depending of the machine where the comparison be done, the percentage of the saving could be even higher.

- Issue History
Date Modified Username Field Change
2013-09-05 18:35 egoitz New Issue
2013-09-05 18:35 egoitz Assigned To => AugustoMauch
2013-09-05 18:35 egoitz Modules => Core
2013-09-05 18:35 egoitz Triggers an Emergency Pack => No
2013-09-09 16:44 jpcalvente Issue Monitored: jpcalvente
2013-12-19 01:22 egoitz Tag Attached: Performance
2013-12-20 12:39 alostale Relationship added related to 0025387
2014-02-07 15:16 hgbot Checkin
2014-02-07 15:16 hgbot Note Added: 0064021
2014-02-10 16:48 hgbot Checkin
2014-02-10 16:48 hgbot Note Added: 0064032
2014-02-12 18:30 hudsonbot Checkin
2014-02-12 18:30 hudsonbot Note Added: 0064174
2014-02-12 18:30 hudsonbot Checkin
2014-02-12 18:30 hudsonbot Note Added: 0064180
2014-04-04 15:41 johnfandl Issue Monitored: johnfandl
2014-04-21 15:27 hgbot Checkin
2014-04-21 15:27 hgbot Note Added: 0066518
2014-04-21 15:28 dbaz Assigned To AugustoMauch => dbaz
2014-04-21 15:28 dbaz Review Assigned To => alostale
2014-04-21 15:28 dbaz Steps to Reproduce Updated View Revisions
2014-04-21 15:28 dbaz Proposed Solution updated
2014-05-05 10:47 hgbot Checkin
2014-05-05 10:47 hgbot Note Added: 0066801
2014-05-05 10:47 hgbot Status new => resolved
2014-05-05 10:47 hgbot Resolution open => fixed
2014-05-05 10:47 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/cd8dfb19562674d797f83a6327f16e230029b005 [^]
2014-05-05 11:18 alostale Note Added: 0066804
2014-05-05 11:18 alostale Status resolved => closed
2014-05-05 11:18 alostale Fixed in Version => PR14Q3
2014-05-06 10:09 hgbot Checkin
2014-05-06 10:09 hgbot Note Added: 0066830
2014-05-06 10:10 alostale Note Added: 0066831
2014-05-06 10:10 alostale Status closed => new
2014-05-06 10:10 alostale Resolution fixed => open
2014-05-06 10:10 alostale Fixed in Version PR14Q3 =>
2014-05-07 18:11 hudsonbot Checkin
2014-05-07 18:11 hudsonbot Note Added: 0066954
2014-05-07 18:12 hudsonbot Checkin
2014-05-07 18:12 hudsonbot Note Added: 0066995
2014-05-07 18:12 hudsonbot Checkin
2014-05-07 18:12 hudsonbot Note Added: 0067000
2014-05-09 10:09 hgbot Checkin
2014-05-09 10:09 hgbot Note Added: 0067037
2014-05-09 10:09 hgbot Status new => resolved
2014-05-09 10:09 hgbot Resolution open => fixed
2014-05-09 10:09 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/cd8dfb19562674d797f83a6327f16e230029b005 [^] => http://code.openbravo.com/erp/devel/pi/rev/b6eadf2004263b2719ae7d003a3ae7ba60424be9 [^]
2014-05-12 08:28 alostale Note Added: 0067081
2014-05-12 08:28 alostale Status resolved => closed
2014-05-12 08:28 alostale Fixed in Version => PR14Q3
2014-05-12 11:46 hgbot Checkin
2014-05-12 11:46 hgbot Note Added: 0067086
2014-05-12 17:35 hudsonbot Checkin
2014-05-12 17:35 hudsonbot Note Added: 0067095
2014-05-15 17:34 hudsonbot Checkin
2014-05-15 17:34 hudsonbot Note Added: 0067159
2014-05-22 13:55 guillermogil Relationship added related to 0026660
2014-05-22 22:16 dbaz Note Added: 0067390
2014-07-02 09:36 alostale Relationship added related to 0026990
2014-07-18 10:33 shankarb Relationship added related to 0027008
2014-07-28 16:12 alostale Relationship added causes 0027121
2014-08-29 10:54 AugustoMauch Relationship added causes 0027503
2014-12-19 09:25 alostale Relationship added causes 0028454
2015-01-13 09:05 alostale Relationship added related to 0028501
2015-02-10 10:41 alostale Relationship added related to 0028893
2017-10-18 19:24 caristu Relationship added related to 0037109
2018-09-11 18:36 caristu Relationship added related to 0039269


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker