Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028454
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2014-12-18 18:552014-12-30 23:28
ReporteregoitzView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revision5d1b178472d1
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-02-07
Regression introduced in release3.0PR14Q2
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/09050a5b416213987340319de2dba42c481ca18e [^]
Triggers an Emergency PackNo
Summary

0028454: can't nullify fields when 1st edition is in grid

DescriptionIt is not possible to nullify any field if the first edition in that tab was done in grid view.
Steps To Reproduce1-Access to sales order window
2-Select a order in draf status
3-Go to the lines
4-add the description column on the grid.
5-Edit the line on grid view by adding a text on the description
6-Save
7-Edit the record on grid view and delete the description added
8-Save.
*The text of the description is restored with the value inserted on step 5.

This fails in all windows if 1st edition in the tab is done in grid view.
Proposed SolutionWhile this is not fixed, the workaround to be make possible to nullify fields is to do the 1st edition in form view.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 00244033.0MP29 closedAugustoMauch When the grid calls the datasource, it should not retrieve the properties that are not shown in the grid. 
caused by design defect 0024705 closeddbaz The windows takes long to be loaed when there are a lot of tabs and a lot of columns on the grid. 
has duplicate defect 0028820 closedalostale Not possible to set empty value in a column with table reference 
causes defect 00288933.0PR15Q2 closedalostale Not possible to nullify fields in grid view using window personalization 

-  Notes
(0072717)
alostale (developer)
2014-12-19 08:31

This seems to be a problem in the client side:

when the description is properly nullified the request payload includes description:null, whereas when it recovers previous value there is no description field.
(0072718)
hgbot (developer)
2014-12-19 09:46

Repository: erp/devel/pi
Changeset: 5d1b178472d15ec2181ae4a6a41be5ad5ddc4591
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Dec 19 09:45:01 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/5d1b178472d15ec2181ae4a6a41be5ad5ddc4591 [^]

fixed bug 28454: can't nullify fields when 1st edition is in grid

  When the first edition in a tab was done in grid view, it was not possible to
  nullify any field.

  The problem was null values are only sent to backend for fields present in the
  standard view. To get those fields form.getFields() method was invoked, in order
  to improve performance, form fields are only loaded when the form is opened 1st
  time, so if the form view was not opened before this check, all nulls were
  removed from the request. As this was cached, all further editions were using this
  incorrect cache.

  The fix consists in not using form.getFields() methods but to get the fields from
  view.formFields which is guaranteed to be loaded one the window is opened.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
---
(0072767)
hgbot (developer)
2014-12-22 12:07

Repository: erp/devel/pi
Changeset: 3e74f819198dcf17de572f343330ea39e6e1213c
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Dec 22 12:06:48 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/3e74f819198dcf17de572f343330ea39e6e1213c [^]

Related with issue 28454: Add comments to function

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view-datasource.js
---
(0072768)
AugustoMauch (developer)
2014-12-22 12:09

Code reviewed and verified in pi@3e74f819198d
(0072811)
hgbot (developer)
2014-12-24 11:09

Repository: tools/automation/int
Changeset: da23dea116bc1a53fa5c4394d3b40ceeb478836c
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Dec 19 12:03:27 2014 +0100
URL: http://code.openbravo.com/tools/automation/int/rev/da23dea116bc1a53fa5c4394d3b40ceeb478836c [^]

related to bug 28454: added selenium test case

 asserting it is possible to nullify fields from grid

---
M src-test/com/openbravo/test/integration/erp/modules/client/application/testsuites/standardview/grid/GridSuite.java
M src-test/com/openbravo/test/integration/erp/modules/client/application/testsuites/standardview/grid/build.xml
A src-test/com/openbravo/test/integration/erp/modules/client/application/testsuites/standardview/grid/GRD0200_NullifyField.java
---
(0073248)
hudsonbot (developer)
2014-12-30 23:28

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0073255)
hudsonbot (developer)
2014-12-30 23:28

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-12-18 18:55 egoitz New Issue
2014-12-18 18:55 egoitz Assigned To => AugustoMauch
2014-12-18 18:55 egoitz Modules => Core
2014-12-18 18:55 egoitz Triggers an Emergency Pack => No
2014-12-19 08:03 alostale Description Updated View Revisions
2014-12-19 08:03 alostale Steps to Reproduce Updated View Revisions
2014-12-19 08:04 alostale Regression level => Production - Confirmed Stable
2014-12-19 08:04 alostale Regression introduced in release => 3.0PR14Q2
2014-12-19 08:04 alostale Severity major => minor
2014-12-19 08:04 alostale Assigned To AugustoMauch => alostale
2014-12-19 08:04 alostale Priority urgent => immediate
2014-12-19 08:06 alostale Steps to Reproduce Updated View Revisions
2014-12-19 08:06 alostale Proposed Solution updated
2014-12-19 08:31 alostale Note Added: 0072717
2014-12-19 09:25 alostale Relationship added related to 0024403
2014-12-19 09:25 alostale Relationship added caused by 0024705
2014-12-19 09:27 alostale Regression date => 2014-02-07
2014-12-19 09:27 alostale Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/09050a5b416213987340319de2dba42c481ca18e [^]
2014-12-19 09:30 alostale Description Updated View Revisions
2014-12-19 09:30 alostale Steps to Reproduce Updated View Revisions
2014-12-19 09:30 alostale Proposed Solution updated
2014-12-19 09:38 alostale Summary Not possible to remove the description on order lines. => can't nullify fields editing in grid
2014-12-19 09:39 alostale Review Assigned To => AugustoMauch
2014-12-19 09:40 alostale Summary can't nullify fields editing in grid => can't nullify fields when 1st edition is in grid
2014-12-19 09:40 alostale Description Updated View Revisions
2014-12-19 09:46 hgbot Checkin
2014-12-19 09:46 hgbot Note Added: 0072718
2014-12-19 09:46 hgbot Status new => resolved
2014-12-19 09:46 hgbot Resolution open => fixed
2014-12-19 09:46 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5d1b178472d15ec2181ae4a6a41be5ad5ddc4591 [^]
2014-12-22 12:07 hgbot Checkin
2014-12-22 12:07 hgbot Note Added: 0072767
2014-12-22 12:09 AugustoMauch Note Added: 0072768
2014-12-22 12:09 AugustoMauch Status resolved => closed
2014-12-22 12:09 AugustoMauch Fixed in Version => 3.0PR15Q1
2014-12-24 11:09 hgbot Checkin
2014-12-24 11:09 hgbot Note Added: 0072811
2014-12-30 23:28 hudsonbot Checkin
2014-12-30 23:28 hudsonbot Note Added: 0073248
2014-12-30 23:28 hudsonbot Checkin
2014-12-30 23:28 hudsonbot Note Added: 0073255
2015-01-30 12:05 alostale Relationship added has duplicate 0028820
2015-02-09 12:43 alostale Relationship added related to 0028893
2015-02-10 10:41 alostale Relationship replaced causes 0028893


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker