Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028893
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-02-09 12:402015-02-10 19:35
ReporteregoitzView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revision05b7936848de
ProjectionnoneETAnoneTarget Version3.0PR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-12-19
Regression introduced in release3.0PR14Q3.5
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/5d1b178472d15ec2181ae4a6a41be5ad5ddc4591 [^]
Triggers an Emergency PackNo
Summary

0028893: Not possible to nullify fields in grid view using window personalization

DescriptionNot possible to nullify a dropdown using window personalization.
It happens when accessing by default to a custom grid view and when the first action peformed after open the window is to open a record on form view.
Steps To Reproduce-Access to the sales order window
-Add on the grid the payment method column.
-Save the view and set as default.
-Close the window
-Open again the sales order window from the menu
-Open a record on form view
-close the form view and go back to the grid
-Edit on grid view a record and try to nullify the payment method combo.
*After save the previous value is restored.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0024705 closeddbaz The windows takes long to be loaed when there are a lot of tabs and a lot of columns on the grid. 
caused by defect 0028454 closedalostale can't nullify fields when 1st edition is in grid 

-  Notes
(0074312)
alostale (developer)
2015-02-10 09:11
edited on: 2015-02-10 10:22

Note it only occurs having a saved view if before saving any edition form view is opened and first saved edition is saved in grid view.

(0074313)
egoitz (developer)
2015-02-10 09:25

Also happens with text fields
(0074314)
eugeni (reporter)
2015-02-10 09:29
edited on: 2015-02-10 09:33

In general, it happens when:
- You use a custom view +
- First saved edition is saved in FORM view (it works if first saved edition is saved in grid view)

(0074316)
hgbot (developer)
2015-02-10 10:54

Repository: erp/devel/pi
Changeset: 05b7936848de9683408839560623a291d08e6448
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Feb 10 10:52:58 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/05b7936848de9683408839560623a291d08e6448 [^]

fixed bug 28893: can't nullify fields in grid view using window personalization

  Using a saved view, if before any edition tab was opened in form view, and
  record edited in grid view, it was not possible to nullify fields.

  The problem was caused by changeset to fix 0028454 which assumed view.formFields
  was always set in order to compute the null fields that should be kept and the
  ones that should be removed when sending data to data source. This assumption was
  not correct in the case of having a saved view: when applying saved view, SmartClient
  removes items in view.formFields.

  The fix includes 2 modifications:
   1. Restore view.formFields after applying saved view
   2. When calculating columns don't assume view.formFields is always set, this part
      wouldn't be necessary for flow 1, but it prevents any other unforeseen possible
      flow

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/personalization/ob-personalization.js
---
(0074317)
alostale (developer)
2015-02-10 11:03

Added test case in TestLink: https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-8032 [^]
(0074323)
AugustoMauch (developer)
2015-02-10 13:19

Code reviewed and verified in pi@05b7936848de
(0074341)
hudsonbot (developer)
2015-02-10 19:35

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/24bb109056f1 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-02-09 12:40 egoitz New Issue
2015-02-09 12:40 egoitz Assigned To => AugustoMauch
2015-02-09 12:40 egoitz Modules => Core
2015-02-09 12:40 egoitz Triggers an Emergency Pack => No
2015-02-09 12:43 alostale Relationship added related to 0028454
2015-02-09 12:45 egoitz Regression level => Production - Confirmed Stable
2015-02-09 12:48 alostale Assigned To AugustoMauch => alostale
2015-02-09 13:02 eugeni Issue Monitored: eugeni
2015-02-10 09:11 alostale Note Added: 0074312
2015-02-10 09:25 egoitz Note Added: 0074313
2015-02-10 09:29 eugeni Note Added: 0074314
2015-02-10 09:33 eugeni Note Edited: 0074314 View Revisions
2015-02-10 10:22 alostale Note Edited: 0074312 View Revisions
2015-02-10 10:23 alostale Summary Not possible to nullify a dropdown using window personalization => Not possible to nullify fields in grid view using window personalization
2015-02-10 10:41 alostale Relationship added related to 0024705
2015-02-10 10:41 alostale Relationship replaced caused by 0028454
2015-02-10 10:44 alostale Review Assigned To => AugustoMauch
2015-02-10 10:44 alostale Regression date => 2014-12-19
2015-02-10 10:44 alostale Regression introduced in release => 3.0PR14Q3.5
2015-02-10 10:44 alostale Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/5d1b178472d15ec2181ae4a6a41be5ad5ddc4591 [^]
2015-02-10 10:54 hgbot Checkin
2015-02-10 10:54 hgbot Note Added: 0074316
2015-02-10 10:54 hgbot Status new => resolved
2015-02-10 10:54 hgbot Resolution open => fixed
2015-02-10 10:54 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/05b7936848de9683408839560623a291d08e6448 [^]
2015-02-10 11:03 alostale Note Added: 0074317
2015-02-10 13:19 AugustoMauch Note Added: 0074323
2015-02-10 13:19 AugustoMauch Status resolved => closed
2015-02-10 13:19 AugustoMauch Fixed in Version => 3.0PR15Q2
2015-02-10 19:35 hudsonbot Checkin
2015-02-10 19:35 hudsonbot Note Added: 0074341


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker