Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028501
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2014-12-30 10:462015-01-13 09:05
ReporterjecharriView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revisionb037d16612db
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todbaz
Web browserGoogle Chrome
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-05-22
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/052c07be4a9ddd2b2a61bd60e948370c53482cb4 [^]
Triggers an Emergency PackNo
Summary

0028501: Not possible to open a window in read only mode more than once

DescriptionNot possible to open a window in read only mode more than once. The window needs to have some tabs
Steps To Reproduce-Go to window "Role" and choose one
-Go to tab Window Access and choose from example "Sales Order" and set as read only for that role
-Login with the role
-Verify that you can open the window and not edit
-Close the window and try to go again

Verify that the window keeps in "Loading status"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0024705 closeddbaz The windows takes long to be loaed when there are a lot of tabs and a lot of columns on the grid. 
caused by defect 0026660 closedguillermogil Read Only tabs are editable when tab level is 2 

-  Notes
(0072874)
hgbot (developer)
2014-12-30 13:02

Repository: erp/devel/pi
Changeset: b037d16612db0ee7d465bb3de1332d3a7b08e20f
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Dec 30 12:57:04 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/b037d16612db0ee7d465bb3de1332d3a7b08e20f [^]

Fixes issue 28501: Window is property loaded having read only tabs

There was a problem in the way read only tabs were initialized. It was caused by this changeset [1], which fixed a problem related with read only tabs loaded lazily. The problem is that under some circumstances the setReadOnly function of the standard view was called without it being fully initialized. The setReadOnly invokation ended up calling the OBViewGrid.resetEmptyMessage function, and tried to execute this line:

this.view.parentView.isShowingTree

The problem is that the parentView property of the view was not set yet, so an error was thrown. To fix this, now the code to update some view properties based in its uiPattern value is executed after the parentView property is properly set.

[1] https://code.openbravo.com/erp/devel/pi/rev/052c07be4a9ddd2b2a61bd60e948370c53482cb4 [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0072875)
AugustoMauch (developer)
2014-12-30 13:06
edited on: 2014-12-30 13:06

Test plan:

- Test that [1], the issue whose fix caused this regression, is still not reproducible.
- Test that the current issue is not reproducible.
- Also test this to check that read only, lazy loaded tabs work properly:
* Open the Role window and choose one role
* Go to tab Window Access and select from example "Sales Order". Do not set it as Read Only
* Go to the Tab Access tab and set as Read Only three tabs: the header, the first child tab (both tabs will not be initialized lazily) and another child tab (that will be initialized lazily)
* Login as the role you selected in the previous step and check that the tabs configured as read only work as expected

[1] https://issues.openbravo.com/view.php?id=26660 [^]

(0072881)
dbaz (developer)
2014-12-30 15:34

Reviewed @ changeset: 25649 - 8cddfd318969
(0073278)
hudsonbot (developer)
2014-12-30 23:28

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-12-30 10:46 jecharri New Issue
2014-12-30 10:46 jecharri Assigned To => AugustoMauch
2014-12-30 10:46 jecharri Web browser => Google Chrome
2014-12-30 10:46 jecharri Modules => Core
2014-12-30 10:46 jecharri Regression level => Production - Confirmed Stable
2014-12-30 10:46 jecharri Regression introduced in release => 3.0PR14Q3
2014-12-30 10:46 jecharri Triggers an Emergency Pack => No
2014-12-30 12:00 AugustoMauch Web browser Google Chrome => Google Chrome
2014-12-30 12:00 AugustoMauch Regression date => 2014-05-22
2014-12-30 12:00 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/052c07be4a9ddd2b2a61bd60e948370c53482cb4 [^]
2014-12-30 12:47 AugustoMauch Issue Monitored: dbaz
2014-12-30 12:49 AugustoMauch Relationship added caused by 0026660
2014-12-30 12:57 AugustoMauch Review Assigned To => dbaz
2014-12-30 12:57 AugustoMauch Web browser Google Chrome => Google Chrome
2014-12-30 13:02 hgbot Checkin
2014-12-30 13:02 hgbot Note Added: 0072874
2014-12-30 13:02 hgbot Status new => resolved
2014-12-30 13:02 hgbot Resolution open => fixed
2014-12-30 13:02 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b037d16612db0ee7d465bb3de1332d3a7b08e20f [^]
2014-12-30 13:06 AugustoMauch Note Added: 0072875
2014-12-30 13:06 AugustoMauch Note Edited: 0072875 View Revisions
2014-12-30 15:34 dbaz Note Added: 0072881
2014-12-30 15:34 dbaz Status resolved => closed
2014-12-30 15:34 dbaz Fixed in Version => 3.0PR15Q1
2014-12-30 23:28 hudsonbot Checkin
2014-12-30 23:28 hudsonbot Note Added: 0073278
2014-12-30 23:39 eugeni Issue Monitored: eugeni
2015-01-13 09:05 alostale Relationship added related to 0024705


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker