Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037109
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2017-10-18 19:222018-01-03 12:38
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revision61c208f24417
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037109: Parent form shown in blank when direct opening a record in a child tab having parent tab configured as "Default Edit Mode"

DescriptionHaving a tab configured as "Default Edit Mode", when direct opening a record on a child tab, the viewForm in the parent is not being loaded. This causes that it is shown in blank.
Steps To Reproduce1) Open the [Client] window. The header and the "Information" tab of this window are both configured as "Default Edit Mode" in the AD.
2) Close it
3) On the "Recent Documents" section, click on the link that opens the "Information" subtab
4) Once the window is opened, collapse the child tab in order to see the header --> ERROR: it appears in blank (see attached image)
TagsNo tags attached.
Attached Filespng file icon blankForm.png [^] (85,881 bytes) 2017-10-18 19:22

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0037093 closedcaristu Wrong behavior after opening a record directly in a tab configured as "Default Edit Mode" 
related to design defect 0024705 closeddbaz The windows takes long to be loaed when there are a lot of tabs and a lot of columns on the grid. 

-  Notes
(0099968)
hgbot (developer)
2017-10-19 17:10

Repository: erp/devel/pi
Changeset: 61c208f24417048f932d615a6a54a63420679653
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Oct 19 16:51:23 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/61c208f24417048f932d615a6a54a63420679653 [^]

fixes bug 37109: Blank "Default Edit Mode" tab on direct child record opening

  Having a tab configured to be opened in edit mode by default, it was being shown in blank after direct opening a record present in one of its child tabs. The problem was that in such scenario the standard viewForm was not being loaded (prepared).

  To fix the problem when opening the child record, the parent tab is marked to force the opening of the parent record in form view once its data has arrived. Note that this is just done when the parent tab is configured to be opened in edit mode by default.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0100026)
alostale (developer)
2017-10-24 13:33

reviewed + tested
(0101339)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-10-18 19:22 caristu New Issue
2017-10-18 19:22 caristu Assigned To => platform
2017-10-18 19:22 caristu File Added: blankForm.png
2017-10-18 19:22 caristu Modules => Core
2017-10-18 19:22 caristu Triggers an Emergency Pack => No
2017-10-18 19:22 caristu Relationship added related to 0037093
2017-10-18 19:24 caristu Relationship added related to 0024705
2017-10-19 17:01 caristu Summary Parent form shown in blank when direct opening a record in a child tab having both tabs configured as "Default Edit Mode" => Parent form shown in blank when direct opening a record in a child tab having parent tab configured as "Default Edit Mode"
2017-10-19 17:01 caristu Description Updated View Revisions
2017-10-19 17:10 hgbot Checkin
2017-10-19 17:10 hgbot Note Added: 0099968
2017-10-19 17:10 hgbot Status new => resolved
2017-10-19 17:10 hgbot Resolution open => fixed
2017-10-19 17:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/61c208f24417048f932d615a6a54a63420679653 [^]
2017-10-19 17:11 caristu Assigned To platform => caristu
2017-10-19 17:11 caristu Review Assigned To => alostale
2017-10-24 13:33 alostale Note Added: 0100026
2017-10-24 13:33 alostale Status resolved => closed
2017-10-24 13:33 alostale Fixed in Version => 3.0PR18Q1
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101339


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker