Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0043175
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2020-02-10 19:322020-02-19 08:41
ReportershuehnerView Statuspublic 
Assigned Toalostale 
PrioritynormalResolutionfixedFixed in Version3.0PR20Q2
StatusclosedFix in branchFixed in SCM revision529930a409c4
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tojarmendariz
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2018-10-30
Regression introduced in release3.0PR19Q1
Regression introduced by commithttps://gitlab.com/openbravo/product/dbsm/-/commit/789aa22ca2be4190e5f07a4770c2172e0e5c0552 [^]
Triggers an Emergency PackNo
Summary

0043175: Update.database message about local changes in application dictionary is missing table name

DescriptionThe update.database mechanism to check for local changes consists of 2 parts:
a.) structure changes
b.) changes in AD

For part b.) the code did show the table having changes also but is no longer doing so -> Regression.

Checking code of code in dbsm-main repo OBDataset.java method hasChanged:
  if (log != null) {
              log.warn("Change detected in table: " + table.getName());

So issue could be either:
- logger being null (even if seems to be set in OBDBSMOBUtil.java)
- logger being not configured to show by default.
Steps To Reproduce1.) Have clean base (i.e. install.source or previous update.database ran)
2.) Cause local change in AD
update ad_window set updated=now() where ad_window_id = '100';
3.) Run update.database

4.) Check output missing info about table
     [java] 18844 [main] INFO org.openbravo.ddlutils.util.DBSMOBUtil - Checking if database structure was modified locally.
     [java] 19425 [main] INFO org.openbravo.ddlutils.util.DBSMOBUtil - Checking if data has changed in the application dictionary.
     [java] 19465 [main] ERROR org.openbravo.ddlutils.task.AlterDatabaseDataAll - Database has local changes. Update.database will not be done. You should export your changed modules before doing update.database, so that your Application Dictionary changes are preserved.
     [java] Database has local changes. Update.database not done.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00431803.0PR20Q1 closedalostale Update.database message about local changes in application dictionary is missing table name 
depends on backport 00431813.0PR19Q4.2 closedalostale Update.database message about local changes in application dictionary is missing table name 
depends on backport 00431823.0PR19Q3.4 closedalostale Update.database message about local changes in application dictionary is missing table name 
caused by feature request 0039504 closedjarmendariz Upgrade Log4j to version 2 

-  Notes
(0117615)
shuehner (administrator)
2020-02-10 19:34

Note: Issue is known present in:
- 19Q1
- pi (for 20Q2)

Given logger seems to be the issue maybe introduce in log4j2 project done in 19Q1 release.
(0117623)
alostale (developer)
2020-02-11 10:40

MR: https://gitlab.com/openbravo/product/dbsm/-/merge_requests/6 [^]
(0117897)
hgbot (developer)
2020-02-18 10:01

Repository: erp/devel/pi
Changeset: 529930a409c41bb08aeb21770481b842d815a704
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Feb 11 10:32:39 2020 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/529930a409c41bb08aeb21770481b842d815a704 [^]

fixed BUG-43175 fixed BUG-43183: log local changes + exclude .git

dsm jar including fixes for:

 BUG-43175:
  When updating database having local changes in AD, the tables with
  changes were not logged.

  While project to upgrade to log4j2 the API, old API passing old logger
  was kept but it become unusable as null logger was used.

  Old API has been removed.

 BUG-43183:
  Exclude .git directory when reading DB xml files

---
M src-db/database/lib/dbsourcemanager.jar
M src/org/openbravo/erpCommon/ad_forms/ModuleManagement.java
---
(0117936)
jarmendariz (developer)
2020-02-19 08:41

Reviewed

- Issue History
Date Modified Username Field Change
2020-02-10 19:32 shuehner New Issue
2020-02-10 19:32 shuehner Assigned To => platform
2020-02-10 19:32 shuehner Modules => Core
2020-02-10 19:32 shuehner Triggers an Emergency Pack => No
2020-02-10 19:34 shuehner Note Added: 0117615
2020-02-10 19:34 shuehner Regression level => Production - Confirmed Stable
2020-02-10 19:34 shuehner Regression introduced in release => 3.0PR19Q1
2020-02-11 10:23 alostale Regression date => 2018-10-30
2020-02-11 10:23 alostale Regression introduced by commit => https://gitlab.com/openbravo/product/dbsm/-/commit/789aa22ca2be4190e5f07a4770c2172e0e5c0552 [^]
2020-02-11 10:23 alostale Assigned To platform => alostale
2020-02-11 10:23 alostale Severity major => minor
2020-02-11 10:23 alostale Relationship added caused by 0039504
2020-02-11 10:38 alostale Review Assigned To => jarmendariz
2020-02-11 10:39 alostale Status new => scheduled
2020-02-11 10:40 alostale Note Added: 0117623
2020-02-18 10:01 hgbot Checkin
2020-02-18 10:01 hgbot Note Added: 0117897
2020-02-18 10:01 hgbot Status scheduled => resolved
2020-02-18 10:01 hgbot Resolution open => fixed
2020-02-18 10:01 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/529930a409c41bb08aeb21770481b842d815a704 [^]
2020-02-19 08:41 jarmendariz Note Added: 0117936
2020-02-19 08:41 jarmendariz Status resolved => closed
2020-02-19 08:41 jarmendariz Fixed in Version => 3.0PR20Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker